PDA

View Full Version : New to Crysis Beta. Graphics corruption??????????????


holdenb
10-19-07, 06:32 PM
Hi all

just bit the bullet & joined fileplanet again as sick of queuing for files

downloaded the Crysis beta & OMFG so much graphics corruption. Textures flashing....objects disappearing

I was running the latest official forceware the .71
but i have now installed the .76 beta driver

It is a bit better now but still occasional glitches.

Is this old news??
Anyone know what my problem is or any advice?

Thanks

wrathofgod
10-19-07, 06:37 PM
It's just loading the shaders. It will go away in a few minutes. It will happen the first time you load up Crysis and each time you make a graphics change.

nutcrackr
10-19-07, 06:39 PM
describe your corruption, there is some known issues but it shouldn't be much.

jAkUp
10-19-07, 06:49 PM
Make sure AA is set to application controlled.

SeriTonin
10-19-07, 06:56 PM
I had the same problem at first, I had to switch drivers....71's to the .76's fixed it for me.

holdenb
10-19-07, 07:20 PM
I had the same problem at first, I had to switch drivers....71's to the .76's fixed it for me.


I've got the .76's.....it has improved the problem but not solved completely.

As requested: the problem is hard to describe exactly but every now & again large objects are replaced by either a black gap....or a brightly coloured luminous uniform texture. This usually just flickers for a second then resolves.

agentkay
10-19-07, 07:33 PM
I'm using the .76 drivers and don't have such problems. Make sure AA, AF, V-sync (in the driver) are set to application-controlled. Once the shaders are compiled and cached (takes a minute or two) the flickering textures/corruption should be gone.

If it doesn't go away, you have most likely a memory leak in the shaders. Please file a bug in the bugtracker at the beta forums.

You can also try to disable the shader compiler by changing this line in the system.cfg

r_ShadersAsyncCompiling = 1

to

r_ShadersAsyncCompiling = 0

But remember the compiler is activated by default to find and report bugs/shader memory leaks in the first place. :)

holdenb
10-19-07, 09:06 PM
I'm using the .76 drivers and don't have such problems. Make sure AA, AF, V-sync (in the driver) are set to application-controlled. Once the shaders are compiled and cached (takes a minute or two) the flickering textures/corruption should be gone.

If it doesn't go away, you have most likely a memory leak in the shaders. Please file a bug in the bugtracker at the beta forums.

You can also try to disable the shader compiler by changing this line in the system.cfg

r_ShadersAsyncCompiling = 1

to

r_ShadersAsyncCompiling = 0

But remember the compiler is activated by default to find and report bugs/shader memory leaks in the first place. :)



thanks for that......I know this is a beta so isn't going to be perfect. I just wanted to check that it wasn't my system which was playing up!!