PDA

View Full Version : Crysis Problem x64 + DX10


Glitch85
10-28-07, 09:55 AM
Hi

When I try to start the game in 64 bit the first screen freezes, then if I try to remove all startup videos, it should jump direct into the menu, I see the menu and then it freezes.

In 32 bit it work great, but would be really great to try it in 64 bit.
I can only play the game in 64 bit if I use the 64bit sandbox 2 editor.

I use nvidia 169.01 driver + newest dx10 nov. update, all windows updates even those that is at nvidia for SLI etc. (not because im using SLI but the others in there)

My system: QX6700, Geforce 8800 GTX, 4 GB ram, Asus P5B-E Plus, Windows Vista Business x64

Brent101
10-28-07, 10:21 AM
Hi Glitch85,

Don't worry, it is not just you. Everyone seems to be experiencing difficulties with playing Crysis in 64bit right now.

JaylumX
10-28-07, 11:04 AM
I don't have any problems playing Crysis in 64bit mode with the DX110 tweaks in DX9 mode. I am running 64bit mode via a shortcut pointing to the bin64 folder.

Buio
10-28-07, 11:12 AM
It worked well with x64 and the previous release driver. After installing the new 169.01 driver it started locking up. So its a driver bug or some sort of conflict introduced with the new one.

JaylumX
10-28-07, 12:59 PM
I am using the 169.01 drivers and I have no problems running in 64bit.

Riplayne
10-28-07, 01:59 PM
Downgrade the drivers, I ran into the issue when I installed the newest Beta 64 bit drivers.

Glitch85
10-28-07, 03:38 PM
I searched on incrysis forums someone tried to force crysis.exe with vsync either on or off in nvidia control panel, actually that solved 1 problems except that after 5 secs ind the menus the 1000 colored dot screen came up and I need to reinstall both drivers and crysis demo in order for me to play even the 32bit again :(, I really think those new drivers have a very big problem, cause I have noticed som strange manu crashes with hellgate london dx10 beta also :(

Those of you that have same 64bit crysis problem, could you try out vsync trick and see if it works ?

Tygerwoody
10-28-07, 05:47 PM
*shocked* This can't be right. Everyone KNOWS that 64bit operating systems are the most stable things on the planet!

gulizard
10-28-07, 05:50 PM
I searched on incrysis forums someone tried to force crysis.exe with vsync either on or off in nvidia control panel, actually that solved 1 problems except that after 5 secs ind the menus the 1000 colored dot screen came up and I need to reinstall both drivers and crysis demo in order for me to play even the 32bit again :(, I really think those new drivers have a very big problem, cause I have noticed som strange manu crashes with hellgate london dx10 beta also :(

Those of you that have same 64bit crysis problem, could you try out vsync trick and see if it works ?

It does work.

FearMeAll
10-28-07, 05:53 PM
It worked well with x64 and the previous release driver. After installing the new 169.01 driver it started locking up. So its a driver bug or some sort of conflict introduced with the new one.
I had the same problem with lockups with the 169.01 drivers..in fact about all my games would lock up after these drivers..odd because so many have had success with them..I just went back to the old ones. We will all have new whql drivers before long..at least by novermber 16th ;)

methimpikehoses
10-30-07, 03:12 AM
Vsync OFF in global settings. (And it bumped me 10FPS... the number in the pic is the result of windowed mode.)

http://i156.photobucket.com/albums/t36/methimpikehoses/crysisdx1064.jpg?t=1193728304

[EOCF] Tim
10-30-07, 08:16 AM
Remember to also put display in single monitor performance mode,unfortunately forcing Vsync seems to kills fps, but from these benches, 32Bit is faster, but we'll see how it works when forcing Vsync isn't necessary.

Forceware 169.01
Windows Vista 64bit

1680x1050, No AA

All settings on Very High, except Shaders and Shadows, which are set to High.

Q6600 G0 : (1600)x9 : 3.6Ghz 1.5v
Corsair 2Gb : Dram 800Mhz 4-3-3-12-2T 2.1v
8800 GTX : 612 - 1500 - 2000Mhz


32Bit CPU Bench


Min : 12.30 - Max : 28.94 - Average : 22


32Bit GPU Bench


Min : 18.96 - Max : 28.94 - Average : 24


-----------------------------------------------------------------------


64Bit CPU Bench


Min : 8.58 - Max : 30.74 - Average : 21


64Bit GPU Bench


Min : 5.63 - Max : 28.94 - Average : 24

Gaco
10-30-07, 09:59 AM
Vsync OFF in global settings. (And it bumped me 10FPS... the number in the pic is the result of windowed mode.)

http://i156.photobucket.com/albums/t36/methimpikehoses/crysisdx1064.jpg?t=1193728304
Wow thanks dude how did you figure that!? :D

I've now updated my indepth crysis DX9/DX10 comparison archive with some 64bit vs. 32bit pictures: http://www.nvnews.net/vbulletin/showthread.php?t=101256

brett01
10-30-07, 10:03 AM
Wow thanks dude how did you figure that!? :D

I've now updated my indepth crysis DX9/DX10 comparison archive with some 64bit vs. 32bit pictures: http://www.nvnews.net/vbulletin/showthread.php?t=101256

Im confused right now!!!

http://www.legionhardware.com/Bench/Crysis_Demo_Performance/32bit_vs_64bit.png

Looking at this I thought of installing vista 64 bit edition but now???Any one help

me which is better???

Gaco
10-30-07, 10:22 AM
BTW there is a profile for Crysis in the 169.01's, it is an easier and better solution to just force the v-sync off in Crysis, not globally.

brett01 your image is a red cross ;)

brett01
10-30-07, 10:30 AM
BTW there is a profile for Crysis in the 169.01's, it is an easier and better solution to just force the v-sync off in Crysis, not globally.

brett01 your image is a red cross ;)
So you say me to install 64bit version????

Gaco
10-30-07, 11:03 AM
So you say me to install 64bit version????
No comprendo. What do you mean?

methimpikehoses
10-30-07, 12:54 PM
Wow thanks dude how did you figure that!? :D



I didn't figure it out... I read it in a Crysis SP review. :o

And of course you don't need to turn it off globally, just in a profile. I turned my gamma correction off as well, and that seemed to help framerate too. ;)

edit: looks like the new drivers fixed it anyway. 169.04s

methimpikehoses
10-30-07, 12:55 PM
So you say me to install 64bit version????

If you are running Vista x64, then just go to games, and right click the Crysis icon and scroll down to dx10 mode.

=DX10 64bit

Glitch85
10-30-07, 05:12 PM
Woohoo the new 169.04 beta driver seems to fix all the crash problems I have had bot hellgate london and crysis :D.

I really cant see any performance difference between the 32 bit and 64bit version of crysis have arround the same fps no matter what version I play.