PDA

View Full Version : I Need Help


nV`andrew
01-26-08, 02:18 PM
:headexplode:

Alright, so I accidentally updated a driver without looking at it close enough, so now Windows is only recognizing one core on my processor. (In CPU-Z and on the task manager)

I believe it was the ACPI driver

Is there anyway to go back, or is there a different driver i can still install?
Would system restore work?
I can backup all my stuff and reinstall windows but i really dont want to. Could i just reinstall the core/system files?

thanks

Drolfrawd
01-26-08, 02:21 PM
:headexplode:

Alright, so I accidentally updated a driver without looking at it close enough, so now Windows is only recognizing one core on my processor. (In CPU-Z and on the task manager)

I believe it was the ACPI driver

Is there anyway to go back, or is there a different driver i can still install?
Would system restore work?
I can backup all my stuff and reinstall windows but i really dont want to. Could i just reinstall the core/system files?

thanks

Maybe I,m being simplistic but uninstall the bad driver
/ or system restore

nV`andrew
01-26-08, 02:23 PM
Maybe I,m being simplistic but uninstall the bad driver
/ or system restore

I tried going back to the 'Standard PC' driver (My Computer>Properties>Hardware) but i still only see one core in cpu-z

Drolfrawd
01-26-08, 02:28 PM
I tried going back to the 'Standard PC' driver (My Computer>Properties>Hardware) but i still only see one core in cpu-z


What driver did you update? Ill find solution for you hoprfully.

nV`andrew
01-26-08, 02:33 PM
What driver did you update? Ill find solution for you hoprfully.

Thanks for the help.

I went to My Computer>Properties>Hardware/Devices>Device Manager
Then i went to Computer and updated the driver to one of the ACPI Power interface drivers, and now im back to Standard PC drivers, although now two are showing up. :thumbdwn:

Drolfrawd
01-26-08, 02:43 PM
Thanks for the help.

I went to My Computer>Properties>Hardware/Devices>Device Manager
Then i went to Computer and updated the driver to one of the ACPI Power interface drivers, and now im back to Standard PC drivers, although now two are showing up. :thumbdwn:


Try this , go to device manger again and select the the computer icon , click on the + sign and then right click the acpi driver , a new screen will appear. Select the driver tab , and then driver details, this will now give you somme choices of driver to use.

I think it should be :\Windows\system32\hal.dll.
Restart your machine. To check it is working bring up the task manager and click the performance tab , you should see both your cpu's there .

Try it and let me know

nV`andrew
01-26-08, 02:49 PM
Well like i said I went back to the Standard PC drivers(I am no longer on the ACPI, but thats what i originally updated to) thinking that would fix it. So under the computer tab, there are TWO Standard PC drivers, and for one of them and icon comes up at the top to uninstall, should i do this?

Thanks

Drolfrawd
01-26-08, 03:05 PM
Well like i said I went back to the Standard PC drivers(I am no longer on the ACPI, but thats what i originally updated to) thinking that would fix it. So under the computer tab, there are TWO Standard PC drivers, and for one of them and icon comes up at the top to uninstall, should i do this?

Thanks


Yes do that , and then check for result..Also in device manager check on the processer tab that both cores are showing, if not uninstall , in fact do that anyway.
If that doesn't work try this

I’d like to suggest you initialize the ACPI driver from Installation CD:

EDIT: The other thing you might do is bring up a command promt and type sfc /scannow with you install cd/dvd in the drive. Will compare any missing or damged sys files and update to proper version.

1. Navigate to “Control Panel”, choose “Device Manager”.

2. Select “Computer” – “Advanced Configuration and Power Interface (ACPI) PC”.

3. Click “Driver” tab and choose “Update Driver”

4. Select “Browse my computer for driver software” – specify your DVD drive location

5. Search and update the ACPI driver.





For the Dual Core CPU issue, please run “msconfig”, choose “Boot” tab, select “Advanced Option”, make sure the “number of processors” has been set to “2”

EDIT: Other thing i thought maybe to try if the above don't work is, bring a command prompt and type sfc /scannow with your install cd/dvd in the drive , compares damaged or missing sys files

nV`andrew
01-26-08, 05:32 PM
Will try this in a bit, thanks so far

XDanger
01-28-08, 08:40 PM
no roll back?

mezkal
01-28-08, 09:00 PM
The various HAL (hardware abstraction layer) kernels to be loaded and their options can be selected at boot time via the boot.ini. There's no need to go through the tedious (and generally unsuccessful) driver installation route.

detailed guide with sample boot.ini files : http://www.vernalex.com/guides/sysprep/hal.shtml

simpler guide : http://www.leinss.com/twohals.htm

detailed breakdown of boot.ini : http://support.microsoft.com/kb/833721

Note : make sure the /onecpu switch isn't there in your boot.ini as that forces Windows to only see one core/cpu regardless of the HAL that's been loaded.

I used to do this to switch between ACPI and APIC back when I had Nforce2 mobos to get rid of IRQ conflicts to make SoundStorm work properly (SS hated APIC due to crappy microcode bugs that never got fixed - made all devices cascade IRQs through IRQ 11, worked fine in ACPI though)