PDA

View Full Version : Random Why Question About Windows


six_storm
02-19-08, 09:41 AM
Over my fast time, I had built a computer for my buddy. He needed a new machine that would blaze through Photoshop. Well, one of the things he bought was a new Wireless N router and wireless card for his workstation. Wireless N is crazy fast!

However, I tried to setup a shared folder on his old laptop so transfer some stuff to his new workstation. You set both to the same workgroup name, make a folder, right click to share, and restart them. Well, none of the computers would recognize each other on the network!

Why does Windows do that? I thought that all you had to do is have 2 computers in the same workgroup with at least one shared folder a piece? Can anybody explain that to me?

DRen72
02-19-08, 10:42 AM
I know that for "N" to work you will have to install extra drivers / software since the OS won't recognize the "N" standard. I know that Vista SP1 brings built-in "N" to the OS. I imagine that XP SP3 will also. So, was the proper software / hardware support installed?

conroejoe
02-19-08, 10:54 AM
Over my fast time, I had built a computer for my buddy. He needed a new machine that would blaze through Photoshop. Well, one of the things he bought was a new Wireless N router and wireless card for his workstation. Wireless N is crazy fast!

However, I tried to setup a shared folder on his old laptop so transfer some stuff to his new workstation. You set both to the same workgroup name, make a folder, right click to share, and restart them. Well, none of the computers would recognize each other on the network!

Why does Windows do that? I thought that all you had to do is have 2 computers in the same workgroup with at least one shared folder a piece? Can anybody explain that to me?


I picked up the Dlink 655 recently with gigabit switch and N. Friday I grabbed an N card, 300 MB/sec where before my G was always "very low" is awesome!! No more disconnects, been connected 5 days straight and I'm about 40 feet away from the router on another floor with my laptop and the signal strength is 100%.

Anyways, your process for sharing folders is correct with XP. Just right click and share the folder (you dont even restart unless you changed the workgroup names). On the other PC goto network places and they will show up, you might have to browse the network, but mine just show up. In Vista however I still cannot share a folder I can write to. So if you are using XP you are doing it correctly. If you are using Vista - you are still doing it correctly, it just doesn't work. I've read multiple guides on how to do this and in the comments people still cannot get Vista to work. Make sure to disable firewalls, etc.

Maybe someone here can help to get it working with Vista, I put too much time in trying and never got it to work but everything I have I share from my XP server so doing it that way I dont have an issue. Trying to open up a shared folder on Vista that is actually writable has never worked for me, I always get permission errors even with all permissions wide open in Vista on that folder.

six_storm
02-19-08, 11:16 AM
I know that for "N" to work you will have to install extra drivers / software since the OS won't recognize the "N" standard. I know that Vista SP1 brings built-in "N" to the OS. I imagine that XP SP3 will also. So, was the proper software / hardware support installed?

Yeah, everything was installed correctly. I really like how Linksys does their setup, very quick and easy. It's just that between two XP computers, they couldn't see each other (minus pinging each other).

Weird . . .

conroejoe
02-19-08, 11:19 AM
Yeah, everything was installed correctly. I really like how Linksys does their setup, very quick and easy. It's just that between two XP computers, they couldn't see each other (minus pinging each other).

Weird . . .


Disable the XP firewall on both machines then. make sure no IPs are static'd and on a different subnet. Should work just fine. I didnt have to do anything other than install drivers for the N card, everything works the same.

nekrosoft13
02-19-08, 11:28 AM
vista is much easier to share folders, i remember in xp often when guess acount was active, sharing didn't work.

conroejoe
02-19-08, 03:48 PM
vista is much easier to share folders, i remember in xp often when guess acount was active, sharing didn't work.


I dont know how, there are many guides on how to share. Many comments from people that can't get it to even work.

Post some instructions on how to share a writable folder off a Vista machine. I can get it shared I cannot make it so that I can write to it from another machine.

conroejoe
02-20-08, 01:31 AM
I was hoping you would've posted something by now. I thought sharing was easy in Vista? Should be easy to put up some instructions.


Even this doesn't work -
http://www.howtogeek.com/howto/windows-vista/how-to-share-a-folder-the-xp-way-in-windows-vista/

WTF, its impossible to share a folder in Vista.

RAY16
02-20-08, 02:08 AM
File sharing works fine for me. The other computers on my network run WinXP.

O_o

nekrosoft13
02-20-08, 07:46 AM
I was hoping you would've posted something by now. I thought sharing was easy in Vista? Should be easy to put up some instructions.


Even this doesn't work -
http://www.howtogeek.com/howto/windows-vista/how-to-share-a-folder-the-xp-way-in-windows-vista/

WTF, its impossible to share a folder in Vista.

is this a race or something? you seriously need a guide? right click on folder, go to share, set permissions and enable share.

conroejoe
02-20-08, 09:39 AM
is this a race or something? you seriously need a guide? right click on folder, go to share, set permissions and enable share.


yea, that doesnt work lol I didn't need a guide with XP, but Vista sharing just doesn't work right.

READ - READ - READ. I already stated this. I can see the folder in my network but if I try to write to it I always get write permission errors even with everyone having read and write set. Seriously sharing in XP worked, it doesn't even work sharing a Vista folder and writing to it from an XP machine. LOL!

I have tried that way and right clicking the folder, properties, sharing, share and set permissions. Neither way works I can see it, but I can't actually drop any files into it.


Good thing XP works fine I can share from my server and it works flawlessly still. I just wanted to figure out how to get sharing working in Vista.

ViN86
02-20-08, 12:35 PM
Over my fast time, I had built a computer for my buddy. He needed a new machine that would blaze through Photoshop. Well, one of the things he bought was a new Wireless N router and wireless card for his workstation. Wireless N is crazy fast!

However, I tried to setup a shared folder on his old laptop so transfer some stuff to his new workstation. You set both to the same workgroup name, make a folder, right click to share, and restart them. Well, none of the computers would recognize each other on the network!

Why does Windows do that? I thought that all you had to do is have 2 computers in the same workgroup with at least one shared folder a piece? Can anybody explain that to me?
why didnt you just share the folder then map it using the name of the computer? prevents having to go through the whole network setup wizard.

ViN86
02-20-08, 12:36 PM
yea, that doesnt work lol I didn't need a guide with XP, but Vista sharing just doesn't work right.

READ - READ - READ. I already stated this. I can see the folder in my network but if I try to write to it I always get write permission errors even with everyone having read and write set. Seriously sharing in XP worked, it doesn't even work sharing a Vista folder and writing to it from an XP machine. LOL!

I have tried that way and right clicking the folder, properties, sharing, share and set permissions. Neither way works I can see it, but I can't actually drop any files into it.


Good thing XP works fine I can share from my server and it works flawlessly still. I just wanted to figure out how to get sharing working in Vista.
Vista sharing has more permissions that's all. you need to enable logins without passwords in your network settings. otherwise, you will need to use the login username/password on the vista machine to view the file.

go to the Network and Sharing Center and expand the Public folder sharing section. then select "Turn on sharing so anyone with network access can open, change, and create files". then expand the "Password protected sharing" tab and select "Turn off password protected sharing". then share the folder, make sure the permissions are set so anyone can view the folder, and connect to the computer from the Run bar using \\IP_OF_TARGET_COMPUTER or \\WINDOWS_COMPUTER_NAME

take 2 pills and call me in the morning. :p

Bearclaw
02-20-08, 12:44 PM
WTF, its impossible to share a folder in Vista.

I would disagree. I used vista for a solid 9 months before going back to XP and I think vista takes file sharing to a whole new level. I mean, it is a lot easier to configure and use. With XP, it is a bit more tedious.

conroejoe
02-20-08, 01:21 PM
Vista sharing has more permissions that's all. you need to enable logins without passwords in your network settings. otherwise, you will need to use the login username/password on the vista machine to view the file.

go to the Network and Sharing Center and expand the Public folder sharing section. then select "Turn on sharing so anyone with network access can open, change, and create files". then expand the "Password protected sharing" tab and select "Turn off password protected sharing". then share the folder, make sure the permissions are set so anyone can view the folder, and connect to the computer from the Run bar using \\IP_OF_TARGET_COMPUTER or \\WINDOWS_COMPUTER_NAME

take 2 pills and call me in the morning. :p


I still get permission errors if I try to write a file to it though. Already tried that.

conroejoe
02-20-08, 01:22 PM
I would disagree. I used vista for a solid 9 months before going back to XP and I think vista takes file sharing to a whole new level. I mean, it is a lot easier to configure and use. With XP, it is a bit more tedious.


I really cant see how you guys think Vista is easier. XP was like 2 clicks, right click share, Just enable file sharing and it was done. Thats much easier than ****ing with permissions in Vista which never work right.

six_storm
02-20-08, 03:26 PM
why didnt you just share the folder then map it using the name of the computer? prevents having to go through the whole network setup wizard.

Who says I went through a wizard? When you have two computers on the same workgroup, you should be able to go to "Network" and you should see the other computer. In my case, it wasn't working so well.

nekrosoft13
02-20-08, 03:44 PM
did you have file and printer sharing enabled in network?

six_storm
02-20-08, 05:53 PM
did you have file and printer sharing enabled in network?

Yuppers! :D

yehuda
02-20-08, 11:03 PM
Maybe you guys have changed some services to be on manual/disabled?

Drolfrawd
02-21-08, 04:48 PM
Don't have time to read the thread, but one thing you must have is the Administrators password must be the same on both machines , when sharing in a work group.Also for info , get rid of simple file sharing , then you can use permisions and Ntfs permissions. add the user and the machine to the folder in question like this


machinename\joebloggs

and enter the admin password .
or you could map the folder as a drive

Gorion
02-22-08, 11:51 AM
Joe it sounds like your password protected sharing is on.

Go to "Netwok and Sharing" in your control panel and turn off "password protected sharing"

Gorion
02-27-08, 10:54 AM
Did you try my suggestion joe?

ViN86
02-27-08, 11:54 AM
Vista sharing has more permissions that's all. you need to enable logins without passwords in your network settings. otherwise, you will need to use the login username/password on the vista machine to view the file.

go to the Network and Sharing Center and expand the Public folder sharing section. then select "Turn on sharing so anyone with network access can open, change, and create files". then expand the "Password protected sharing" tab and select "Turn off password protected sharing". then share the folder, make sure the permissions are set so anyone can view the folder, and connect to the computer from the Run bar using \\IP_OF_TARGET_COMPUTER or \\WINDOWS_COMPUTER_NAME

take 2 pills and call me in the morning. :p

I still get permission errors if I try to write a file to it though. Already tried that.



Joe it sounds like your password protected sharing is on.

Go to "Netwok and Sharing" in your control panel and turn off "password protected sharing"

.

Gorion
02-27-08, 02:55 PM
Sorry Vin I didn't mean to repeat you. I didn't read all of your post. I'm such a loser. I'm going out back to flog myself. now I'll be back in say half an hour :D