PDA

View Full Version : DirectDraw/AGP problem (long)


shombre
04-29-03, 09:24 AM
Hi, I'm wondering if anybody could throw some ideas my way.

A friend has a completely stock P4 2.0, 100mhZ FSB, 512Mb RAM on an Sis645 chipset with a (completely stock) HiS 64Mb GeForce4MX440, running WinXP Home. On board audio. As far as I can tell all recent WinXP updates seem to have been installed. He was recently using Detonator 41.xx. DirectX 9.0a was installed and was working fine.

Just recently, out of the blue, his games started to tell him that there was "no 3D card present". DXDIAG revealed DirectDraw and AGP Texture acceleration to be "unavailable", and the amount of VRAM detected as "N/A". Direct3D acceleration (for DX8 and DX9) work. OpenGL games now come up with the infamous "Cannot load subsystem". The only event of note was the installation of a USB webcam a few days beforehand - but it worked fine to begin with ! Initially he tried to use XP's "rollback driver" option - to no avail. :confused:

I tried the following :-
a) Manually reinstalling Detonator drivers (older versions plus the 41.xx series) - I used DriverCleaner in between installations, and made sure that XP's ghey System File Protection didn't interfere.

b) Installing the latest AGP drivers from SiS' website prior to above installation

c) Reinstalling DirectX9

d) Going through MSInfo to ID any conflicts - the AGP's IRQ is shared with the NIC, that's it, and always has been AFAIK.

e) Physically inspecting the card - no visible damage; no artifacts on boot or in the GUI environment.

The things I couldn't get to see were the AGP driving value, AGP aperture size or AGP speed - there is no "Advanced Chipset Features" tab in his Award BIOS setup. However these haven't been consciously altered by him, and the card worked beautifully until three days ago.

Short of reinstalling XP, is there anything else to try ? Any advice would be appreciated !

Sorry if this isn't in the right place, but I'm not sure where the problem lies :(

shombre
04-29-03, 06:52 PM
Disabling Microsoft NetMeeting made it all come good. I'm not sure why, but if anybody else has this problem that may be something to try.

Thanks to those who read this msg, anyway. :D