PDA

View Full Version : Win XP/SP-2 x64 failed to update from MS


NaAZoOR
03-13-08, 08:19 PM
I've been using XP/SP-2 x64 for about 5 months now, it was pretty good and every thing was ok including updating OS from Microsoft by the update link (don't like to use automatic updates). till it start fo fail communicating with the server every time i try to update a month ago.

every time i went to update page it starts to check for available updates , then it shows a silly NON CODED error message that:

Windows Update has encountered an error and cannot display the requested page

pics here show the steps:

http://img299.imageshack.us/img299/1579/updterrfb7.jpg

then

http://img368.imageshack.us/img368/2972/updatefailurehy7.jpg

i tried a lot of things but all failed.

P.S: i tried to use Firefox .. but the same error showed up.
any suggestions??

nekrosoft13
03-13-08, 08:36 PM
1) uninstall windows update activex from your PC
2) temporary disable automatic update service.
3) delete this folder C:\Windows\SoftwareDistribution (note this folder can only be deleted when automatic update is turned off)
4) re-enable automatic updates service

AthlonXP1800
03-13-08, 08:44 PM
You used XP for 5 months? That very odd with outdated Windows Update v4, it should be updated to latest v6 automatically.

If everything didnt worked nekrosoft13 suggested then try click below:

http://www.update.microsoft.com/microsoftupdate/v6

NaAZoOR
03-14-08, 10:19 PM
AthlonXP1800:

i did the following advice the went to the url u gave me after doing the next step & it works really fine ... thx.

This is a stupid bug that MS has so far not fixed. None of the fixes they suggest work. Anyway, do the following:

Go to the following key

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet
Settings\

Look for the key User Agent and delete the whole key. NOT a string, the whole key. Windows update will now work.

BTW, this key may re-appear and Windows Update will again fail, so it is best to bookmark the reg location.

nekrosoft13:

thx for effort.

Dragunov
03-16-08, 10:10 AM
In the URL, change the 4 to 6 and hit enter :)

Drolfrawd
03-16-08, 04:14 PM
You're Doing it wrong