PDA

View Full Version : Can't open C: drive


Capt. Picard
05-08-08, 10:04 AM
I ran a AVG on a computer and now afterwards I can't open the C: drive. If I doubleclick on it, it only gives me the options, like when you right-click and select 'open with'.

How do I fix this.

nekrosoft13
05-08-08, 10:09 AM
stop erasing stuff from registry ;)

not sure how much you erased.

but this should help (again, if you erased more than this, then you might need more code)

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Drive]
@="Drive"
"EditFlags"=dword:000001d2

[HKEY_CLASSES_ROOT\Drive\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00 ,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00 ,32,00,5c,00,73,00,68,00,\
65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c ,00,2c,00,38,00,00,00

[HKEY_CLASSES_ROOT\Drive\shell]
@="none"

[HKEY_CLASSES_ROOT\Drive\shell\find]
"SuppressionPolicy"=dword:00000080

[HKEY_CLASSES_ROOT\Drive\shell\find\command]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00 ,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,45,00,78,00,70,00,6c,00,6f,00,72,00,65,00 ,72,00,2e,00,65,00,78,00,\
65,00,00,00

[HKEY_CLASSES_ROOT\Drive\shell\find\ddeexec]
@="[FindFolder(\"%l\", %I)]"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\Drive\shell\find\ddeexec\applica tion]
@="Folders"

[HKEY_CLASSES_ROOT\Drive\shell\find\ddeexec\topic]
@="AppProperties"

[HKEY_CLASSES_ROOT\Drive\shellex]

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s]

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\LDVPMenu]
@="{BDA77241-42F6-11d0-85E2-00AA001FE28C}"

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\Offline Files]
@="{750fdf0e-2a26-11d1-a3ea-080036587f03}"

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\Sharing]
@="{f81e9010-6ea4-11ce-a7ff-00aa003ca9f6}"

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\{59099400-57FF-11CE-BD94-0020AF85B590}]

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\{5E44E225-A408-11CF-B581-008029601108}]
@="Roxio DragToDisc Shell Extension"

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\{D6791A63-E7E2-4fee-BF52-5DED8E86E9B8}]
@="Portable Devices Menu"

[HKEY_CLASSES_ROOT\Drive\shellex\ContextMenuHandler s\{fbeb8a05-beee-4442-804e-409d6c4515e9}]
@=""

[HKEY_CLASSES_ROOT\Drive\shellex\CopyHookHandlers]

[HKEY_CLASSES_ROOT\Drive\shellex\CopyHookHandlers\R oxio DragToDisc Shell Extension]
@="{5E44E225-A408-11CF-B581-008029601108}"

[HKEY_CLASSES_ROOT\Drive\shellex\DragDropHandlers]

[HKEY_CLASSES_ROOT\Drive\shellex\DragDropHandlers\W inRAR]
@="{B41DB860-8EE4-11D2-9906-E49FADC173CA}"

[HKEY_CLASSES_ROOT\Drive\shellex\DragDropHandlers\W inZip]
@="{E0D79305-84BE-11CE-9641-444553540000}"

[HKEY_CLASSES_ROOT\Drive\shellex\DragDropHandlers\{ 5E44E225-A408-11CF-B581-008029601108}]
@="Roxio DragToDisc Shell Extension"

[HKEY_CLASSES_ROOT\Drive\shellex\FolderExtensions]

[HKEY_CLASSES_ROOT\Drive\shellex\FolderExtensions\{ fbeb8a05-beee-4442-804e-409d6c4515e9}]
@=""
"DriveMask"=dword:00000020

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers]

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\Sharing]
@="{f81e9010-6ea4-11ce-a7ff-00aa003ca9f6}"

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\{1F2E5C40-9550-11CE-99D2-00AA006E086C}]

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\{596AB062-B4D2-4215-9F74-E9109B0A8153}]
@=""

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\{5E44E225-A408-11CF-B581-008029601108}]
@="Roxio DragToDisc Shell Extension"

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\{7988B573-EC89-11cf-9C00-00AA00A14F56}]
@=""

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\{ECCDF543-45CC-11CE-B9BF-0080C87CDBA6}]

[HKEY_CLASSES_ROOT\Drive\shellex\PropertySheetHandl ers\{fbeb8a05-beee-4442-804e-409d6c4515e9}]
@=""

nekrosoft13
05-08-08, 10:10 AM
that code is from work, i just noticed, if you don't have roxio, winzip and winrar, erase those references

Capt. Picard
05-08-08, 10:27 AM
What do I do with that ^^

nekrosoft13
05-08-08, 10:31 AM
open notepad, paste that in

and save as .reg file, then double click on .reg file, it will ask you if you want to import.

for it to take effect you will have to restart the explorer.exe or reboot pc.

Capt. Picard
05-08-08, 10:43 AM
sorry, doesn't work.

This is the situation.
By some one else. Is there like a autorun.inf in the root of c drive?

No there isn't now one but there could have been one before I ran AVG 8 earlier today. The problem is I also ran CCleaner's registry checker and deleted a bunch of reg entries that the program identified as "problems". Only after this did this problem started. The program though does cater for you to make backup copies of those entries. However, even after I reinstalled those entries the problem is still there.

nekrosoft13
05-08-08, 10:47 AM
c driver never have autorun.inf by default, end user can could add one for some dumb reason, but you never need one.

autorun.inf holds info what to do when you plug in a drive to already running PC

if that solution, didn't work then you must have deleted more stuff from the registry


btw, that is what i posted
http://img30.picoodle.com/img/img30/4/5/8/f_untitledm_3ec677f.jpg
c drive is not an extension, but is treated the same way.

npras42
05-08-08, 12:05 PM
stop erasing stuff from registry ;)

not sure how much you erased.

but this should help (again, if you erased more than this, then you might need more code)


What makes you think he's deleted part of his registry??? He doesn't say that anywhere, does he?

nekrosoft13
05-08-08, 12:31 PM
What makes you think he's deleted part of his registry??? He doesn't say that anywhere, does he?

well someone or something did. you can also delete part of registry and exe files won't open

mailman2
05-08-08, 01:30 PM
Ive had strange issues with AVG blocking folders and files - try uninstalling AVG and see what happens.

Capt. Picard
05-08-08, 05:42 PM
What makes you think he's deleted part of his registry??? He doesn't say that anywhere, does he?

It's a bit confusing because I placed quote marks around it a couple of posts up, but this is basically what I did. I said this in reaction to someone else's statement in another forum.

No there isn't now one but there could have been one before I ran AVG 8 earlier today. The problem is I also ran CCleaner's registry checker and deleted a bunch of reg entries that the program identified as "problems". Only after this did this problem started. The program though, does allow for you to make backup copies of those entries BEFORE it is delted. However, even after I reinstalled those entries the problem is still there.

npras42
05-08-08, 06:54 PM
Have you uninstalled AVG now? You probably should to see if its fixes it (though unlikely). Also its a common side-effect of viruses/malware to have that kind of effect so maybe try a malware cleaner of some description. I haven't used one since upgrading to Vista so I can't really recommend one.