PDA

View Full Version : GF4 "use video adapter scaling" and getting rid of bilinear scaling?


subbo
05-07-03, 12:52 PM
Hi.

I recently bought a Formac Gallery 2010 20.1" TFT with a DVI connection and a native resolution of 1600x1200. I plugged it to my Asus GF4 Ti4200 and it works and looks amazing.. one MAJOR gripe though:

The Nvidia detonators dont let me choose the option to use the display's internal scaling (if such exists), and the GF4's own scaling (in the drivers?) uses EYE-BLEEDING bilinear filtering even for 800x600 which is exactly half the native resolution of 1600x1200.

I want to use "nearest neighbor" scaling for 800x600 or optionally ALL windows resolutions.. is there a registry or driver tweak to do this? There is the option to "center picture" in the drivers but no way to choose whether it uses bilinear or not.

Thanks!

omv
05-08-03, 09:19 PM
I'm going from memory since I'm not in front of my machine, but from the nView Display mode, you should be able to select "Screen Adjustment" and switch between "adapter scaling", "center", and "monitor scaling".

I have mine set to monitor scaling, and get the expected behavior. Can't verify what happens with adapter scaling, since my adapter won't put out native resolution correctly.

subbo
05-09-03, 04:53 PM
For me the "use monitor scaling" option is greyed out.. sometimes its ticked AND greyed out, leaving the center and video adapter scaling options unticked.. weird.

Anyway I can't really choose monitor scaling manually.

I'll try the display in another computer (with the same kind of Asus V8420 GF4 Ti4200 card) tomorrow to see if it's the same behavior.

PS. For those wondering/having no clue about this; I want to see a double pixel-size 800x600 scaled up to 1600x1200 and not a bilinear/bicubic filtered blurry nastiness. If you want to demonstrate it for yourself, take a screenshot (PRNT SCRN) at 800x600 go to eg Photoshop and paste it there. Then enlarge it to 1600x1200 = eye-bleeding blur. Now, undo that step, choose Image -> Image Size again, then select Nearest Neighbor on the "Resample Image" slot, click OK = Nice clean double sized pixels.

omv
05-09-03, 05:09 PM
So, I just tested this on my laptop GF4Go - like your setup, monitor scaling is greyed out. However, I definitely just get pixel-doubling at 800x600 - just tested it.

Unfortunately, I can't verify my GF4200 behaves the same way, since adapter scaling isn't really an option on my desktop display due to the resolutions involved.

subbo
05-12-03, 03:30 PM
Dang, and I dont have any other DVI-cards than these two GF4 to test with. It's not such a big deal only that some games that have 800x600 menus (bf1942) or can't go any higher during gameplay would look much clearer.

Thanks for the insight though.

omv
05-13-03, 12:41 AM
Check out the new 44.03 drivers - there's some new options in the device adjustments - might work better.

subbo
05-17-03, 11:45 AM
Thanks for the tip!

The new option specificly is "fixed aspect ratio scaling" which means good news for people with 1280x1024 resolution displays (which is not a 4:3 resolution in itself) and games like BF1942 with an option only for 1280x960, this leaves black bars on the top and bottom without ugly bilinear stretching.

The new 44.03 didn't fix my scaling problem, it still uses interpolated scaling, but seems quite a bit sharper than before, more like bicubic. 800x600, 1024x768 (especially) and 1280x960/1024 seem alot more usable now with 44.03.

It's good to see some movement in the tft-support department on nvidia's part. Perhaps the exact pixel doubling option will be available in the future.

Anybody know if and how I could pass a hint to nvidia (driver crew) to fix the exact double resolution scaling?