PDA

View Full Version : Vista 64 and 8000 series, 3d apps give BSOD


brr
06-18-08, 09:37 AM
As the title says: both 8400GS and 8800GS crash vista when I try to run anything with 3d content. Even NVIDIA Control Panel, when going to the page with the rotating NVIDIA logo, causes this. Unlikely to be bad hardware, linux runs 3d apps without problems (doom3, quake4, ut2004, rfactor etc..). Not an overheating problem either, this happens instantly after booting when I go to NVIDIA Control Panel. Screen flickers, graphical corruption, "display driver stopped responding", and then BSOD. I haven't overclocked anything either.

Specs: Asus M2NPV-VM mobo, 1GB ram, EVGA 8800GS, Athlon64 X2 4000+, Vista Home Premium OEM 64, 175.16 NVIDIA driver, all other drivers latest I could find.

I guess this is an NVIDIA driver issue, but can anyone suggest a workaround? An old driver (tried 169 series, no luck)? Change some hardware (I'd rather not, system specs are fine with my current needs)? I do realize I should have more memory, but Vista does crash right away when going to NVIDIA Control Panel. I doubt that Vista can't handle that with 1 gig ram.

shilk
06-18-08, 11:27 AM
Have you used Driver Sweeper and cleaned all traces of NVIDIA drivers before installing new drivers? Have you checked or changed anything in your BIOS? Installed Motherboard drivers?

If you haven't done so already, try installing SP1 for Vista. There's loads of fixes in it and it's stabalized the OS much more than when it was released a while ago.

brr
06-18-08, 11:45 AM
Have you used Driver Sweeper and cleaned all traces of NVIDIA drivers before installing new drivers?

I didn't at first, but the problems appeared when I installed NVIDIA driver for the first time. Later I learned about the Driver Sweeper and have used it since.

Have you checked or changed anything in your BIOS? Installed Motherboard drivers?


My BIOS settings are more or less default values, I checked PnP OS since Vista did not recognize my video card otherwise. After trying several display driver versions, I updated chipset drivers as well. No change. BIOS is also updated to latest version.

If you haven't done so already, try installing SP1 for Vista. There's loads of fixes in it and it's stabalized the OS much more than when it was released a while ago.

SP1 is installed, no change.

shilk
06-18-08, 12:02 PM
BIOS is also updated to latest version.

If you updated your BIOS, then it probably reset the values for some settings. Might need to check that again to make sure. Memory timings could be the culprit.

If you installed chipset drivers, try installing your video drivers afterwards. I had a flaky mobo before that did some really retarted stuff and I was getting the same symptoms. It only worked after I installed the chipset drivers first, then the video drivers.

Have you tried the new NForce drivers for your mobo? Have you checked the logs in Vista to see what could be the cause of it? Could be the C++/DirectX redistributables as well. Try grabbing the latest ones. Bioshock wouldn't even load for me until I installed them on Vista 64.

Picked this up on another forum as well:
Well, I think I overcame this by letting the Bios option to "Auto" and let the Asus AI selector to handle the single/dual card setup.

Couldn't hurt to try it. Personally, I try not to let the BIOS set things to AUTO.

brr
06-18-08, 01:26 PM
Thanks for the advice, I've tried everything except checking the logs so far but unfortunately with no improvement. I did file a bug report at the Nvidia Vista Quality Assurance page, although they are probably drowning in similar reports. If checking the logs doesn't help, I guess replacing the mobo is easier than continuing to debug this.