PDA

View Full Version : *grumble* D..M..A..


Serath
08-26-02, 09:38 PM
Yes... I have a question about DMA and it may be silly but... ah well.
Right now I've got a lovely abit kt7 mobo and all's working fine with one exception. I'll explain in a bit.
first system spex:
Windows XP Pro
Abit KT7 (non-raid)
Athlon T-bird 850
GF256 DDR
512MB Ram
IBM 27GB 7200RPM HD
Creative DVD drive
Phillips 12x CD burner

NOW here's the deal.
I've checked all my settings and everything is a go go go for DMA to function 100%
when I install all my stuff from scratch all is well. I fire up my PC the first few times and DMA is sweetness galore...
BUT funny thing...after a short time my poor creative DVD drive starts to misbehave. Lots of freezing and cracklingwhen accessing
Upon checking Device Manager I find that the drive has defaulted to PIO mode... I've got everything to "Use DMA if available" and it USES DMA for about a week, then craps back to PIO.
I've tried it in different configurations as slave, master, stand alone master primary, secondary, you name it, but the problem still occours over and over.

Does anyone have a clue why this would happen? After removing and reinstalling the drive SOMETIMES DMA will kick back in for a bit, and other times it requires reinstalling my VIA drivers, whereas other times even that doesn't fix it. DMA works fine on the drive under other operating systems so... just wondering...

DOES ANYONE HAVE AN IDEA ON WHAT TO DO!?!?!?!?!

Matthyahuw
08-27-02, 01:07 AM
It's an XP issue, hopefully it will be fixed in SP1

Serath
08-27-02, 09:15 AM
Call me crazy, but I just decided to give the latest Bus Master miniport drivers a try (they aren't installed with the VIA 4in1 drivers) and everything is dandy... crazy.

eL_PuSHeR
08-27-02, 04:03 PM
This seems a common issue with certain CD-ROM/CD-RW/DVD drives and Windows XP. Here is a *experimental* way I've found to cure it.

1) Go to hardware manager and delete both IDE channels

2) When windows asks you to reboot, do so, but do not let windows to load, just press DEL at system post to enter bios setup.

3) Make sure all your drives are set to AUTO in bios setup (AUTODETECTION). Also make sure DMA/UDMA access is available through bios

4) Before leaving the bios, search for an option called "Update ESCD" "Update configuration data" or something like that. More likely to be found under PnP setup.

5) Save changes and reboot

6) Let windows re-detect both IDE channels again (and attached drives to them).

7) At this point you may need to manually set DMA access for some IDE devices manually under hardware manager. Do so.

8) That's it. With luck and leaving your drives to AUTO in bios, you won't lose your DMA access again.