PDA

View Full Version : nVidia FW 177.89 beta - OpenGL 3.0


roman63
08-14-08, 12:09 PM
http://developer.nvidia.com/object/opengl_3_driver.html

This driver is aimed at developers to start coding to the new OpenGL 3.0 and GLSL 1.30 features. These features are not enabled by default. They can be enabled using the nvemulate utility, as described here: http://developer.nvidia.com/object/nvemulate.html

You need one of the following graphics cards to enable the OpenGL 3.0 and GLSL 1.30 functionality.

Desktop: GeForce 8000 series or higher; GeForce GTX 260, 280; Quadro FX 370, 570, 1700, 3700, 4600, 4700x2, 5600
Notebook: GeForce 8000 series or higher; Quadro FX 360M, 370M, 570M, 770M, 1600M, 1700M, 2700M, 3600M, 3700M
http://developer.nvidia.com/object/nvemulate.htmlNVemulate

NVemulate allows you to emulate the functionality of various GPUs (very slowly) in software. In addition, you can use it to control GLSL Support and Open GL 3.0 Support.

New in this version of NVemulate:

* Support for OpenGL 3.0 and GLSL 1.30


XP32 - http://developer.download.nvidia.com/opengl/2008-08/NVIDIADisplayWin2K(177_89)Int.exe

XP x64 - http://developer.download.nvidia.com/opengl/2008-08/NVIDIADisplayWin2KAMD64(177_89)Int.exe

Vista32 - http://developer.download.nvidia.com/opengl/2008-08/NVIDIADisplayWinVista(177_89)Int.exe

Vista64 - http://developer.download.nvidia.com/opengl/2008-08/NVIDIADisplayWinVista64(177_89)Int.exe

nekrosoft13
08-14-08, 12:22 PM
will open it up in a sec,

DSC
08-14-08, 06:40 PM
Driver supports Geforce 6/7 cards also, btw. No OGL 3.0 for those hardware though, only GF8/9/200 can enable OGL 3.0 features.

Mike89
08-15-08, 12:56 AM
So who is coding games in OGL anymore, let alone 3.0? To tell the truth I wish some would, I always liked games in OGL.

Misfire
08-15-08, 01:01 PM
isn't id software's RAGE coded in opengl?

AngelGraves13
08-15-08, 01:22 PM
Can't wait to see what the Carmack does with OpenGL 3 on RAGE and DOOM 4.

degust
08-18-08, 06:34 PM
So who is coding games in OGL anymore, let alone 3.0? To tell the truth I wish some would, I always liked games in OGL.
Well considering that OGL 3.0 is like DX10 feature-wise but works not only under Vista but under XP, OS X and Linux too i'd say someone may start using it pretty soon...

Mike89
08-22-08, 11:45 AM
So how's the driver? Haven't heard comments from anyone using it yet.

Scendore
08-22-08, 06:32 PM
I ran IL2 1946 with all the updated DLLs and it runs like a slide show... Something is broken with older OpenGL games... Went back to 177.66 which are the best for Il2 so far.