PDA

View Full Version : New nForce2 Drivers 2.41


Pages : [1] 2

Garand Jinn
05-19-03, 02:16 PM
Now available at www.nvidia.com

|JuiceZ|
05-19-03, 03:52 PM
thx for the heads up, bout frickin' time! :p

The Baron
05-19-03, 04:02 PM
And they fixed the SCSI thing. woot. makes me wish I had an nForce 2 ;)

StealthHawk
05-19-03, 05:04 PM
Originally posted by The Baron
And they fixed the SCSI thing. woot. makes me wish I had an nForce 2 ;)

They SCSI thing was annoying. Glad it's fixed. Even though I updated my drivers yesterday...so it's kinda sad that I have to reboot my computer again.

jnd3
05-19-03, 05:45 PM
I still think driver announcements are more appropriate for one of the software forums...and besides, I had the scoop by 40 minutes or so! :angel:

Regardless, glad to see they're out. I'm looking forward to giving them a try (and turning on EAX in Splinter Cell and Ghost Recon).

So what's the recommended install method? Boot safe mode, uninstall existing drivers, reboot, install new drivers? Or do you all just plaster 'em over the existing drivers?

Cheers,
JND

Needa916
05-19-03, 06:45 PM
Originally posted by jnd3


...So what's the recommended install method? Boot safe mode, uninstall existing drivers, reboot, install new drivers? Or do you all just plaster 'em over the existing drivers?

Cheers,
JND

Hey I am glad I checked this thread before posting that exact question. How to uninstall old and install new?

Red Dog
05-19-03, 08:29 PM
I downloaded them, but i read at nforcershq that some people are experiencing ide problems after installing them.

im gonna wait a while and watch.

jnd3
05-19-03, 09:23 PM
:fu:

Well, I got 'em installed OK. Booted into safe mode, uninstalled everything that said "Nvidia", and rebooted. Canceled out of autodetecting and installed the new driver package (and the detonators after that). All looked fine.

But.

I went to kill some Nazis in MOHAA:SH, and the bloody thing is asking me to put the CD in the drive. It shows up in "My Computer", it autoplays when I put the CD in, and then it promptly crashes. I suppose I could uninstall and reinstall the games....

Edit: Ghost Recon, Syberia, and Medieval: Total War all played fine. Splinter Cell and MOHAA/SH gave me the "Wrong CD" error message. You'd think it would be an all-or-nothing thing...

Edit [2]: OK, I changed the CDROM to PIO mode in the device manager. Now all the games work. Odd..... :confused:

Cheers,
JND

volt
05-19-03, 09:29 PM
Why does it say Win9X only ?

Red Dog
05-19-03, 09:40 PM
ok, it seems at least safedisc game dont work with the new ide sw.

I rolled back with system restore and re-installed without the ide sw driver and everything is working fine now.

now I have an ultra 400 memory controller showing in device manager! (nf7-s rev 2)

:D


jnd3, let us know is a game re-install works.

StealthHawk
05-19-03, 09:43 PM
Originally posted by volt
Why does it say Win9X only ?

Where does it say that? I downloaded the XP drivers and they installed fine.

netviper13
05-19-03, 09:43 PM
Seems like nVidia's driver department is getting good at everything except IDE drivers.

volt
05-19-03, 09:46 PM
eeeeeeh, nevermind too much coffee.

volt
05-19-03, 09:50 PM
Originally posted by netviper13
Seems like nVidia's driver department is getting good at everything except IDE drivers.

what's wrong with those?

StealthHawk
05-19-03, 10:13 PM
Originally posted by volt
what's wrong with those?

Read Red Dog's post. He says safedisc cds don't work now.

volt
05-19-03, 10:15 PM
Baaaaaah! Thought maybe some transfer slowdowns.
Not gonna say anything else today :o

SavagePaladin
05-19-03, 10:16 PM
You still have to consider they're working with their own unusual hardware design and the drivers are still relatively new in the grand scheme of things.

I'm kinda glad I'm skipping to nforce3+ath64, but I suspect they'll still have issues.

CaptNKILL
05-19-03, 10:55 PM
Well Im VERY impressed with these drivers. I used to have problems with Vietcong and hardware sound. Id get random REALLY LOUD sounds for no reason (like they werent being distance-filtered correctly). I still prefer the clearity of software sound, but its nice to be able to turn on hardware sound and PLAY the game. Before it was just annoying.

I installed the IDE drivers and im not having any problems at all. I didnt notice any huge improvement, but I wasnt really looking for one, so I guess things could be faster.

Good drivers Nvidia. Keep up the good work :)

BTW, I enabled EAX in VC too and it sounds great... it used to sound crappy before this update. Its a shame I cant have software sound quality with EAX reverb :rolleyes:

Shaitan
05-19-03, 11:54 PM
I installed these drivers and all seems well.

zerodamage
05-20-03, 01:33 AM
Ok... figured out what it is. My Network Controller doesn't like the new nvidia drivers. This is the error message I was getting. The BSD that came up while Windows was loading.


STOP: c0000263 {Driver Entry Point Not Found}
The \SystemRoot\System32\Drivers\Nvnet.sys device driver could not locate the entry point NdisGetFirstBufferFromPacketSafe in driver NDIS.SYS

After going into Safe Mode, I disabled: Nforce MCP Network Controller, rebooted and windows booted right up. (Windows 2000 btw).

I then did a search for new drivers and it went back to the old INF file. Ends with a 3 vs the 11 it had and worked just fine after that.

Anyone else have this problem? Please post here. May be an Epox 8rda+ issue, not sure.

SavagePaladin
05-20-03, 04:30 AM
You're saying your NIC drivers were at 3.11? This and the last pack have had 3.13

|JuiceZ|
05-20-03, 01:59 PM
Installed the drv's including the SW IDE ones. After rebooting, winxp failed to boot up, even in safemode. Had to end up reverting to old hw profile, xp was able to bootup fine, and after checking device mgr, it still showed the drv's had been installed. Haven't noticed any difference in terms of perf, but the hw sound support appears to have improved in a few games.

ToxicFool
05-20-03, 07:58 PM
I think I am going to wait a while.. anyone still having the sound card problem with the crackling sound distrotion that randomly happens?

SavagePaladin
05-20-03, 10:56 PM
Yeah. I'm pretty sure you should see a fix shortly, but whether that means within a month or within two or more, I couldn't say. (I think under two, but I've been wrong.)

netviper13
05-20-03, 11:11 PM
*sigh* excellent graphics driver support, shoddy motherboard support. Just as I'm getting excited about the Dolby Digital for a possible new receiver, more driver issues. Guess I'm sticking with the ole' GTXP for now.