PDA

View Full Version : Forceware 181.22 beta x86/x64


Pages : [1] 2

saturnotaku
01-16-09, 10:04 AM
Vista 32-bit

http://www.nvidia.com/object/winvista_x86_181.22_beta.html

Vista 64-bit

http://www.nvidia.com/object/winvista_x64_181.22_beta.html

Package includes recently released PhysX 9.09.0010 drivers and is supposed to have fixes for Mirror's Edge.

shilk
01-16-09, 12:09 PM
Thanks for the heads up! Gonna give them a download and try them out. :)

Isola
01-16-09, 01:04 PM
check for F3 crash plz :-(

DHP
01-16-09, 02:16 PM
Great set of drivers.

Fallout 3 crashes are gone, and the driver is a lot faster than the 180.48's in F3. I had some slowdown issues with the 48 set when al lot of supermutants where around. That problem is gone. Great!!! Runs smoother than the 48 set.

Miirors Edge runs fine too...

Keepers. :cool: Good job nV!!!! (urock)

DHP
01-16-09, 02:18 PM
Edit; double post. :o

randsom
01-16-09, 02:59 PM
they seem to be problematic on my system as are all the 181 series, wierd desktop issues, and slowdowns, i went back back to 180.84s which are great on my system.

ATOJAR
01-16-09, 03:28 PM
Darn it! ... only just installed the 181.20's the other day .....

Bokishi
01-16-09, 04:05 PM
Cool DL'ing now

j0j081
01-16-09, 05:47 PM
hope this fix the crashes with UT3 as well.

nekrosoft13
01-16-09, 06:16 PM
good drivers!

first nvidia 2009 driver ;)

shilk
01-16-09, 06:45 PM
Never had a crashing issue with Fallout 3, but I did notice they were smoother than the drivers I had installed before (181.20, 185.20 and 180.60's). I made sure my settings were the same and I wasn't just getting the placebo effect. :D Mirror's Edge fly with these drivers as well, so I cranked it up to 4x AA and 16 AF @ 1440x900.

Couldn't be happier with these drivers so I'm keeping them - for now. :)

swanksta
01-16-09, 11:43 PM
I read that only the new PhysX is attributable to performance in Mirror's Edge and that these drivers are mainly for the listed bugfixes. Will someone confirm this? (I already have the new PhysX)

AdamK47
01-16-09, 11:57 PM
These drivers seem great. Fallout 3 no longer crashes when looking up in the sky anymore. That was the only major complaint I had with the 181.20 drivers. I did notice something odd after installing this driver set. PhysX no longer worked even though I had it enabled. I uninstalled the PhysX driver and reinstalled it trough a stand alone package and it worked after that. Performance was horrible in Mirrors Edge before and after reinstalling PhysX it's smooth.

breathemetal
01-17-09, 01:53 AM
So these are a-ok for FO3?

DHP
01-17-09, 05:51 AM
Yep, actually these are the BEST driver yet for FO3. :cool:

Wolfhound
01-17-09, 10:53 AM
UT3 still crashes with these, not in 2 minutes but crashes after some time playing (30 to 40 minutes)

mailman2
01-17-09, 10:59 AM
UT3 still crashes with these, not in 2 minutes but crashes after some time playing (30 to 40 minutes)

some people were having this issue, uninstall physx and it fixes it apparently.

Wolfhound
01-17-09, 02:21 PM
some people were having this issue, uninstall physx and it fixes it apparently.

Dsiabling it in game will solve it too?, thanks for the tip :thumbsup:

HYBRID
01-17-09, 03:41 PM
This crashes ETQWars, back to 181.20.

Isola
01-17-09, 06:42 PM
Dsiabling it in game will solve it too?, thanks for the tip :thumbsup:

or maybe in the nvidia control panel?mmmm

Wolfhound
01-18-09, 01:10 PM
or maybe in the nvidia control panel?mmmm

Nice will try, disabling in game doesn´t help

AdamK47
01-18-09, 03:20 PM
This crashes ETQWars, back to 181.20.

I tried the game out last night. I haven't played the game in a long time. Played the game for about an hour and all seemed fine.

AdamK47
01-18-09, 03:21 PM
UT3 still crashes with these, not in 2 minutes but crashes after some time playing (30 to 40 minutes)

I don't seem to have a problem with crashing with PhysX enabled. Am I just lucky?

j0j081
01-18-09, 08:01 PM
some people were having this issue, uninstall physx and it fixes it apparently.

That's what I thought originally but it still crashes. the crashes are so random you might think you've fixed it for a while though.

Wolfhound
01-19-09, 07:59 AM
Disabling in control panel doesn´t work too UT3 still crashes