PDA

View Full Version : Having trouble with wireless network


saturnotaku
06-06-03, 01:59 PM
My roommate and I have our broadband wireless Internet connection set up. I'm connecting to our network via an SMC wireless PCI card. And my laptop connects via an SMC PCMCIA card.

My laptop will connect to the wireless network and get an IP address without any problem.

My desktop, though, is a different story. When my system boots, I will get into Explorer and my machine will take forever to load because I can't automatically obtain an IP address from our gateway/DHCP server. When the network connection icon appears in my system tray, I can click on that and be able to connect to our network. Then I'll get the IP address and be able to surf and what have you.

I just want to know if there's any way I can either have Windows skip automatically searching for an IP address or be able to have the DHCP server assign me an IP address right off the bat.

I tried manually configuring the DHCP server and IP address but that doesn't work. Any ideas?

intercede007
06-06-03, 02:39 PM
Leave DHCP on.

Go into the TCP/IP settings for your LAN card and give it the DNS numbers from your provider, and give the card a IP address below 100. So in other words, all cards you want to have static IP's should be 192.168.1.2 .. 192.168.1.3 ... so forth.

You shouldn't have to mess with the DHCP settings at all.

Now, if you can figure out why my wireless router drops all the connections (including the wired and the cable modem) every couple of hours, I'll buy you a car.

EDIT

Consider this if you have a Linksys product. Get a sledghammer, and place the router on the floor. Lift hamemr over head... Sorry, my frustration bleed out there.

I called Linksys about a simliar problem I had with my WRT54G router, and they said that for whatever reason (they were uncertain why) some routers were not sending out DNS, IP or both information to the networked devices. A firmware update fixed that for me.

You said you are using SMC cards but not which router. Be aware that more often then not, cards from a differant company then a router do not play well together, especially in the 802.11g range.

saturnotaku
06-06-03, 02:59 PM
Our "router" is a Celeron 550 running Windows 2000. This is the only way we could do it without suffering some severe performance losses.

I did what you said and fiddled with some other settings, now the connection icon appears a lot faster in my system tray. All I do is right click, view all wireless networks, then hit connect and I'm good to go.

I appreciate your help.

If you want a wireless router, check out the SMC2804WBR (http://www.smc.com/index.cfm?sec=Products&pg=Nitro-Technology&&site=c). Envy News did a review on this and it received the Merit Award. From my experience with SMC's wireless cards, I think you'd be very happy with their routers.

intercede007
06-06-03, 03:14 PM
Here's what I don't understand. Why do you have to click on the bubble to connect?

When my PC's start (assuming my router wants to play nice) my wireless cards (DHCP) all automatically connect. Is that supposed to work that way for you?

saturnotaku
06-06-03, 03:51 PM
It works that way on my laptop. The problem is when I boot my desktop, my card will try to obtain an IP address but it will assign me a 169.xxx.xxx.xxx which is bad. I need to get a 10.xxx.xxx.xxx in order to be able to access the web. The only way I can get that is to click on the bubble and manually authenticate. And that is once the icon appears in my system tray after seemingly taking forever to appear.

The Baron
06-06-03, 03:56 PM
Ah, wireless networking. One of the few areas where I actually AM a guru. :p (necessity. it's a bitch.)

Intercede is absolutely right--NEVER EVER EVER use DHCP if you can avoid it. Leave the server on for things that work fine, but usually you should just assign IPs. Makes it a lot simpler when you need to open ports, use the DMZ, etc. al.

Now, once it's connected, you need to flibble, er, fiddle with the RTS threshold and the fragmentation threshold in order to prevent insane packet loss (unless you're two feet away from your router, in which case you should use Ether, you dolt). My RTS threshold is 1700 and my fragmentation threshold is 1850 (my card is good about that, but some cards need it in a multiple of 64 IIRC). That prevented 99% of packet loss from the wireless in my old house without degrading the speed very much. (Oh, you set this stuff either in the card's utility or in the card's properties under Device Manager.)

Now, as for automagic connections, if you're using the WinXP wireless ****^H^H^H^Hstuff, you have to set it to automatically connect to all networks (not just preferred ones--never worked for me). Then it should connect on startup.

Now, if you can figure out why my wireless router drops all the connections (including the wired and the cable modem) every couple of hours, I'll buy you a car.

Just checking, but that IS a joke, right? ;)

The Baron
06-06-03, 03:58 PM
Originally posted by saturnotaku
It works that way on my laptop. The problem is when I boot my desktop, my card will try to obtain an IP address but it will assign me a 169.xxx.xxx.xxx which is bad. I need to get a 10.xxx.xxx.xxx in order to be able to access the web. The only way I can get that is to click on the bubble and manually authenticate. And that is once the icon appears in my system tray after seemingly taking forever to appear.

Hmmm.. what's the IP of your router? 10.0.0.1? In that case, go to the TCP/IP settings of your card and set the IP to 10.0.0.x. 169.x.x.x is the automatic Windows stuff, so I think the problem is that it's not connecting at startup. See above. ;)

intercede007
06-06-03, 04:03 PM
Originally posted by The Baron

Just checking, but that IS a joke, right? ;)


Yes and no. It's symbolic of my frustrations. I will buy you a case of beer though ;)

The dropped connection problem is not a joke though. Linksys can't even figure it out. I've already RMA'd the router and the power supply once.

The Baron
06-06-03, 05:34 PM
Hmmm... at least my Belkin just kills all of the wireless connections at random and not the cable modem.

intercede007
06-06-03, 06:18 PM
Originally posted by The Baron
Hmmm... at least my Belkin just kills all of the wireless connections at random and not the cable modem.

So I'm not the only one? Thank god!!

GlowStick
06-06-03, 06:33 PM
The Baron, i got a question for u!

I have a Wireless router that has computers near it (wired of cousre) and one one that has a USB wireless nic on it.

The wired one works fine, very fast very nice.

But the wireless one works GREAT for like a min, or so, then it completely drops. And windows says 'network card disconected' then within a few seconds it comes back great! Cant play games, browsing is ok, sometimes you gotta keep hitting reload waiting for it to connect again. I am not far from the router the signal is very strong.

My question is, is it my router, or my nic that is the problem? or are they both working correctly? or should i get a pci nic? heh?

The Baron
06-06-03, 07:56 PM
Read and learn. (http://www.nvnews.net/vbulletin/showthread.php?s=&threadid=4825&highlight=wireless) ;)

GlowStick
06-06-03, 08:33 PM
Originally posted by The Baron
Read and learn. (http://www.nvnews.net/vbulletin/showthread.php?s=&threadid=4825&highlight=wireless) ;)

Im blind, sure pick on blind people.

saturnotaku
06-07-03, 09:17 AM
I don't know what I did, but after a whole lot of messing around I was able to connect to our network by bypassing DHCP. My system boots up perfectly and I don't need to manually connect to our network.

Thanks for all the tips guys. :D