PDA

View Full Version : Disable Force Full GPU scaling for good.


mark9117
04-01-09, 03:03 PM
When I restart the system or restart my X server, the display is rendered larger than my 42" FPD television. I can open the nVidia-settings application, uncheck "Force Full GPU Scaling" under the Flat Panel Scaling options for the flat panel display attached to the card and the display corrects itself -- everything looks fine.

If I have to restart X, the setting for "Force Full GPU Scaling" reverts to the checked state and the display is once again rendered larger than the television screen.

How can I make this setting (disable Force Full GPU) persistent?

Thank you.

Mark Adams
madams9@msn.com

kdorf
04-01-09, 04:28 PM
NVidia settings aren't automatically loaded when you log in, though I think starting the program should fix the issue for you. You can try saving the configuration and putting `nvidia-settings -l` in your .profile and see if that helps. It will force nvidia-settings to apply whatever configuration you have saved in .nvidia-settings-rc.

AaronP
04-01-09, 09:33 PM
Option "FlatPanelProperties (ftp://download.nvidia.com/XFree86/Linux-x86/180.44/README/appendix-b.html#FlatPanelProperties)" "Scaling = Native"

mark9117
04-02-09, 02:34 PM
NVidia settings aren't automatically loaded when you log in, though I think starting the program should fix the issue for you. You can try saving the configuration and putting `nvidia-settings -l` in your .profile and see if that helps. It will force nvidia-settings to apply whatever configuration you have saved in .nvidia-settings-rc.

Thanks for that info kdorf. Interestingly, I notice that .nvidia-settings-rc is found only under my root user account. Would you recommend copying that file to my regular user directory?

Also, there is no reference to scaling in that file. Should AaronP's suggestion below be inserted into the .nvidia-settings-rc configproperties section?

Thanks again.

Mark

zander
04-02-09, 03:03 PM
~/.nvidia-settings-rc is created by nvidia-installer when it exits; FlatPanelProperties is an X driver option, see http://us.download.nvidia.com/XFree86/Linux-x86/180.44/README/appendix-b.html#FlatPanelProperties.

mark9117
04-02-09, 05:29 PM
~/.nvidia-settings-rc is created by nvidia-installer when it exits; FlatPanelProperties is an X driver option, see http://us.download.nvidia.com/XFree86/Linux-x86/180.44/README/appendix-b.html#FlatPanelProperties.

Thanks Zander, I was hip to the fact that it was an option for the xorg.conf file. I just couldn't figure out where to put it.

Turns out putting it under
Section "Device"
Identifier "Videocard0"
did the trick.

I appreciate the help fellows. I've been chasing my tail on this for months.


Mark

zander
04-02-09, 05:33 PM
For posterity, you can place NVIDIA X driver options in either the Screen or Device section(s) of the X configuration file; this is also documented in the README section linked to above:
The following driver options are supported by the NVIDIA X driver. They may be specified either in the Screen or Device sections of the X config file.

mark9117
04-03-09, 02:38 PM
For posterity, you can place NVIDIA X driver options in either the Screen or Device section(s) of the X configuration file; this is also documented in the README section linked to above:
The following driver options are supported by the NVIDIA X driver. They may be specified either in the Screen or Device sections of the X config file.

I saw that information, but this setup involves two displays in Twinview. That produces multiple (okay, 2) Screen sections and for whatever reason, there are also two Device sections. Believe it or not, that complicates things.

At any rate, thanks to this forum it's working as it should and I am grateful.


Mark