PDA

View Full Version : Vista File Transfer Speed


Hambone
04-03-09, 07:27 PM
I need to look into this - I never bothered to read up. In the image below I'm transferring some folders of pretty large size from an old (original) Segate 1T drive to a new WD Black 1TB drive. Both are SATA 3.0 drivers. (set that way via jumper and with quality SATA 3.0 cables I ordered off Newegg). I think both drivers are 32MB cache drives as well.

At first I tried to highlight and copy over everything from the Segate to the WD. The speed was actually at ~150MB/s for maybe two seconds and then it slowly dropped down to about 26MB/s where it stabalized. That was just annoying and I had no idea why. It should have been going in order one by one and been much faster.

I've been going a couple of folders at a time now slowly, but I'm at the end and got tired of waiting so I did three big ones all at once.

I'm only getting 37MB/s right now from the 3 for 1 deal. That seems so low. I'll try to read up over the weekend.


http://img4.imageshack.us/img4/6007/11659444.jpg

nekrosoft13
04-03-09, 08:44 PM
you are probably running RTM, this was rather common issue in RTM, all was fixed in SP1

Drolfrawd
04-03-09, 08:45 PM
+1

Bman212121
04-04-09, 02:32 AM
Copying anything more than 1 at a time is going to kill performance. The issue with hard drives is the seek time to find the files. It's going to really slow things down when you try that.

Like Nekro Said, adding SP1 should definitely fix a lot of the issues. One thing to keep in mind is that 2nd folder you copied has a ton of files in it. It's going to take quite a bit longer to copy that folder than the 3rd one which has much larger files in it.

The 150MB spike at the beginning was just Vista recording drive caching. The drive itself cannot copy data that fast. The fastest you'll see is probably around 80MBps for the 3rd copy. The 2nd one might only chug along at half that speed.

Eliminator
04-05-09, 09:32 AM
try going to control panel->turn windows features on/off->uncheck remote differential compression

Bman212121
04-05-09, 09:50 AM
try going to control panel->turn windows features on/off->uncheck remote differential compression

I'd be interested to know if that makes and difference or not. From what I've read about it the compression is used for DFS replication. Basically two servers in a domain mirroring data over a wan link. So I'm not sure if a normal transfer would have any affect or not.

LovingSticky
04-05-09, 10:01 AM
Switch off antivirus, antispyware and any other malicious software you might have. Most of these packages slow down disk access 10-20x times (!!). Never ever use AV packages if you value performance.

See this: http://www.codinghorror.com/blog/archives/000803.html

mailman2
04-07-09, 03:56 AM
Switch off antivirus, antispyware and any other malicious software you might have. Most of these packages slow down disk access 10-20x times (!!). Never ever use AV packages if you value performance.

See this: http://www.codinghorror.com/blog/archives/000803.html

nice link but not really realistic to run a Windows machine on the internet without AV these days.

Q
04-07-09, 08:43 AM
I should clarify that SP1 fixed the problem for many users, but not for all. Performance is still **** if you do heavy read/writes like virtualization. In comparison to XP/W2k, that is.

Bearclaw
04-07-09, 09:07 AM
Ya, tell em Q! **** vista! W7 FTW.