PDA

View Full Version : Can't enable Desktop Effect after upgrading to snv_111


Pages : [1] 2

shaoxuan
04-16-09, 09:59 AM
Hello gurus,

I'm using opensolaris 2008.10 snv_101b for a few months, and the Desktop Effect works fine (Nvidia Geforce 7100 + 630i). But after live-upgrading to snv_111 via "pkg image-update"(the video card driver has upgraded to 180.22), the Desktop Effect can't be enabled. How can I do to enable Desktop Effect?

Thanks.

paulgress
04-16-09, 05:09 PM
This is a problem with nv111 and 112 that should be corrected in nv113. It's not the 180.22 driver.

Bug Title: compiz fails to start at login for nvidia graphics cards

Bug description: compiz fails to launch upon login because Xserver is not loading GLX extensions. This is due to The SMF service svc:/application/opengl/ogl-select:default picking the wrong type of GLX extension, it points to the generic Mesa library.

Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0

Workaround: Set vendor string manually :
$ svccfg -s applications/opengl/ogl-select setprop options/vendor = nvidia
$ svcadm restart applications/opengl/ogl-select

Restart X server and re-login

shaoxuan
04-16-09, 09:19 PM
Hello paulgress,

Thanks for your comprehensive advice, I will try it ,thanks!

shaoxuan
04-16-09, 09:55 PM
This is a problem with nv111 and 112 that should be corrected in nv113. It's not the 180.22 driver.

Bug Title: compiz fails to start at login for nvidia graphics cards

Bug description: compiz fails to launch upon login because Xserver is not loading GLX extensions. This is due to The SMF service svc:/application/opengl/ogl-select:default picking the wrong type of GLX extension, it points to the generic Mesa library.

Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0

Workaround: Set vendor string manually :
$ svccfg -s applications/opengl/ogl-select setprop options/vendor = nvidia
$ svcadm restart applications/opengl/ogl-select

Restart X server and re-login


Hello, can't set vendor string manually:

yurippe@Mars:~$ svccfg -s applications/opengl/ogl-select setprop options/vendor = nvidia
svccfg: mode 'applications/opengl/ogl-select' does not match all instance or service (translated from Chinese)
yurippe@Mars:~$

paulgress
04-17-09, 09:19 AM
Try:
$ svccfg -s applications/opengl/ogl-select setprop options/vendor=nvidia
$ svcadm restart applications/opengl/ogl-select

I removed the spaces between "vendor = nvidia"

This is what worked for me, I copied and pasted from another area with spaces.

shaoxuan
04-17-09, 10:04 AM
Try:
$ svccfg -s applications/opengl/ogl-select setprop options/vendor=nvidia
$ svcadm restart applications/opengl/ogl-select

I removed the spaces between "vendor = nvidia"

This is what worked for me, I copied and pasted from another area with spaces.

I have tried, but with no luck. I copied and pasted to execute too. :(
The terminal returned the same messages as before.

shaoxuan
04-17-09, 10:19 AM
By the way, the video chip I'm using is not a independent video card, it's intergrated with the motherboard. But it did support desktop effect when the OS is 2008.10 snv_101b.

Before I tried these two commands, I have upgraded the video card driver to 180.44, the driver was downloaded from Nvidia web site.

paulgress
04-17-09, 12:17 PM
How did you install the latest 180.44 driver?
I was under the impression that you couldn't just yet install into SXCE or Opensolaris without certain workarounds. The workarounds are as follows:

cd /usr/X11/lib/modules
mv libwfb.so libwfb.so.copy
cd amd64
mv libwfb.so libwfb.so.copy
/tmp/NVIDIA-Solaris-x86-180.44.run
.
.
.
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so
cd ..
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so

This assumes you have the correct libwfb.so installed from the nv111 DVD. Suns library needs to be used due to the upgrade to X.Org 1.5. You may need to copy libwfb.so from the DVD (both 32 & 64 bit versions). You can also use this procedure to downgrade to the previous 173 or 177 series drivers.

zander
04-17-09, 12:50 PM
On a related note, the libwfb.so workarounds should no longer be needed with NVIDIA Solaris graphics driver releases >= 180.50 (see e.g. ftp://download.nvidia.com/solaris/180.50).

shaoxuan
04-17-09, 01:07 PM
How did you install the latest 180.44 driver?
I was under the impression that you couldn't just yet install into SXCE or Opensolaris without certain workarounds. The workarounds are as follows:

cd /usr/X11/lib/modules
mv libwfb.so libwfb.so.copy
cd amd64
mv libwfb.so libwfb.so.copy
/tmp/NVIDIA-Solaris-x86-180.44.run
.
.
.
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so
cd ..
mv libwfb.so libwfb.so.nvidia
mv libwfb.so.copy libwfb.so

This assumes you have the correct libwfb.so installed from the nv111 DVD. Suns library needs to be used due to the upgrade to X.Org 1.5. You may need to copy libwfb.so from the DVD (both 32 & 64 bit versions). You can also use this procedure to downgrade to the previous 173 or 177 series drivers.

Hello,

I first uninstall NVDAgraphics, and then install the Nvidia-Solaris-x86-180.44.run without any problem (except the desktop effect issue). It's odd? :o

Thanks zender, I'm downloading the 180.50 driver.

Shao

shaoxuan
04-17-09, 01:42 PM
Hello,

After installing the 180.50 driver, I can't see the login window now. When the system wait for login input ,the screen is whole blue, I can see the mouse curser and I can move it too. But I can't see the login window. when you tap in the user/password blindly, the system can log you into, but the screen is still whole blue.

By the way, I chmod a+x and execute Nvidia-Solaris-x86-180.50.run directly to upgrade the driver (Is this method right?).

What can I do to correct this? I'm using another PC now. :(

Thanks,
Shao

zander
04-17-09, 02:02 PM
@shaoxuan: I didn't mean to suggest that you install 180.50 on your system - since you had already installed 180.44, X.Org's libwfb.so binary may already have been clobbered. 180.50 also has a bug that prevents it from working correctly on pre-G80 (GeForce 8) series GPUs. We hope to release an updated 180.xx driver addressing this problem either sometime today or early next week. Please see http://www.nvnews.net/vbulletin/showpost.php?p=1984850&postcount=7 for a workaround.

paulgress
04-17-09, 02:10 PM
I only have a few more suggestions.

1) Try installing nv112 now available.

http://www.opensolaris.org/jive/thread.jspa?messageID=368315&tstart=0#368315

Also, this build comes with 180.44 driver, you'll have to add the 180.50 manually. Also, please note the workarounds on this page.

2) Try the workaround I gave you earlier now that you've progressed with the 180.50 driver.

3) If all else fails, try posting to xwin_discuss forum for Opensolaris/SXCE

http://www.opensolaris.org/jive/forum.jspa?forumID=25

Sun graphics engineers monitor this forum and quite often respond to end user problems.

shaoxuan
04-17-09, 03:01 PM
@shaoxuan: I didn't mean to suggest that you install 180.50 on your system - since you had already installed 180.44, X.Org's libwfb.so binary may already have been clobbered. 180.50 also has a bug that prevents it from working correctly on pre-G80 (GeForce 8) series GPUs. We hope to release an updated 180.xx driver addressing this problem either sometime today or early next week. Please see http://www.nvnews.net/vbulletin/showpost.php?p=1984850&postcount=7 for a workaround.

Hello,

The screen is corrupted, how can I input commands?

What can I do in single user mode? the "xrander" command can't be found.

Shao

zander
04-17-09, 03:45 PM
If the 180.50 NVIDIA graphics driver packages can't be uninstalled in single-user mode, you may still be able to temporarily disable the automatic graphical login service, such that you're presented with a text-mode login.

paulgress
04-17-09, 04:10 PM
If you install nv112 it will clear all the graphics driver issues.

To try and clear nv111 you need copy the libwfb.so libraries into the directories I posted earlier. To do this will require some work. You have to boot into Failsafe mode and when it asks to mount the root filesystem as /a enter "y" for yes. Instead of finding the libraries on the nv111 DVD, I've taken the liberty to put them on my company website so you can download them.

http://www.rad-electronics.com/Downloads/X11/libwfb.so
http://www.rad-electronics.com/Downloads/X11/amd64/libwfb.so

You'll need to burn it on a CD or usb stick and mount it manually.
To mount it manually you need to determine the driver for mounting it is. You have to issue the command "rmformat" without the quotes. If you had a usb stick in when you entered rmformat, then to mount that:

mount -F pcfs /dve/dsk/c0t0d0p0:c /mnt

If it's a CD issue:

mount -F hsfs /dev/dsk/c0t0d0s2 /mnt

Where the "c0t0d0s2 or c0t0d0p0 is replaced by what comes from the output of rmformat.

Then copy them over:

cp /mnt/libwfb.so /a/usr/X11/lib/modules/libwfb.so
cp /mnt/amd64/libwfb.so /a/usr/X11/lib/modules/amd64/libwfb.so


It will probably be far easier to just upgrade again to nv111 or nv112.

zander
04-17-09, 04:30 PM
For what it's worth, 180.51 is now available (see ftp://download.nvidia.com/solaris/180.51), which fixes the libwfb.so clobber problem and doesn't suffer from the GeForce 6/7 series regression 180.50 did.

paulgress
04-18-09, 10:12 PM
I've thought of what I believe an easier way to get the libraries into nv111. Even though you cant see the login screen, your there. If you login as root you should be at the console even though you don't see it (you can test it by typing "reboot" after loging in). At this point you can turn telnet and ftp services on, this way you can ftp the files over, then telnet login as regular user and su to root. At this point you can copy the files to their proper location. It should go something like this:

root
your-password
svcadm enable ftp
svcadm enable telnet

go to another computer on the same internet, get to a terminal window (in windows the command prompt) and type:

ftp 192.168.1.100

The IP address is the one assigned to the nv111 box. You can only login as a regular user, not root. Put the files to a location you remember.

Now open another terminal window and type:

telnet 192.168.1.100

The IP address is the one assigned to the nv111 box. You can only login as a regular user, not root. now type:

su
your-root-password

now you have root privileges, simply copy the files now to their proper location.

shaoxuan
04-19-09, 08:21 AM
Hello,

After upgrading video driver to 180.51 in single user mode, now I'm in graphical mode to post. I'm working on libwfb.so issue now. I'll report later.

Thanks for your help.
Shao

shaoxuan
04-19-09, 08:42 AM
Hello,

I have upgraded the video driver to 180.51, but can't enable desktop effect too, Even using the libwfb.so file which paulgress provided. Why?

By the way, I'm not using SCXE, I'm using opensolaris, so snv111 is the most recent version. Can't upgrade it to 112 now.

Thanks,
Shao

paulgress
04-19-09, 06:01 PM
With the incorrect libwfb.so library installed you won't get any graphics display, not even the login prompt. Also, you will need to be careful in the future, as Sun is talking about upgrading to XOrg 1.6 soon.

What error message do you get if you enter:

/usr/bin/compiz &

From a terminal window.

shaoxuan
04-19-09, 09:30 PM
Hello paulgress,

Thanks for your quick reply.

yurippe@Mars:~$ /usr/bin/compiz &
[1] 958
yurippe@Mars:~$ /usr/bin/compiz-bin (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0

paulgress
04-19-09, 10:42 PM
OK, were going to try again. If you look at the post on this link:

http://www.opensolaris.org/jive/thread.jspa?messageID=368315&tstart=0#368315

They show the error message they are getting:

"Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not
a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on
display :0.0"

It looks identical to yours. The only difference is they started it with the command "compiz-bin, it's basically the same, compiz is a shell script to start "compiz-bin". So we established you have the same problem, so you should require the same solution.

At the root prompt enter:

# svccfg -s application/opengl/ogl-select setprop options/vendor=nvidia
# svcadm restart application/opengl/ogl-select

This time I discovered an error with the previous post. The word application doesn't end with an "s". If you look at the previous posts there was an "s" showing as "applications". So just copy and paste the above entry and you should be good.

shaoxuan
04-20-09, 01:39 AM
OK, were going to try again. If you look at the post on this link:

http://www.opensolaris.org/jive/thread.jspa?messageID=368315&tstart=0#368315

They show the error message they are getting:

"Error message: /usr/bin/compiz-bin (core) - Fatal: Root visual is not
a GL visual
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on
display :0.0"

It looks identical to yours. The only difference is they started it with the command "compiz-bin, it's basically the same, compiz is a shell script to start "compiz-bin". So we established you have the same problem, so you should require the same solution.

At the root prompt enter:

# svccfg -s application/opengl/ogl-select setprop options/vendor=nvidia
# svcadm restart application/opengl/ogl-select

This time I discovered an error with the previous post. The word application doesn't end with an "s". If you look at the previous posts there was an "s" showing as "applications". So just copy and paste the above entry and you should be good.

Hello Paulgress,

amazing! now the Desktop Effect works, Thanks Paul, I have wasted you too much time. :)

johnmartin
04-20-09, 11:09 AM
Simplified workaround for NVIDIA GLX not selected properly in b111-112:

# svccfg -s ogl-select setprop options/vendor=nvidia
# svcadm restart ogl-select

If you have already wiped out libwfb.so by installing a pre-180.50
driver from the NVIDIA download page, recover first by uninstalling
the driver:

# pkgrm [-R alt-root-location ] NVDAgraphicsr NVDAgraphics

libwfb is delivered in the SUNWxorg-server IPS package. Reinstall it:

# pkg uninstall -r SUNWxorg-server
# pkg install SUNWxorg-server

All of this should be fixed in b113.