PDA

View Full Version : BioShock Mouse Acceleration Fix


AngelGraves13
04-24-09, 05:24 PM
* Locate Bioshock.ini and User.ini
Windows XP
C:\Documents and Settings\[Username]\Application Data\Bioshock
C:\Documents and Settings\[Username]\Application Data\Bioshock2
Windows Vista or Windows 7
C:\Users\[Username]\AppData\Roaming\Bioshock
C:\Users\[Username]\AppData\Roaming\Bioshock2


Disabling Mouse Acceleration & Smoothing

In User.ini with Notepad Go to Edit>Replace and search for the two MOUSEX and MOUSEY acceleration speeds and change them from their default 2500 speed to 750 or any other value that feels comfortable. You will need to "Replace All" the following two lines since they repeat.

MouseX=IF_MOUSE_LOOK_ENABLED Count bXAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseX Speed=2500.0
MouseY=IF_MOUSE_LOOK_ENABLED Count bYAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseY Speed=2500.0

And the final step is to bind a key to disable Mouse Smoothing. In the 2K forums, someone suggested F10. I came up with a slightly more invisible way of doing this...

W=MoveForward | set Engine.PlayerInput MouseAccelThreshold 0.0 | set Engine.PlayerInput MouseSmoothingMode 0

Now as soon as you hit the forward key W your mouse is good to go, you don't have to do a separate key bind for it.

JasonPC
04-24-09, 07:04 PM
I've never noticed mouselag in this game, anyone else?

AngelGraves13
04-24-09, 07:51 PM
I've never noticed mouselag in this game, anyone else?

You probably don't use high dpi mice with 1ms delay.

JasonPC
04-24-09, 08:57 PM
I had a Logitech G7 though I'm not sure what the delay time was on it.

Alaa
04-24-09, 09:10 PM
Mouse control felt weird to me.

AngelGraves13
04-24-09, 09:45 PM
This fixes it almost completely. Mouse Acceleration still cannot be disabled during cut scenes, but during the rest of the game it is fine as long as you bind the command to a key and press it after a game/level load.

skank
04-25-09, 02:57 PM
I tried this and I still get wierd movement in game and I can still move my mouse really slowly without it registering movement, G9 with latest drivers.

SH64
04-25-09, 07:14 PM
Too late :(

AngelGraves13
04-26-09, 04:29 AM
I tried this and I still get wierd movement in game and I can still move my mouse really slowly without it registering movement, G9 with latest drivers.

You need to hit F10 after every level/saved game load.

Load a saved game, hit F10 and move around. Make sure your sensitivity isn't at 1.