View Full Version : glx missing on ubuntu 9.04 64bit with 9600gt

07-01-09, 09:27 PM

As per the instructions given by 'zander' at http://nvnews.net/vbulletin/showthread.php?t=46678 on August 2002.

>> 1) If you have a stability problem, please read this thread first:
>> http://www.nvnews.net/vbulletin/showthread.php?t=58498

As far as I can tell, stability is not my issue.

>> 2) Please search the NVIDIA Linux (or FreeBSD) Forum for existing threads discussing the
>> problem you are seeing, it may have been resolved (or a workaround may have been found). If you
>> can not find such a thread, please start a new thread - it is really hard to keep track of
>> bugs/problems if they are discussed in generic threads (such as '1.0-8756 for Linux x86-64
>> released').

I have searched many forums for solutions to my problem, but none of them seem to work. Furthermore, I am not confident that the solutions I have attempted were carried out correctly.

>> 3) Please always include a detailed description of the problem (both when starting a new thread
>> and when posting to existing threads), as distinct problems can have nearly identical symptoms
>> (e.g. black screens, hung X servers, ...). Reliable reproduction steps are especially useful.

I have a P5Q Pro motherboard and a 9600gt video card. I am trying to create a fully functional 64bit ubuntu 9.04 installation (ubuntu-9.04-desktop-amd64.iso). Upon installation of this distribution, the login screen successfully loaded and I was able to login to the desktop environment. I edited /etc/apt/sources.list to include more and began to install many packages using apt-get. I don not know if you need these or what the relevant packages are for the nvidia driver. However, I installed all the ones that were recommended to me by the programs I was trying to install and also by the forums I browsed. Then I downloaded the file 'NVIDIA-Linux-x86_64-185.18.14-pkg2.run' from the nvidia website and executed the following commands.

ctrl alt f1
/etc/init.d/gdm stop
telinit 1
sh NVIDIA-Linux-x86_64-185.18.14-pkg2.run

I said yes to everything except to have the X configuration overwritten. I did this because in a previous ubuntu installation it caused the system to boot into a text based recovery mode and I was unable to access the x server. I didn't know then what I know now about reseting the /etc/X11/xorg.conf file.

Anyway, I restarted the computer and attempted to find the new driver in (System > Administration > Hardware Drivers). When 185.18 was not found in that list I decided to enable the 180.44 driver.

Restarting and configuring (System > Administration >NVIDIA X Server Settings) allowed me to setup my dual monitor display. I have done many things since then, but as it stands now the packages marked as installed in the 'Synaptic Package Manager' can be found in the file packages in info.bz2

My problem is that when I look at the OpenGL/GLX Information entry (System > Administration >NVIDIA X Server Settings) I see this

Fail to query the GLX server vendor.

Further investigation with the command line queries can be found in the file command-outputs in info.bz2

I have tried several things including reinstalling using envy, adding additional modules in xorg.conf, loading dri, disabling dri, loading dri2, disabling dri2, enabling composite, disabling composite, enabling renderaccel, disabling renderaccel, and other things that I can't remember in the xorg.conf

None of my actions change the behavior of my system. Installation of anything that needs the graphics card results in the same 'glx' error when I try to run them. Also, compiz is installed, but adjusting settings in the 'CompizConfig Settings Manager' does not do anything. Furthermore, switching from the 'metacity' to the 'compiz' window manager causes most window interactions to freeze until I switch back.

>> 3a) Please always include a copy of an nvidia-bug-report.log file, which can be generated
>> with the `nvidia-bug-report.sh` script shipped with the NVIDIA Linux/FreeBSD graphics drivers
>> and installed in your PATH; the log file will be placed in the current working directory.

It is attached in the info.bz2 file.

>> 3b) In case of NVIDIA Linux graphics driver installation problems (when using one of the official
>> .run installers), please attach the `nvidia-installer` log file, /var/log/nvidia-
>> installer.log.

It is attached in the info.bz2 file.

>> 3c) If you have collected additional information, but are not sure if it is relevant /appropriate,
>> please attach it, anyway.

I have included my current xorg.conf file in the info.bz2 file.

I hope you can help me. Besides my graphics driver, I have everything setup.

07-01-09, 09:36 PM
Hello again,

I forgot the files that contains my packages.

A search for 'nvidia' shows:

A search for 'headers' shows:

A search for 'glx' shows:

07-03-09, 06:07 PM
So you know that there is a Linux section to this forum, yet you don't post about your issue in it. :wtf: