PDA

View Full Version : Looking for a nVIDIA bios (Creative or reference)


eL_PuSHeR
06-25-03, 12:37 AM
Hi, all

I'm desperately looking for a bios upgrade for my GeForce4 Ti4200 (Creative) because I'm having some weird palette issues with some games. I've tried several detonator versions. I've checked my bios settings. I've tried running these games (old DOS games) from windows and from real MS-DOS. Still the same. So I think it's a bios issue. Running Ray Adams Bios Editor, says that my vendor IDs match Micro-Star International Co. Ltd, which I don't know why because the card is a Creative 3DBlaster4 Titanium 4200. Do you know any web page where I can download bioses? www.x-bios.3dgames.ru/ seems to be down.
TIA.

AthlonXP1800
06-25-03, 02:32 AM
Well I has Creative Geforce 4 Ti 4600, I dont have any problem with original BIOS 4.25.00.22.47 and Detonator 44.65. I never flashed the BIOS since bought the card last year cos Creative told in Creative forum that they felt it not necessary to released BIOSes because the cards did not shown up any problems, if here are problems, then they will post the BIOSes on the site. So yes Creative cards are made by MSI, it the same cards. I gave it a test to download MSI Live Update 2 program from MSI site and run Live VGA Driver to see if it will detect my card. Yes it detected.

VGA Card Information:

VGA Card Manufacturer MSI
VGA Card Model Name MS-8872 [C3]
VGA Card BIOS Vendor NVIDIA
VGA Card BIOS Version 4.25.00.22.47
VGA Card Driver Version 4465

So you will need to backup your VGA BIOS first before flash the BIOS, you can flash NVIDIA reference BIOS too, I think it will be easier to use MSI Live Update 2 program to flash it, I suggest you to read Geforce FAQ with 2 question about VGA BIOS first.

http://www.technologyvault.co.uk/geforce/faq.php?list=categories&prog=gef&lang=en

Download MSI Live Update 2:

http://tw.msi.com.tw/autobios/seriesexe/liveupdate2.exe

eL_PuSHeR
06-25-03, 09:09 AM
Thank you very much for the quick reply AthlonXP1800, I'll try those things you mention and will post back.

gstanford
06-25-03, 10:34 AM
Your Creative's cards BIOS matches MSI specs because MSI manufacture the card for Creative.

You could possibly try an MSI BIOS - I don't know if Creative have anything weird added to their BIOS or not.

Try going to www.msi.com.tw and asking in their graphics card forum. Someone in there may know.

AthlonXP1800
06-25-03, 12:00 PM
Originally posted by gstanford
Your Creative's cards BIOS matches MSI specs because MSI manufacture the card for Creative.

You could possibly try an MSI BIOS - I don't know if Creative have anything weird added to their BIOS or not.

Try going to www.msi.com.tw and asking in their graphics card forum. Someone in there may know.

I think the only thing changed with MSI BIOS to Creative card is the MSI and Creative ID number, or maybe MS-8872 [C3] - C could mean Creative, OEM number 3?

I did tried searched MSI forum about Creative so none found.

eL_PuSHeR
06-26-03, 08:14 AM
I just downloaded and flashed a reference bios and I got a garbled screen. Good thing I dumped my bios before. Reflash it back and now I am waiting for Creative/MSI to release something.

AthlonXP1800
06-26-03, 03:53 PM
Hmmm well it may seem that your Creative 4400 card is have a defect, you may try email Creative to RMA the card to Creative for replacement.