PDA

View Full Version : Can't delete folders


dreavus
11-23-09, 07:18 PM
I can't delete D:\Users, D:\Windows, and D:\Program Files. they are on an old drive with a lot of data I want too keep. I can't store it else where so I cant reformat the drive.

Albo
11-23-09, 07:42 PM
That doesn't make too much sense. If you want to keep the data, why do you want to delete it?
I am 100% sure that windows blocks deleting major folders like that. What exactly are you trying to do?

dreavus
11-23-09, 07:52 PM
I moved all the files I wanted to save it on a folder on to the root. I want to delete everything else on the drive but the saved folder.

Q
11-23-09, 08:20 PM
1. Take ownership (NTFS) of directories.
2. Give your user full control under NTFS.
3. Try to delete
4. Restart computer and try to delete again.

ViN86
11-23-09, 08:21 PM
Use command prompt. Right click on command prompt and run as administrator. Then type the following (hit return after each entry):


D:
rmdir Users
rmdir "Program Files"
rmdir Windows


After, type dir to make sure they've been deleted. If they've been deleted, they won't be listed.

Usually, command prompt as Admin will override everything.

supra
11-23-09, 08:41 PM
1. Take ownership (NTFS) of directories.
2. Give your user full control under NTFS.
3. Try to delete
4. Restart computer and try to delete again.

yeh i reckon its that too. probs got old ntfs permissions still on it. take control of permissions and try again.

ViN86
11-23-09, 08:56 PM
Admin command prompt doesn't care about the privileges :)

dreavus
11-24-09, 10:30 AM
1. Take ownership (NTFS) of directories.
2. Give your user full control under NTFS.
3. Try to delete
4. Restart computer and try to delete again.


When I was tryig to do this on my own thats some of thie things I got. I think I need to do step 2 but not sure how.

Use command prompt. Right click on command prompt and run as administrator. Then type the following (hit return after each entry):


D:
rmdir Users
rmdir "Program Files"
rmdir Windows


After, type dir to make sure they've been deleted. If they've been deleted, they won't be listed.

Usually, command prompt as Admin will override everything.


Microsoft Windows [Version 6.1.7100]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>D:

D:\>rmdir Users
Access is denied.

D:\>

einstein_314
11-24-09, 11:09 AM
1) Right Click on the folder in question > Properties > Security Tab > Advanced Button > Owner Tab > Edit Button > Choose your account > OK > OK
2) Back on the Security Tab in folder properties, click on Edit to change permissions
3) Select your account and check Allow for all options.
4) Delete folder

Revs
11-24-09, 11:16 AM
I'm not 100% sure, but I think it can be done in Disk Cleanup. I know if you reinstall Windows and don't format the drive, the old Windows folder is saved as Windows.old in the drive and you have to delete this way.

dreavus
11-24-09, 12:59 PM
1) Right Click on the folder in question > Properties > Security Tab > Advanced Button > Owner Tab > Edit Button > Choose your account > OK > OK
2) Back on the Security Tab in folder properties, click on Edit to change permissions
3) Select your account and check Allow for all options.
4) Delete folder

Worked for the Users folder, but not working for the others.

I'm not 100% sure, but I think it can be done in Disk Cleanup. I know if you reinstall Windows and don't format the drive, the old Windows folder is saved as Windows.old in the drive and you have to delete this way.

I installed Windows 7 on a different hard drive. Its smaller than my main one, it was for testing purposes. I decided to stay with it, and instead of reinstalling 7 on my main drive, keep win 7 on the smaller drive and use the main drive for storage.

ViN86
11-24-09, 01:15 PM
Did you run the command prompt as administrator? I guess the real question is does your user even have Administrative privileges?

Also, you're sure you're deleting the correct Windows folder right?

dreavus
11-24-09, 01:35 PM
Did you run the command prompt as administrator? I guess the real question is does your user even have Administrative privileges?

Also, you're sure you're deleting the correct Windows folder right?

yes for all 3.

*EDIT* Ok I think I found the problem. for some reason, I have full control of the 2 folders, but not all the files in side them. I an edit the permission of each file and it will delete them while saying I cant before doing so. how would I set permission on all fiules and folders on the d drive?

*EDIT2* ok all gone! but the hidden boot folder and System Volume Information still cant be deleted, but those too only hold 12.9 MB its not a worry.

K007
11-24-09, 04:22 PM
http://www.nvnews.net/vbulletin/showthread.php?t=141469

you run into the same issue as i have.

had vista on hdd1, installed w7 on hdd2, u want to keep w7 now and remove vista from hdd1/perm, but you cant format hdd1 because it has the system boot (mbr) information on hdd1.

i found some links on my thread that might come handy for you, but i haven't tried it myself yet. basically you have to move the mbr to the hdd2 w7 drive. you can see on disk management -> hdd, you will notice hdd1 is indicated as the System, so you can't format it/etc.

einstein_314
11-24-09, 07:26 PM
Umm, why don't you just format the drive? If you already moved all the files you want to keep off of it....just format it.

K007
11-24-09, 10:17 PM
u can't format a drive with the 'system' partition.