PDA

View Full Version : Jade Empire Jerky


Greg
12-30-09, 07:10 PM
Just bought Jade Empire on Steam. No matter what graphics setting, the game is jerky. Just rotating the camera has a jerkiness or stutter to it.

Fraps shows constant 30 or 60 frame rate depending on 'ClampFPS=1' JadeEmpire.ini option and vsync.

When spinning or moving quickly, the animation almost looks like it jumps back then forward. Unplugging Xbox 360 controller has no effect.

Edit: Although it may appear as an input issue, for example, don't move the mouse so fast, the jerky camera movement occurs during cinematic cut scenes also.

Google shows other people with the same problem, but not working solution.

System:
Windows 64
4gb ram
Intel Q6600
nVidia GTX 275
xbox controller, joystick

Bah!
12-30-09, 07:32 PM
Just bought Jade Empire on Steam. No matter what graphics setting, the game is jerky. Just rotating the camera has a jerkiness or stutter to it.

Fraps shows constant 30 or 60 frame rate depending on 'ClampFPS=1' JadeEmpire.ini option and vsync.

When spinning or moving quickly, the animation almost looks like it jumps back then forward. Unplugging Xbox 360 controller has no effect.

Google shows other people with the same problem, but not working solution.

System:
Windows 64
4gb ram
Intel Q6600
nVidia GTX 275
xbox controller, joystick

Yeah, I'm having this same problem. Constantly 60 fps but gameplay is choppy as hell.

Eliminator
12-30-09, 08:13 PM
the game was made for 30fps and so are the animations... leave vsync on and keep the clamp to 30fps and enjoy the game

I believe it also says this in the readme file

Greg
12-30-09, 08:39 PM
the game was made for 30fps and so are the animations... leave vsync on and keep the clamp to 30fps and enjoy the game

I believe it also says this in the readme file
Doing that. All settings are default, game is locked on 30fps. Camera and movement stuttery / jerky / laggy to make it almost unplayable. I might make a video to demonstrate.

I also notice the CPU affinity is already set to single core. Still looking for a solution.

Eliminator
12-30-09, 08:55 PM
try running it in windows xp compatibility mode... im not sure how you can do that on steam

Greg
12-30-09, 09:02 PM
Here's what it looks like:
http://www.youtube.com/watch?v=OJgPFZh3UTI

try running it in windows xp compatibility mode... im not sure how you can do that on steam
I could not get XP compatibility mode to start, however Run As Administrator runs but does not help.

Bah!
12-31-09, 12:47 AM
the game was made for 30fps and so are the animations... leave vsync on and keep the clamp to 30fps and enjoy the game

I believe it also says this in the readme file

Except that it's the exact same at 30 fps as it is at 60 fps...choppy as hell.

Greg
01-05-10, 12:10 AM
korokoro suggests in this thread (http://forums.steampowered.com/forums/showthread.php?t=982455&page=2) to disable the Steam overlay.
All I had to do was disable the Steam overlay (File > Settings > In-Game tab > Uncheck "Enable Steam Community In-Game" if you don't know) and the framerate jankiness went away.
It didn't work for me, but seemed to help at least one other person. Worth a try.

crainger
01-05-10, 01:06 AM
I had this problem ages ago on my Nvidia 7 series. I believe it's a driver issue. I had to go back to an older set of drivers. Probably not a solution for us who now have 260GTX though. ::(:

Hopefully a better solution is found as it's a killer game. Hopefully the Steam sale gave it a boost and a small fix is found by either Nvidia or Bioware.

Greg
01-05-10, 08:07 AM
Interesting crainger. We could certainly report this to the big nV if we found driver versions that do and don't work. I notice the Steam forum thread lists Ati users with what appears to be the same problem.

omzig
01-05-10, 08:22 AM
Id been having a similar problem this week on replaying Turok (2008) but after setting the Prerender limit to 0 via nHancer its been super smooth,i know its a diffrent game engine/rendering pipe (as i recall JE is opengl?) but it might be worth giving it a try

nomec
01-05-10, 08:27 AM
I remember having this issue originally. Did we confirm that it has to do with the fact that the game is capped at 30 fps? I think you can go into the config files and change the max fps up to 60 so it's much smoother. I cannot remember exactly what I did since I installed the game over 2 years ago and finally got around to finishing it on Sunday.

edit: nevermind I read through some of the other responses above more closely and I guess that isn't the problem. All I know is that I tried the game on Sunday and the only modification done was forcing AF in the control panel, and the game was working fine so I am pretty sure I messed around with the config files to make it work well originally.

Greg
01-05-10, 11:22 PM
I am having success with Steam overlays disabled. However I had to reboot, not just restart Steam. I've only tested briefly, will test some more later, but the jerkiness was gone.

Greg
01-06-10, 09:00 PM
The final solution for me was to merely reboot the PC. I can re-enable the Steam overlay. I rarely reboot, typically only when changing hardware.

Bah!
01-07-10, 02:25 AM
The final solution for me was to merely reboot the PC. I can re-enable the Steam overlay. I rarely reboot, typically only when changing hardware.

Yeah, I was going to post that i've had Steam overlay turned off for since i installed it, but the reboot worked...thanks. :)

Like you i rarely reboot my computer and hadn't done so since long before i installed Jade Empire.