PDA

View Full Version : BioShock stuttering


saumilsingh
03-08-10, 01:38 PM
This is the demo that I am playing, but I want to figure out how to fix this before I download the full game on my 1Mbit connection only to find that it's stuttering :(.

My problem:
Everytime I enter a new area, the game becomes a 15-20fps slideshow for a few seconds and then jumps back up to 60fps.
During these stutters, my HDD isn't being thrashed at all.
I even tried switching to the lowest details to check if I was running out of VRAM, but the stutters were present even with the lowest texture details.

The demo included a 'timing fix' for AMD processors, but I found out that that's just the Dual-Core Optimizer and I already have a much newer version of that already installed.

My PC:
Athlon 64 X2 4800+
GeForce 9800GT 512MB (195.62 drivers)
2GB DDR667 RAM

Nothing is overclocked.

JasonPC
03-08-10, 08:26 PM
Have you tried it in DX9?

bob saget
03-08-10, 08:46 PM
strange, it worked fine with my 8800GTS i had. Have you installed the latest DirectX Redists?

K-1
03-08-10, 09:03 PM
I can't offer any help, but I can say I had the exact same problem when I upgraded my CPU to a Phenom II X3 720 (paired with an 8800GT). The game had run just fine when I was still on an Athlon 64 3700+, and all other games run with no problems, so I couldn't understand what was wrong.

Actually, I think I recall finding a post on the Nvidia forums claiming that the stuttering was due to a driver problem, and that it was necessary to use older drivers for Bioshock. Never bothered acting on that, just uninstalled the game instead :o.

crainger
03-09-10, 12:32 AM
Try setting the power profile to performance and/or turn off all Cool and Quiet options in Windows or even better, the BIOS. Newer AMD CPUs seem to have an issue where they take a little longer to speed back up. I see this on my AMD HTPC. During a level load the CPU works less and slows down, back in the action it takes a little while to get back upto 100%.

I'm assuming when you say new area you mean level load? If you mean a new room, then you have a problem with the PC steaming the game assets. If that's the case, drivers are the most likely cause and you'll have to experiment. ::(:

saumilsingh
03-09-10, 02:55 AM
^ Cool & Quiet is already disabled from the BIOS.

And I mean that it's stuttering when entering a new room, not loading a new map.
If it's a driver issue, which are some of the drivers that you guys know run BioShock perfectly?

At this point, I am thinking that the demo is way past its life expectancy and compatibility with newer drivers has been broken beyond recognition. And that the full version won't have these problems.

crainger
03-09-10, 04:40 AM
It's possible it's a demo issue. I'm using the 196.34 drivers. Just played Bioshock 1 from start to finish with 2x2 SSAA perfectly. Now playing Bioshock 2.

saumilsingh
03-09-10, 05:20 AM
I hope :(.
Thanks all anyway.

Kemo
03-09-10, 07:37 AM
its not a demo issue. I have the same problem. I'm seeing people with single-cores saying that they didn't have a problem until they upgraded to multi-core. Try disabling that "Threaded Optimization" for the Bioshock profile in the Nvidia Control Panel (for nvidia users).

saumilsingh
03-09-10, 04:44 PM
^ Didn't work :(.