PDA

View Full Version : How to force disable page file clearing?


Crow_Nest
04-11-10, 12:08 PM
Ive had a few installations of windows 7 where by my shutdown can take up to 5 minutes. And this only starts to happen after installing my applications so its got nothing to do with the drivers. The problem is this doesnt happen all the time with every installation of windows i have, so i cannot determine the cause of the problem. It cant be my softwares because i install the same ones all the time, and windows works just fine.

So after googling a bit i came across this forum which helped me fix the issue. http://www.sevenforums.com/performance-maintenance/32317-very-slow-shutdown.html

[Start] [Run] [Regedit]
Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management
Modify/Create the Value Data Type(s) and Value Name(s) as detailed below.
Data Type: REG_DWORD [Dword Value] // Value Name: ClearPageFileAtShutdown
Setting for Value Data: [0 = Clear Page File Disabled / 1 = Clear Page File Enabled]
Exit Registry and Reboot

So it seems that windows somehow triggered the page file clearing, disabling it solved my problem. But now the thing is, everytime i go back to windows to run/install/uninstall something it re-enables by itself again. I dont have this issue on my other PC, and i checked to see that page file clearing is already disabled by default.

Is there anyway to FORCE clear page file to disable? Its a pain to wait a decade for my laptop to shutdown.

t3hl33td4rg0n
04-11-10, 08:32 PM
If you can't trace the application or driver causing it to re-enable, then what you can do is disable write permissions to that registry key.

Although, I don't know what kind of consequences this will have with the other entries in the key....


Right-Click the key, click permissions.
Click advanced, uncheck the box for "inherit from parent the permission entries that apply to child objects.
Click remove on the popup window after unchecking, the permission entries should be blank now.
Click on add, click on advanced, click on find now - highlight system and click ok, then click ok again.
You should be at the permission entry window, click on deny for Full Control, then click on allow for Query Value, then check the box at the bottom for "apply these permissions to objects and/or containers within this container only", click ok.
Repeat the previous two steps and apply the same permissions for the Administrators group.
fin


This will effectively deny the system or process acting on the administrators behalf to change any entry inside this key.

Hope this helps!

Crow_Nest
04-12-10, 03:35 AM
Nevermind i managed to find the cause of the problem. I set my privacy eraser to remove windows SWAP files which causes the page file to re-enable.

But thanks for the tip, will keep that in mind. :D

t3hl33td4rg0n
04-14-10, 05:16 AM
Nevermind i managed to find the cause of the problem. I set my privacy eraser to remove windows SWAP files which causes the page file to re-enable.

But thanks for the tip, will keep that in mind. :D

Good, because my suggestion is a "dirty" trick.