PDA

View Full Version : GTX470 occasionally black screen and hard freeze


Milena
08-09-10, 02:12 AM
Hi there

I got an EVGA GTX470 for a couple of weeks now and sometimes my desktop just turns into a black screen and hard freezes my pc. This never happens when the card is under heavy load e.g. gaming, cuda, benchmarks. It seems to happen when the card is switching to a lower power profile when its set to adaptive power mode. This issue is operating system independent as far i can say. I had it on Arch Linux with the 256.35 Linux driver as well as latest Windows driver on Windows 7 x64. I never had this problem with my old GTX275. Is this a sign of a faulty card or a driver bug with power modes ? The card works perfect and reliable at maximum performance when playing games. The last crash occured after running Furmark, when the card cooled down and (probably) entered a lower power mode. Temperatures are alright, 39C idle, 75-80 when playing and 90 Furmark. I recently installed a X-Fi Titanium Soundcard and they share the same IRQ but i doubt that will lead to problems like this.

Any suggestions ?

Thanks in advance

DiscipleDOC
08-09-10, 08:16 AM
You stated that this problem was o/s independent...what does that mean? Do you mean that it is doing this in Windows and not Linux, Linux and not Windows....?

If it's one of the above, I would totally wipe the driver from your machine, and re-install it. If it's doing this on both o/s, then you may want to replace the card--especially if it's not doing it with another card.

Milena
08-09-10, 10:07 AM
I had it on both OS as they share the same driver code mostly. Its questionable if this is really a faulty card because its 100% reliable under max load, i left Furmark and other stress-tests running and everything was fine. Playing Metro 2033 for hours which really pushes the card didn't cause any problems either. These freezes are rare and far between but they only occur in low power modes when i work on the desktop.

Should i RMA and hope the replacement card don't have this problem ? I'm a bit scared i send it in and evga don't trigger the bug and declares my card healthy as its very rare.

Dazz
12-07-10, 01:18 AM
RMA mate my GTX260 was doing the same since I got it and died the other day.