PDA

View Full Version : 45.20 and ALI Magik -- Confusing


dys
07-31-03, 04:58 AM
Hi all,
Right I'll cut straight to the chase, I've got an iwill XP333-R mobo and an ASUS V59950 5900 FX. As you may be aware (or maybe not) ALI Magik northbridges and detonators aren't a happy pair as ALI have screwed up their AGP functionality. Anyway to get half way decent performance a flag must be set in the registery for the detonators(EnableAliAGP=1), I do this via rivatuner.

Now, every version of detonators so far gives different values of Total Local Video Memory,Total Local Texture Memory and Total AGP Memory(from 3dbenchmark) before the flag is enabled (normally something like 32Mb, 59mb, 0Mb). With 44.03 dets after the flag is set the values change to 64Mb, 64Mb and 126Mb, which I thought was the correct values??

But with the 45.20 dets the values start at 0Mb, 0Mb, 0Mb and after the flag is set go to 128Mb, 128Mb, 254Mb. After benchmarking I get a big increase in performance with no noticable side effects, i.e. +~700 3d2003 points +~1500 Code creatures points etc etc.

I was wondering :
1. What are the memory values everyone else gets with their FX5900 128Mb?? (should it be 64,64,126 or 128,128,254??)

2. Why is it only the 45.20 that release all my cards potential?
(i.e. WTF is going on??)

3. What are other people doing who own an ALI magik northbridege??

Other dets (44.90, 44.67,44.72 etc) all give different initial mem readings but onlygive 32,32,64 after the flag is set, therefore performance sucks??????

Cheers dys.

saturnotaku
07-31-03, 07:08 AM
Originally posted by dys
3. What are other people doing who own an ALI magik northbridege??

I have no idea and a whole lot of other folks here won't know either. You're the first person I've seen on these boards in a long time (and I've been around here 2.5 years) who owns an ALi Magik 1.

dys
07-31-03, 08:10 AM
I obviously spoke to soon when I said there were no side effects !! Now when I try and boot to windows I get an lsass.exe error before the login box appears :) the system then reboots. If I go into safe mode, remove the driver and reboot its fine. The 45.20 dets are the only driver that have this prob, but they are the driver that gives the best performance :(

Anyway, what do others get in their Total Local Video Memory,Total Local Texture Memory and Total AGP Memory from 3d benchmark when using a 128Mb FX5900 ???? I just want to know if it should be 64, 64, 128 or 128, 128,256 ??

Cheers dys