PDA

View Full Version : Nvidia GeForce 275.33 WHQL drivers


Pages : [1] 2

DSC
06-01-11, 06:07 AM
Nvidia has released new official GeForce WHQL drivers.

Desktop
http://www.nvidia.com/object/winxp-275.33-whql-driver.html

http://www.nvidia.com/object/winxp64-275.33-whql-driver.html

http://www.nvidia.com/object/win7-winvista-32bit-275.33-whql-driver.html

http://www.nvidia.com/object/win7-winvista-64bit-275.33-whql-driver.html

Notebook
http://www.nvidia.com/object/notebook-win7-winvista-275.33-whql-driver.html

http://www.nvidia.com/object/notebook-win7-winvista-64bit-275.33-whql-driver.html

grey_1
06-01-11, 10:01 AM
Thanks DSC.

I can't adjust 3D convergence with the 260.71s so hopefully these will fix that.

grey_1
06-01-11, 10:30 AM
Ah was there an issue with that? Last time I've tried 3D, that setting seemed locked for me as well... I don't remember the driver I used though.

I couldn't find much on it, mostly blu-ray that folks can't adjust on. I always thought it was something I was doing wrong, but resetting shortcuts, reinstalling drivers etc never worked.

I'll post results after getting these installed tonight. :)

Vardant
06-01-11, 10:51 AM
Aren't these just WHQL'd 275.27?

Yaboze
06-01-11, 01:55 PM
No, there are some changes, including some Witcher 2 fixes mentioned in the notes.

FlakMagnet
06-01-11, 02:42 PM
"The Release 275 beta driver v275.27 can cause significant performance drop in The Witcher 2. This issue has been resolved in v275.33 drivers."

Apart from that, they look the same as the 275.27 betas from the notes.

Vardant
06-01-11, 03:07 PM
Haha, I've completely missed that, because I always just jump to the performance numbers. Thanks guys, gonna install them now.

FlakMagnet
06-01-11, 03:56 PM
They also fix an issue of flickering shadows and flickering 'yellow pyramids' I had in some of the DiRT 3 menus (when you select 'View Car' for example and pan about using the arrow keys). This problem only seemed to affect the menus and not while driving, so not really a significant fix.

Sean_W
06-01-11, 04:17 PM
Good for Crysis 2 as well. :)

nekrosoft13
06-01-11, 04:51 PM
Aren't these just WHQL'd 275.27?

no, they would not change version number, if nothing was changed.

red777star
06-01-11, 06:37 PM
These still suck. Crysis 2 still flickers for SLI GTX280 setup.

Sean_W
06-01-11, 08:50 PM
New AA modes:

8x CSAA, 16x CSAA, 16xQ CSAA, 32x CSAA. :)

Pennyboy
06-02-11, 04:34 AM
Is 16xAA fixed and working in Dirt 2/3 with this driver?

Erda
06-02-11, 02:21 PM
I can't even enable SLI with these drivers. No matter what I try it doesn't work. I have tried a complete reinstall of the drivers and unistalling the old ones. I have tried switching the video cards. I have tried a different SLI bridge. Low and behold when I reinstall 270.61 SLI works again. Am I the only person that has problems getting SLI to work with these drivers?

GitDat
06-02-11, 05:13 PM
These still suck. Crysis 2 still flickers for SLI GTX280 setup.

Same for me with my setup :thumbdwn:

[AK]Zip
06-02-11, 06:04 PM
I can't even enable SLI with these drivers. No matter what I try it doesn't work. I have tried a complete reinstall of the drivers and unistalling the old ones. I have tried switching the video cards. I have tried a different SLI bridge. Low and behold when I reinstall 270.61 SLI works again. Am I the only person that has problems getting SLI to work with these drivers?

SLI works just fine for me. I just installed these and ran a few benchmarks.

grey_1
06-03-11, 07:54 PM
Rolled back to the 270.61s.

For some reason these are causing horrible performance in Witcher 2 for me on a GTX 480. Stuttering, barely playable fps etc. All with the entire nvcp at default settings and in game settings medium or lower.

On the 270.61s with the 'high' graphical preset it's smooth as butter.

red777star
06-03-11, 11:09 PM
Same for me with my setup :thumbdwn:

I found a problem. If you pull out GTX 280 you use for physics flickering stops.

fasedww
06-04-11, 07:42 AM
I found a problem. If you pull out GTX 280 you use for physics flickering stops.

Just disable the physics card in device manager instead.:)

red777star
06-04-11, 05:29 PM
Just disable the physics card in device manager instead.:)

Haha duh

shadow001
06-04-11, 06:37 PM
It was blue screen after blue screen wih these and using 3 GTX580's in triple SLI and 3 displays, even when just running windows and web surfing, so i'm back to the beta 275.27's and everything works fine now....Goes to show that WHQL means these days..;)

Blacklash
06-04-11, 11:21 PM
EDIT:

I tried these in The Witcher 2 and DA 2. They're fine for me. Note, I only install the graphics driver and physx, nothing else. I'm getting FPS in the 50s with vsync enabled in Flotsam. I use the ultra preset but disable ubersampling.

http://imageshack.us/photo/my-images/845/w2275a.jpg/

EDIT 2: I do get odd shadows in some areas in DA 2. It's not constant and it didn't show up immediately. 270.61 doesn't do that.

Peoples-Agent
06-05-11, 04:05 AM
Not noticed much wrong with these apart from one strange occurance. Later in the day after installing, just after midnight the screen went black, aero disabled itself. Not long after it came back on. No message in event viewer, no task bar pop ups or errors.

I heard WEI runs itself in the background sometimes after new driver installs? Is that right?

Yaboze
06-05-11, 10:18 AM
These seem fine for me in Witcher 2, but I am in Chapter 2, I haven't tested any other areas.

I don't think WEI runs itself after drivers are updated. My WEI rating was grayed out and I had to re-run it.

DiscipleDOC
06-06-11, 11:50 AM
Rolled back to the 270.61s.

For some reason these are causing horrible performance in Witcher 2 for me on a GTX 480. Stuttering, barely playable fps etc. All with the entire nvcp at default settings and in game settings medium or lower.

On the 270.61s with the 'high' graphical preset it's smooth as butter.

Yea...these drivers are causing black outs in BFBC2. I'm going to have to roll back too.:thumbdwn: