PDA

View Full Version : Stereo mode stopped working (interlacing instead)


Telumehtar
08-21-03, 07:07 PM
I've been using my E-D stereo glasses with the 45.23 drivers for a few days, everything has been working.

Today I tried to use them and instead of page flipping between the left and right images, the card has started displaying the left image on even numbered lines and the right image on odd numbered lines. I.e. it is interlacing them instead of page flipping them:

LLLLLLLL--------
--------RRRRRRRR
LLLLLLLL--------
--------RRRRRRRR
LLLLLLLL--------
--------RRRRRRRR

The LCD glasses are also not being activated.

Why would it do this? Things I've tried:
- switching to analglyph mode and back
- rebooting
- reinstalling the drivers
- changing resolutions and refresh rates

I first noticed this problem when I tried to use the Stereo Viewer program available from the "Stereo Properties" tab. The first stereo image I loaded yielded the error message, "nvstview.exe has generated errors and will be closed by Windows. You will need to restart the program. An error log is being created."

Another image displays but with left and right on two halves of the screen instead of page flipped (or interlaced). It was only when I then tried the Test Application and the Medical Test Image that I noticed the interlacing problem.

System:
Ti4200
Windows 2000 Professional
Iiyama VM Pro 454
E-D Glasses

Any insight into this problem would be greatly appreciated.
Thanks,
Rob.

Filibuster
08-22-03, 10:19 PM
The first thing I would try would be to completely uninstall the stereo driver and the Detonator driver with the 'add/remove programs' control panel, if you haven't done this yet. (you only said you reinstalled them, but that could just be left out)

That usually sets everything back to defaults for me.

The other thing you can try is to take the attached registry file and import it, and see if it helps, in case one of the hidden/confusing registry settings is messed up. I really don't know if this will help, but I do my best. Not a lot of stereo users out there it seems. :) If you go this way I would definately check out all the settings before trying to run it (and maybe even reboot).

At least it's something to try. If you think there is another registry entry you might need to check against, let me know.

Telumehtar
08-23-03, 06:01 PM
Thanks Filibuster! You've fixed it. It seems the registry settings were messed up somehow. I can only assume it is possible to set "interlaced mode" in the registry, and perhaps the stereo viewer did this, but it is not possible to de-select it using the dialogue box.

You're right about there not being many stereo users - even for me it's more of a novelty toy than something I will use all the time, but it's fun, and works well once you get your eyes used to it.

Rob.