PDA

View Full Version : NVidia-ATI OpenGL Compliance Update


Pages : [1] 2

Deathlike2
09-01-03, 06:46 PM
Old Thread:

http://www.nvnews.net/vbulletin/showthread.php?threadid=16099&highlight=OpenGL+Compliance

There's a new version of GLView (if you goto the old thread, there is a link provided to goto the website)...

They've fixed a couple of minor things... including adding an OpenGL 1.4 test..

This test however crashes the program for some reason or another...

OS: Win2k SP4
Video Card: Geforce 3
Driver: 45.23 WHQL

When running the 1.4 Test, there is texture flickering... then it crashes completely.

Anyone with different video cards.. please test this out (I'd prefer a GF3 user test it out, to verify my results)

Current compliance:
1.2 - 100% - 11/11
1.3 - 100% - 9/9
1.4 - 93% - 14/15
1.5 - 50% - 5/10

Other notes:
The report shows this...
No fragment program extension found.
This feature enables per pixel programming (DX8 Pixel Shader) Some for actual or future OpenGL programs may require this extension to run.

If I'm not mistaken... doesn't the GF3 have a pixel shader just like the GF4 and FX? (it'll be weaker, and a lower version, but it exists nonetheless)

Nutty
09-01-03, 07:25 PM
GF3/GF4 have NV_RegisterCombiners, and NV_TextureShaders, which are the equivelent of DX8 Pixel Shaders. They do not support the new ARB_FragmentProgram, which are DX9 class pixel shaders.

Edit: Just ran the program. I get same compliance values as you. I ran the test, the 1.4 was flickery, but did not crash. The programs crashed on exiting though. My personal opinion is that the 1.4 test is just written badly, as is the app, or it wouldn't crash.

Deathlike2
09-01-03, 07:33 PM
I don't anticipate support for stuff that can't be supported in the first place (no big deal)...

I'm just referring to features that DO exist and SHOULD be available via OpenGL 1.4 and before (neither NVidia or ATI has OpenGL 1.5 support)

Nutty
09-01-03, 07:39 PM
Well apparently GF-FX now doesn't support 8bit textures with palletes, and its been dropped from drivers also I believe. ATI never supported it. Technically its a part of GL1.1, but as no developer ever uses it they dropped it.

I guess when they say it supports 1.4/1.5, they mean it supports the features that developers actually use out of 1.4/1.5

Deathlike2
09-01-03, 07:42 PM
That would make some sense...

The 8-bit palette support has been dropped a while back (see the Geforce FAQ)... it's supposed to be a feature for older games... I doubt it's worthwhile anymore with today's graphics cards (since they should be able to run Q3 at about 120+fps)

Spliffstarr
09-01-03, 10:40 PM
actually the new cards from ATI are opengl 1.5, 2.0 compliant. ATI said they will not expose those functionality until the opengl board finalize those standards...

991060
09-02-03, 03:54 AM
this is what I got on 9700Pro with Cat 3.6

http://bbs.gzeasy.com/uploads/post-1-1062488707.gif

Sazar
09-02-03, 04:17 AM
Originally posted by Spliffstarr
actually the new cards from ATI are opengl 1.5, 2.0 compliant. ATI said they will not expose those functionality until the opengl board finalize those standards...

is it to be assumed that the firegl series does have the functionality exposed in its drivers ?

since it is a developer level product ?

ShoobyDooblyDoo
09-02-03, 04:26 AM
FireGL X1 is basically a 9700 while an X2 is a 9800 GPU core. Using the currently new unifed drivers for the FireGL line ends with the same OpenGL Extension viewer results as 9700/9800 users.

Correct me if I'm wrong but when ATI said their product line already would support OpenGL 2.0 I think they meant inclusion from the 9700 (9500 softmods too! :) ) line and upwards, and not just the FireGL product line.

Dazz
09-02-03, 05:21 AM
Nope only the Radeon 9800 & 9600 are OpenGL 2.0 compliant due to the F-Buffer (unlimited instructions)

ShoobyDooblyDoo
09-02-03, 08:28 AM
Thanks for the info :)

Deathlike2
09-03-03, 07:49 AM
The extensions must be written in the drivers before they are compliant...

The hardware itself may be able to support the extensions... but even so... the extensions have to exist in the first place to even determine what is "compliant" or not

Templar
09-04-03, 05:32 AM
any one with an FX Ultra please do this test. I'm curious to see if the OpenGL support is half @ss on it too?! AKA support according to Nvidia PR which doesn't always reflect reality.. but that's kind a hard when you're smoking acid all day :D

Simon

tertsi
09-04-03, 07:22 AM
FX5800 Ultra and det45.23.

v1.2 (100% - 11/11)
v1.3 (100% - 9/9)
v1.4 (100% - 15/15)
v1.5 (60% - 6/10)

zero.TA
09-04-03, 04:44 PM
FX5900 Ultra and det 45.23.

v1.2 (100% - 11/11)
v1.3 (100% - 9/9)
v1.4 (100% - 15/15)
v1.5 (60% - 6/10)

Deathlike2
09-04-03, 05:04 PM
Have any of you guys have probs running the OpenGL 1.4 test?

That's my current concern here.

The test is located in the report tab..

GlowStick
09-04-03, 08:21 PM
Hello,

After installing the new Ca 3.7 OpenGL Extention Viewer reports this.

1.2 11/11
1.3 9/9
1.4 15/15
1.5 4/10

Unless the program is wrong, i do belive we were promiced 'Full OpenGL 1.5 support on the next driver release'

Deathlike2
09-04-03, 08:43 PM
"next driver release" refers to the 3.8... 1.5 OpenGL compliance isn't expect until approximately 4 weeks from now (I believe the ~4 week system kicks in officially this time around)

Phyre
09-04-03, 09:24 PM
On my laptop with a GeForce FX Go5600

1.2 11/11
1.3 9/9
1.4 15/15
1.5 5/10

Drivers are the 43.36

Phyre

GlowStick
09-05-03, 01:14 AM
Originally posted by Deathlike2
"next driver release" refers to the 3.8... 1.5 OpenGL compliance isn't expect until approximately 4 weeks from now (I believe the ~4 week system kicks in officially this time around) No, Next Driver release means 3.7, here is how it you calculate it.

If you release a driver set, and you call them Cat 3.6, then a few weeks later say, "Dont worrie, in the NEXT driver update we will have 100% ogl 1.5 compliance" that acutally dose mean 3.7

Nutty
09-05-03, 03:52 AM
Why does it really matter soo much? No-games are using it yet anyway. Its not like you're gonna get some magical eye candy appearing in games when GL 1.5 drivers ship.

GPSnoopy
09-05-03, 10:27 AM
Is it me or from 991060' screenshot this program doesn't make any diference between required core features and optional extensions introduced with a specific OpenGL version?

If it's the case, it makes the results in percents of this program a bit useless.

GlowStick
09-05-03, 11:10 AM
Originally posted by Nutty
Why does it really matter soo much? No-games are using it yet anyway. Its not like you're gonna get some magical eye candy appearing in games when GL 1.5 drivers ship. Because ATi specificily said they would add it in, and they never did. Its kinda like this and i quote from hellbinder "ATi has THE BEST LINUX SUPPORT EVER" back in jan.

Deathlike2
09-05-03, 11:22 AM
It was a post at http://www.warp2search.net

To summarize what was said
1.5 Compliance will be done in the next version of the Cats... development of the OpenGL drivers for compliance wasn't going to be done before 3.7... (I don't exactly remember the sources)

3.7 WAS NEVER meant to have the update... to say the least.

GlowStick
09-05-03, 11:29 AM
Originally posted by Deathlike2
It was a post at http://www.warp2search.net

To summarize what was said
1.5 Compliance will be done in the next version of the Cats... development of the OpenGL drivers for compliance wasn't going to be done before 3.7... (I don't exactly remember the sources)

3.7 WAS NEVER meant to have the update... to say the least. So what you rember is what he said.

1.5 Compliance will be done in the next set of Cats.

3.7 is the next set of cats.

OH BTW, we are not developing 1.5 for the next set of cats aka 3.7