PDA

View Full Version : EF2 problem


darky
09-26-03, 02:51 PM
Just installed a 9800 np in my system and I used CAT 3.7 driver.
Now I had a weird problem with EF2,the game ran fine without fullscreen anti-aliasing.When I used fullscreen anti-aliasing,the game's framerate droped down to 1fps.
Any suggestions to fix this weird problem ???

digitalwanderer
09-26-03, 02:55 PM
Originally posted by darky
Just installed a 9800 np in my system and I used CAT 3.7 driver.
Now I had a weird problem with EF2,the game ran fine without fullscreen anti-aliasing.When I used fullscreen anti-aliasing,the game's framerate droped down to 1fps.
Any suggestions to fix this weird problem ???
Yeah, go into your video controls-openGL-additional options and enable "Triple-buffering". :)

EDITED BITS: Also, are you using forced AA or application controlled AA? (I can't remember if EF2 had in game AA controls or not. )

darky
09-26-03, 02:59 PM
Thankyou for respond,I will try it later tonite.:)

digitalwanderer
09-26-03, 03:13 PM
Originally posted by darky
Thankyou for respond,I will try it later tonite.:)
I'll check back and see how it went. Heck, I might even re-install the game since it was a pretty good game. :)

darky
09-26-03, 08:47 PM
Well I'm new to ATI control panel thing,under OpenGL tab there is no triple buffering option except Z buffer.
Anyway I just edited window registry under OpenGL to add a key to force triple buffering.I had to admit that triple buffering did improve and smooth out framerate of the game.
For now I played EF2 at res of 1600x1200 and the jaggy edges were not that bad either.But it will be nice if I can find a solution to fix this problem.
Do you think it will help if I install CAT 3.6 ?

SH64
09-26-03, 10:14 PM
Originally posted by darky
Well I'm new to ATI control panel thing,under OpenGL tab there is no triple buffering option except Z buffer.
Anyway I just edited window registry under OpenGL to add a key to force triple buffering.I had to admit that triple buffering did improve and smooth out framerate of the game.
For now I played EF2 at res of 1600x1200 and the jaggy edges were not that bad either.But it will be nice if I can find a solution to fix this problem.
Do you think it will help if I install CAT 3.6 ?

1)the Force triple buffring option is located in the opengl bar .. inside the compatability settings .. if you cant see it , thats mean you didnt installe the 3.7 correctly.
it should really improve the performance like it did in Call of duty demo.

2)EF2 is optimized for nVidia cards , so when you turn the FSAA you will see some poor AA in the game unless you turn on the "nVidia AA" option . and thats what my bro who had a 9700 pro & complained about.

3)to improve the framerate even more just disable the stencil shadows . its already dosent look correct in this game & it just suck frames for nothing.

4)i dont recommend getting back to the 3.6 ! the 3.7 are cool & in worst cases they equals the 3.7

darky
09-26-03, 11:40 PM
You were right though,the driver I got from Guru3d didn't install correctly.I just got Cat 3.7 from Ati website and re-installed the driver and the triple buffering option is there now.
I had figured out my AA problem with EF2,the game's own fullscreen AA was not working right with ATI card.I had to set AA in the ATI panel and disable the game's own full screen AA.Now the game ran so beautifully with 4XAA and 16X Aniso.
Thanks for all the helps.