PDA

View Full Version : new bios my motherboard and got new feature IDE PCI BUS MASTERING what is it ???


b5fan
09-18-02, 04:31 PM
hi,
Got latest bios for my motherbaord and its got a new feature to select disable or enable called IDE PCI BUS MASTERING
jsut wondering what it does and will it improve my system performance ?

Motherboard a ECS K7S5A
new bios

Chalnoth
09-19-02, 12:00 AM
I'm pretty sure that's just an option for enabling/disabling DMA for hard drive access on the integrated controller. Nothing new here.

eL_PuSHeR
09-19-02, 08:52 AM
Just leave it enabled for maximum performance.

FastM
09-19-02, 12:17 PM
I just stuck this "IDE PCI BUS MASTERING" in a Google Search and came up with this.


http://www.pcguide.com/ref/mbsys/buses/types/pciIDEBM-c.html

Smokey
09-19-02, 06:07 PM
Well this is interesting, as when I enable it, I cant load windows :( its tells me that it cant find the boot device :confused: Any ideas would be great. Im using a Maxtor DimandMax 27.5Gb ATA66. Ive tried to find infomation on this problem before, but no luck. I would like to have it enabled as I know my HDD supports Bus Matering.
Thanks in advance.

Chalnoth
09-19-02, 06:10 PM
Well, just check that it's enabled once you get into windows. That's what counts.

Smokey
09-20-02, 04:56 AM
Thats the problem, in Windows it says im using PIO :(

PsychoSy
09-20-02, 05:09 PM
If you have the ECS K7S5A board, you need to run this utility in order to enable UDMA 66/100 transfers. Unzip this file, and double click the SISIDE.EXE (you won't notice any hint of it actually executing but rest assured once you double click it, it did its job and terminated). Reboot afterwords! :)

thcdru2k
09-20-02, 07:03 PM
ehh he has a msi kt3 ultra :), thats what i got, i have it enabled and it defiantely doesn't say pio. make sure you have an ultra ata 100 or 133 cable.

Smokey
09-20-02, 08:06 PM
Originally posted by thcdru2k
ehh he has a msi kt3 ultra :), thats what i got, i have it enabled and it defiantely doesn't say pio. make sure you have an ultra ata 100 or 133 cable.

Cables are fine, used the ones that came with the board, I just find this annoying as I know my hdd is slower than it should be, in my manual it says to enable bus mastering in the bios, and I know my HDD supports it. :mad:

SocketAzzWipe
09-20-02, 10:03 PM
Originally posted by Smokey


Cables are fine, used the ones that came with the board, I just find this annoying as I know my hdd is slower than it should be, in my manual it says to enable bus mastering in the bios, and I know my HDD supports it. :mad:

Also...I think the ATA 100/133 cable can be placed only one way (cant switch the sides)...make sure the blue side is on the motherboard...

Smokey
09-21-02, 04:30 PM
Cable is fine, thing is I build pcs, and this hasnt worked from day one. The only thing I can think of, is that maybe its my HDD? I dont have the money at the moment to buy a new one. No biggy I guess, I'll just live with it until I can afford a new HDD :( Thanks for your replys all the same everyone.

PsychoSy
09-22-02, 05:10 PM
Go to your device manager and change the driver for the PCI IDE Bus. It'll probably be listed as a "VIA PCI IDE Controller". Click the "Update Driver" tab, tell the wizard you want to "choose from a list", and it'll pop up with two compatible drivers, one of them being "Standard Dual Channel PCI IDE Controller". Chose that one and click OK then reboot after it's done.

When Windows comes back, verify that it's using that driver and check to see if it's using UDMA modes instead of PIO. I had to do this with my old MSI K7T Pro 2A when I dropped WinXP in it - I could not get UDMA to work with VIA's drivers at all.

Changing to Microsoft's native "Standard Dual Channel" driver worked. :)