View Full Version : Oddly Slow Performance

11-12-03, 08:07 PM
I just got my 5900, and am running into some odd things, though I can tell it will be a nice card.

Just to for specs:
x2 Xeon 2.4GHz
1.5GB PC1600
BFG 5900

Anyway, I fired up JK2 (High detail) at 1600x1200, with 4xAA and 8x AN, and go an absolutely steady 28fps, not 27, not 29, 28 all the time. I thought it was a bit strange and low, so I fiddled around in the settings and finally turned Vsync off in the game, and On in the driver. All of a sudden, 90fps.

I pulled out an oldie, Descent 3, and did the same thing. I noticed it stuttered a little in D3D, so I switched it to OpenGL mode. What do I get? 28.6fps on the button, and in its case, not 28.5, not even 29, 28.6. No detail settings affect it, so I made sure Vsync was off in the game. Anyway, looking around at old benchmarks I saw original GeForce256's getting 111fps at 1024x768 (no fancy stuff) so I am pretty sure a 5900 can get better than 28.6. Fiddling with turning Vsync off everywhere boosts it to around 60fps. That though, is below my refresh rate anyway.

That sent me back to fiddling with JK2, and I noticed, even with Vsync set to 'Always Off,' and the resolution at 640x480 it never gets above 90fps, in fact at 640, it is basically pegged at 90fps the whole time, like Vsync was on somewhere.

Has anybody run into something like this?

11-12-03, 08:54 PM
Since JK is a Q3A engine game, it looks like you have the com_maxfps setting or its equivalent set to 90, which is the default in Q3A as well. Set it to 0 (don't have the game so I don't know if that is the true command) in a config file or at the console and you'll get as many frames as the card will render.

11-13-03, 11:49 PM

If anyone comes up with something about Vsync please let me know.

Ps 23:4-5

11-13-03, 11:56 PM
If you set the vsync to 0 for d3d it sorted out the bad mouse lagg in UT2003, resolution anything over 1280x1024.

Riva tuner will do that bye the way and It really makes a BIG difference.