PDA

View Full Version : Activision games are bad with ATI hardware


Sotos
11-21-03, 07:41 AM
From
Call of Duty
to
Empires Dawn of Modern world :(

I have from texture corruption to serious CRASHES with Catal 3.9

Activision reccomends Cat 3.7 for these games but i do not want to downgrade..Catal 3.9 play much better some games from Catal 3.7 for my system

while with Nvidia hardware the problems with these games are much less or runs flawless :(

Damn sometimes i hate that i bought an ATI card :(
I hope ATI driver team does something about that or Activision release some patches soon

SH64
11-21-03, 08:00 AM
Its relative my friend ... CoD run as smooth as wind with Cat 3.7 on my ATI card (except a random crash once :o )
while its running good on the nvidia but with far less freamrate while AA is enabled .
Cat 3.7 is the best so far .sometimes you need to revert to old drivers in order to play the games properly .
for Ex. i experianced some tearing a stuttring on NFSU demo with 52.16 Forceware & when i reverted to 45.23 .. everything is running fine & even some other games issues with 52s has gone.

Sotos
11-21-03, 08:08 AM
Originally posted by SH64
Its relative my friend ... CoD run as smooth as wind with Cat 3.7 on my ATI card (except a random crash once :o )
while its running good on the nvidia but with far less freamrate while AA is enabled .
Cat 3.7 is the best so far .sometimes you need to revert to old drivers in order to play the games properly .
for Ex. i experianced some tearing a stuttring on NFSU demo with 52.16 Forceware & when i reverted to 45.23 .. everything is running fine & even some other games issues with 52s has gone.

You maybe are right :(

but downgrading to 3.7 is not a good sollution

I have better IQ with 3.9 and some games like NeverWinterNights or some other games(like Ufo Aftermath) are behaving better with 3.9 from 3.7

What should i do???
I just want a driver that plays all games great
If i downgrade to 3.7 i win better stability with CoD or Empires DOMW but i lose in some others :(

SH64
11-21-03, 08:23 AM
Originally posted by Sotos
You maybe are right :(

but downgrading to 3.7 is not a good sollution

I have better IQ with 3.9 and some games like NeverWinterNights or some other games(like Ufo Aftermath) are behaving better with 3.9 from 3.7

What should i do???
I just want a driver that plays all games great
If i downgrade to 3.7 i win better stability with CoD or Empires DOMW but i lose in some others :(

CoD one of the best FPS game yet ! its worth a downgrading . i'll do anything just to play it & enjoy every second with it .
i reverted from 3.8 to 3.7 just to play it .. & i'll stick with 3.7 until some other good drivers released ... 3.10 maybe

The Baron
11-21-03, 09:46 AM
downgrading to 3.7 is not a good solution? how so? It's the price you pay for having constant driver releases; there will be problems in a few driver sets until the driver team can get around to it.

Fotis
11-21-03, 09:53 AM
Try the hotfix (http://www.ati.com/support/infobase/4291.html) ATI released a couple of days ago.It fixes both the problems you mention.:)That driver is actually CAT 3.10 with WHQL certification pending.
The driver also offers Opengl 2.0 support!

vampireuk
11-21-03, 11:00 AM
For some reason when I updated the cats Deux Ex locks up whenever I try to change the resolution at the start. I rolled back and this is still happening now, I now curse them for robbing me of my Deus Ex joy:mad: :D

Sazar
11-21-03, 12:25 PM
Originally posted by vampireuk
For some reason when I updated the cats Deux Ex locks up whenever I try to change the resolution at the start. I rolled back and this is still happening now, I now curse them for robbing me of my Deus Ex joy:mad: :D

try the hotfix and see if it works...

deus ex works fine for me on my AIW 9700pro with the cat 3.9's and the hotfix

vampireuk
11-21-03, 12:51 PM
No joy with the hotfix, I've tried several different releases and the same. I shall curse ATI from now on:eek2:

If I get the job I'm going for I may just make a new purchase.

Line01
11-21-03, 01:09 PM
This is odd but on my Radeon 9500 The best drivers I ever had was Omega's omega_2407a They ran the fastest and the best of all the drivers even the 3.9. you might try them. They were based on the old 3.2 cats but the worked great. Never a problem:) . with the new drivers every thing froze up.

You don't have a Sound Blaster live card do you?

cavalier
11-21-03, 01:26 PM
The BETA 3.10 Cats. (called a "hotfix" by ATI until WHQL certification by Microsft in December) fix the Call of Duty crashing problem, as well as a host of others.

I tried Deus Ex with these new drivers (which I recommend to everyone with an ATI card) and it runs flawlessly, just as before with the Cat. 3.5 drivers.

You say you tried to hotix drivers (3.10's) but remember, this is a full driver set and you can't install over the top of the old ones...you have to delete the 3.9's and install the hotfix driver as you would any new one.

Did you do this? If not, that may be the source of your grief.

Also, some games need to be reinstalled once you change drivers (don't know why but some games are picky like that) so if the above fails, copy your Deus Ex save games somewhere, delete and reinstall the game, put your save games file back in and try to play it then.

I've had a few games where I've had to do this and it works like a charm.

Best of luck to you and post back with your results.

Sotos
11-21-03, 01:59 PM
I installed 3.7 and crashes are gone with Call of Duty :)
but still some problems remains with Empires Dawn of Modern World :(

but i guess i will try 3.10 because as my <other games> are not working so good

Where can i find them????

Sotos
11-21-03, 03:38 PM
I just installed the 3.10 beta

THEY ROCKKKKK!!!! :D :D

Not only my Activision game problem is solved (like CoD crashes)
but i also notice an increase in performance (especialy in Empires Dawn of the modern world when using complicated shadowing effect):D

The other thing i noticed is my DESKTOP ICONS are have a sharper look from 3.7

I almost tested half my games until now and the 3.10 seems excellent and run stable :D
The 3.10 beta will be staying at my system until 3.10 official arrives...

I guess i will stay with ATI :)

cavalier
11-21-03, 03:41 PM
go to www.ati.com or www.rage3d.com (a great ATI resource, BTW) for the new drivers

Remember, they're called a 3.9 "hotfix" but are actually a full driver install of the BETA 3.10's The "hotfix" is kind of a code name until they get certified by Microsoft next month.

So, the best way to remove your old drivers (which you HAVE to do to install this new set is:

1. Go to control panels & add/remove

2. Remove ATI Control Panel

3. Remove ATI display drivers

4. Use Driver Cleaner (search the web and you'll find it, it's a great free utility that cleans out any remaining display driver files from your old driver set)

5. Restart Computer

6. When windows tries to look for a new driver to install, hit cancel and go to the driver you downloaded, double cllick on it and it'll do the rest automatically.

7. Reboot and enjoy the most stable drivers ATI has released since the 3.5's!!!

cavalier
11-21-03, 03:52 PM
Hey Sotos,

Glad to hear it, man. You beat me to posting the instructions on where to get it but I'm glad you found it.

Yes, your icons are sharper and you're not seeing things....the BETA 3.10's give you a crisper and more clear 2D image than before.

Also, if you play games with ansio filtering you'll notice a BIG difference in how crisp the graphics are now as the ansio has received a boost in this driver as well. Go ahead and check it out with NFS: Underground.

Spread the word, would you, about how great these drivers are so that more people that had problems, like you, can get the help they're seeking and so that the ATI driver team gets the credit they so deserve.

Now, aren't you glad you stuck with ATI?

AngelGraves13
11-21-03, 04:04 PM
just tried them out too....OpenGL 2.0 mmmmm

Sotos
11-21-03, 06:57 PM
Originally posted by cavalier
Hey Sotos,

Glad to hear it, man. You beat me to posting the instructions on where to get it but I'm glad you found it.

Yes, your icons are sharper and you're not seeing things....the BETA 3.10's give you a crisper and more clear 2D image than before.

Also, if you play games with ansio filtering you'll notice a BIG difference in how crisp the graphics are now as the ansio has received a boost in this driver as well. Go ahead and check it out with NFS: Underground.

Spread the word, would you, about how great these drivers are so that more people that had problems, like you, can get the help they're seeking and so that the ATI driver team gets the credit they so deserve.

Now, aren't you glad you stuck with ATI?

I do not have Nfs Underground but i have seen the difference from the rest of my games :)

It seems like a great driver...all games that i have tested run stable and with excellent image quality even better from 3.9 :)
And they are supposed to be beta

I hope these drivers become WHQL really soon :)
the only thing that i am afraid is maybe that microsoft tweaks them and make them screwy :(

I hope their future CAT drivers becomes even more better and "games friendly" like Cat 3.10 is right now

And now that Catalysts will have OPENGl 2.0 support i am sure Nvidia "will run like hell" of creating some Forceware with Opengl 2.0 support also...if they have not done it already

hehehe...NvIdIa :p

AngelGraves13
11-21-03, 10:22 PM
it shouldn't...

Morrow
11-22-03, 10:04 AM
Originally posted by Sotos
And now that Catalysts will have OPENGl 2.0 support i am sure Nvidia "will run like hell" of creating some Forceware with Opengl 2.0 support also...if they have not done it already

why should they do that?

The OpenGL 1.5 specs just got finalized 2-3 months ago. OpenGL 2.0 is far, far away from being completed.

Even Doom 3 does only support OpenGL 1.3, adding OpenGL 2.0 in this stage is completely nonsense.

Sotos
11-22-03, 10:26 AM
Originally posted by Morrow
why should they do that?

The OpenGL 1.5 specs just got finalized 2-3 months. OpenGL 2.0 is far, far away from being completed.

Even Doom 3 does only support OpenGL 1.3, adding OpenGL 2.0 in this stage is completely nonsense.

Because when Nvidia is lacking in something new compared to their competitors
then they run like hell(as soon as possible) to release it also for their cards

example with Nvidia Geforce fx 5800....
When Nvidia find out that ATI with 9800pro was having much better F/ps numbers and with less fan noise they release the 5900 as soon as possible and the 5900 had also 256 bandwidth these time as ATI hardware already had

I am sure they will create a Forceware with Opengl 2.0 support when they find out that ATI is already supporting it from now with their new 3,10 drivers...

The Baron
11-22-03, 11:27 AM
I think you misunderstand; OpenGL 1.5 drivers aren't even really out there. OpenGL 2 is nowhere close to being finished, so they don't have to worry about it until it is.

PenguinJim
11-22-03, 08:04 PM
Originally posted by Sotos
Because when Nvidia is lacking in something new compared to their competitors
then they run like hell(as soon as possible) to release it also for their cards


Shame ATi didn't do that for Digital Vibrance :( ;)