PDA

View Full Version : Metal gear 2 problems


Cotita
01-26-04, 02:38 PM
I have several problems with Metal gear2.

First, sound is horrible, distorted and noise. I disabled hardware aceleration on the sound properties and distortion is gone but its replaced by sttutering mostly with voice.

On the video side I get graphic corruption with the cars on the bridge during the intro sequence when I start a new game.

At resolutions higher than 1024x768, again during the intro sequence in the bridge when Snake is cloacked, its not transparent but translucent with a greenish look. Funny thing is that if I run at 1600x1200 with a 1024x768window maximized Snake is transparen again.

On the radio screen, no one appears on the windows, they are green and you can only see a pair of green glasses floating. (I had the same problem with a ti4600 and 45.23 drivers a while back).

I have a geforce FX5900 with 53.03 drivers
Abit nf7-s
AthlonXP 2500+
Windows XP SP1
DX9
nforce 3.13 and 4.09 sound drivers
Sound is trough optical cable to a dolby digital decoder 5.1 speakers.

RAY16
01-26-04, 03:00 PM
I don't know about the other problems, but to solve the blank codec models just turn the model quality one notch down from the highest (in other words, second highest).

ATI_Dude
01-26-04, 04:34 PM
Like he said. The remaining graphical problems (like missing shadows) can be fixed by rolling back to the 45.xx drivers.

SuLinUX
01-26-04, 09:39 PM
Did you install the latest patch?

Cotita
01-28-04, 12:08 AM
AFAIK the latest patch is for ATI cards only

NickSpolec
01-28-04, 03:26 AM
Enable Table-Fog too.

EciDemon
01-28-04, 04:45 AM
Dunno how to fix the sound as I use an Audigy2 (no problems)

The missing faces in the codec is cos the game isn't compatible with the vertex shader part of newer nvidia drivers (after 45.23 its broken)
The real fix is to use older drivers as at a certain point in the game you must have the model quality slider set to full to see the codec effect.
(it's nice but you can live without it)

The jumping cars in the intro could be fixed with the ATI patch but I do not reccomend that as that will give you texture problems in some cutscenes. The game is fillrate intence and if the game can not render at full speed you will get those jumpy cars in the intro. FIX=Lower the screen resolution and it will go away.

The Stealth effect at the given resolution (only one) is just some bug, probably got something to do with the back buffer (where images are stored to do some effects), just use another resolution. To me it only happend in 1280x1024 probably cos its not 4:3 ratio, Im not sure though

As you have an FX card you will probably have problems with the guards in the VR missions, only the textures is shown and the pixel overlay effect on the player modles will not render ... Again thats a vertex shader problem and it only happens on FX cards. Either lower the model quallity slider enugh to make it go away or dissable the vertexshader with Rivatuner ... no real fix though as everything will look as if it was renderd with dx7 hardware *suxx*

This game is not very compatible with FX cards :( ... you could get the game fully working with your older GF4 TI card using a bit older drivers.
Only problem is that the "focus" effect will be very slow with drivers prior to 45.23. The game uses both Pixelshaders and Vertexshaders to render effects so you need such hardware to get all the goodies. BTW thats just what the Model quallity slider controlls ... If you lower it those effects will be dissabled giving you the ugly player models and red thermal goggles


Ive seen a lot of ppl reccomending the ATI 2.0 patch for GeForce users to fix some problems but it's not worth it when you see the problems you GET with the patch on Nvidia hardware. so Don't! use it.

Ive experimented _a lot_ with this game so belive me when I tell you so :)
From what Ive found there is no 100% fix for Nvidia users. Ironicly the game was released with only Geforce support but with the ati patch on ati hardware you get it fully working *lol*

NickSpolec
01-28-04, 09:24 AM
Back around when this was first released, I had a GeForce3.

The graphics exibited all the problems people all listing happened to me too (missing codec faces, grey/green graphics). It was fixed with enabling table fog emulation.

EciDemon
01-29-04, 03:32 AM
Just to see what happend I tried to turn off the table fog emulation (Gf3TI200). That made outdoor envariouments look very odd ... as expected.

The missing faces in the codec is not due to tablefog emulation ... but could of cours also be affected by it (if it indeed was working and table fog emulation was set to off)

anyways, it is cos of the vertex shader part in the drivers on dx8> nvidia hardware.

The missing faces during codec talk never happens on GF4mx/GF2 simply cos they do not have vertex/pixel shaders ... but on the other hand they do not get any of those effects either. That is what you dissable by turning down the model quallity slider ... it does not affect the complexity of 3d models as one might think (so this slider dosen't affect MX/Gf2 users at all).

ATI_Dude
01-31-04, 02:45 PM
Originally posted by EciDemon
Dunno how to fix the sound as I use an Audigy2 (no problems)

The missing faces in the codec is cos the game isn't compatible with the vertex shader part of newer nvidia drivers (after 45.23 its broken)
The real fix is to use older drivers as at a certain point in the game you must have the model quality slider set to full to see the codec effect.
(it's nice but you can live without it)

(...)

As you have an FX card you will probably have problems with the guards in the VR missions, only the textures is shown and the pixel overlay effect on the player modles will not render ... Again thats a vertex shader problem and it only happens on FX cards. Either lower the model quallity slider enugh to make it go away or dissable the vertexshader with Rivatuner ... no real fix though as everything will look as if it was renderd with dx7 hardware *suxx*

This game is not very compatible with FX cards :( ... you could get the game fully working with your older GF4 TI card using a bit older drivers.
Only problem is that the "focus" effect will be very slow with drivers prior to 45.23. The game uses both Pixelshaders and Vertexshaders to render effects so you need such hardware to get all the goodies. BTW thats just what the Model quallity slider controlls ... If you lower it those effects will be dissabled giving you the ugly player models and red thermal goggles


Ive seen a lot of ppl reccomending the ATI 2.0 patch for GeForce users to fix some problems but it's not worth it when you see the problems you GET with the patch on Nvidia hardware. so Don't! use it.

Ive experimented _a lot_ with this game so belive me when I tell you so :)
From what Ive found there is no 100% fix for Nvidia users. Ironicly the game was released with only Geforce support but with the ati patch on ati hardware you get it fully working *lol*

I agree, it's pretty ironic that the game is now more compatible with ATI hardware especially since it's a direct port of the Xbox version which uses NVIDIA graphics hardware.

As for the vertex shader issues with GeForce FX cards they're probably caused by a difference in architecture between the NVIDIA NV2A GPU of the Xbox and the NV3x GPUs. Whereas the NV2A features two parallel vertex shader units the NV3x GPUs feature a floating point array composed of an uknown number of floating foint units running in parallel mode. This is probably why the game is more compatible with Radeon cards since they use a similar vertex shader architecture as the NV2A.