PDA

View Full Version : 40 detonators and flashing?


krocodile
10-07-02, 09:03 PM
Hey there,
Has anybody seem the same issue I have with the Detonator 40's and Windows XP? For some reason with using any of the Detonator 40's from the first beta on up, 3D graphics using Shockwave on internet tend to have flashing. For example, if you play BlasterBall 2, once the Title Screen displays, you see flashing on the window of the title text and such. The problem does not occur in Windows ME though using the same driver revision?!? If I go back to the 30.xx WHQL drivers the problem is corrected. I just hope that when the 40's come out of beta that I'm not stuck with the same problem. Thanks for any suggestions! :-)

saturnotaku
10-07-02, 10:00 PM
I would experience some pretty bad flashing in 2D games - like the Hyperspace Delivery Boy demo (shut up, shut up, shut up :p). This seems to have been cured with the 40.71 and 40.72 driver sets. Also with these drivers I would experience bad flashing and lockups with Shogo: MAD, but again with the above drivers the problem doesn't exist on my machine.

McBane
10-07-02, 10:39 PM
argh...i also have flashing in 3d...especially in d3d....hope nvidia gets their **** together....what good is the nv30 when they cant provide new STABLE dets...

krocodile
10-07-02, 10:42 PM
Hmm..... interesting. I don't have those games so I couldn't tell you if I had any issues with flashing there. Interesting as it may seem, I did some more testing and found that Shockwave, 3DGroove, and Wildtangent games seem to be the most effected. This is with the 40.72 drivers. Maybe it's a bug in the driver with the browser? I don't have Netscape to test that theory. I guess I shouldn't expect to much from a beta huh :) Thanks a lot for your response.

walkndude
10-09-02, 10:32 PM
Your best bet is to disable fastwrites. Fashing textures in d3d, flash or during windows splash screens is a sure sign of the problem, especially if you try opengl and the problem doesnt persist...

Instead of diggin through the bios(many wont show the option anyway) use the latetest rivatuner to force this feature off. This is by far the best way to go about things as fastwrites are clamped to sba(side band adressing) and failing to squash this clamp will make it extremely difficult to disable fastwrites at all or will make it necessary to disable both. Thats a bit of a no-no as sba does have a smallish effect on performance with highend systems...

Click the poweruser tab and load the database (any 40.xx will do) then go to "system global" and scan the reg entries for "EnableAGPFWStrap" and "EnableAGPFW". Values should be blank for both. Right click and choose the greyed out bulb from the pop-up window for each. Reboot and check to see if the settings stayed by clicking the videocard icon next to the dx emblem in rivatuner and click the "agp" tab. This shoud show fastwrites as "force off" and "off" while sba should show "determined by driver" and "on"...

Good luck, hope this helps

McBane
10-10-02, 12:02 AM
nope that aint it.....maybe if the rest of the dets did it...only the 40's do it....30's and below dont have this problem.....


Only reason i even bother with the 40's is that they dont produce artifacts in Hitman 2....but flashing appears in older games.

walkndude
10-11-02, 02:01 AM
Actually the fix is for 40.xx series specifically, unfortunately as newer drivers are developed sometimes a fucntion which performed correctly in an earlier set can be broken during a revision.

The fact that fastwrites didnt pose a problem when using 30.xx or earlier doesnt mean that it cant cause problems when enabled in a newer set ... That doesnt make sense.

If you tried it out and are fairly sure fastwrites was actually disabled, well, sorry it didnt do the trick. As for anyone else having similar problems I encourage you to try it out as systems differ and what doesnt work for one, may be just what the doctor ordered for another.

btw -forgot to mention you'll need to reboot befor the settings will take effect.

Kruno
10-11-02, 03:58 AM
I never had this problem with any dets. The 40.XX dets all worked perfectly on my system.

walkndude
10-12-02, 01:43 PM
Thats great kiler but you have a geforce3 -fastwrites and sba are disabled by default...