PDA

View Full Version : And Another Antec 480W Bites the Dust!


Rytr
03-23-04, 08:43 PM
Anybody else having problems with Antec 480W psu's. I have lost two in 3 months. First one would only provide 11.4V on the +12V rail at idle right out of the box. The second one gave me 11.8V under load...until today.

Came home from work today and found my computer dead. Green lite on my Abit IC7 motherboard would light up (on battery power) but no fans, no nothing...deader than a door nail. Put my dependable year-old Antec 430W back in the box and back under full power.

The psu for this box is under heavy demand with a total of 10 fans (5 case cooling fans), 2 HDDs, a Zip drive, 2 optical drives, and a 9800Pro. The 480W psu should not give up so quickly.

MUYA
03-23-04, 08:55 PM
Anybody else having problems with Antec 480W psu's. I have lost two in 3 months. First one would only provide 11.4V on the +12V rail at idle right out of the box. The second one gave me 11.8V under load...until today.

Came home from work today and found my computer dead. Green lite on my Abit IC7 motherboard would light up (on battery power) but no fans, no nothing...deader than a door nail. Put my dependable year-old Antec 430W back in the box and back under full power.

The psu for this box is under heavy demand with a total of 10 fans (5 case cooling fans), 2 HDDs, a Zip drive, 2 optical drives, and a 9800Pro. The 480W psu should not give up so quickly.
Mine is fine after 6 months.....true power 480W u mean?

Rytr
03-23-04, 09:22 PM
Yup, genuine Antec 480W True Power. I have a Antec 430W TP that has been in and out of at least half a dozen boxes and still provides 11.87-11.94V under full load on the +12V rail, even on NF2 boards.

Dazz
03-24-04, 05:17 PM
RMA it again, also 430w is more then enough for that.

MUYA
03-27-04, 06:59 PM
I got my 480W TP on special deal/promotion $80 I think or a lil bit higher.Been working like a charm, my comp is up 24/7

Rytr
03-27-04, 08:06 PM
Yeah, the 480W TP is a good psu and I really don't mean to be knocking it but I was just curious to know if anybody else is having problems. I mean 2 psu's in three months is a run of bad luck.

NickSpolec
03-28-04, 02:26 AM
My faithful 400w Allied is still rocking, even with my power hungry 2.5ghz Barton (and motherboard), giving 12.20 to 12.34 on the +12, and 11.94 to 12.12 on the -12 under load (unless this is a bad thing).

I don't have nearly as many fans as you, but I do have a lot of components.

All in all, it has been a great 30 bucks spent (when I bought it).

Nemesis
03-29-04, 07:25 AM
Anybody else having problems with Antec 480W psu's. I have lost two in 3 months. First one would only provide 11.4V on the +12V rail at idle right out of the box. The second one gave me 11.8V under load...until today.

Came home from work today and found my computer dead. Green lite on my Abit IC7 motherboard would light up (on battery power) but no fans, no nothing...deader than a door nail. Put my dependable year-old Antec 430W back in the box and back under full power.

The psu for this box is under heavy demand with a total of 10 fans (5 case cooling fans), 2 HDDs, a Zip drive, 2 optical drives, and a 9800Pro. The 480W psu should not give up so quickly.
You're lucky - my old IC7 setup had the same symptom, turned out my 550W Enermax had died, and taken out a P4C 3.0GHz CPU and the IC7 mobo.
New setup (thanks, home insurance) in sig - the Tagan 480W totally blows the Enermax away in all departments.

Rytr
03-29-04, 07:39 AM
Nemesis,

Interesting, never heard of that psu. Gonna look it up as I need another psu. Been looking at SPI and TTGI units and wanting to get a PC Power & Cooling. However, the price on the PC Power & Cooling units are a little steep.

MUYA
03-29-04, 07:47 AM
Rytr: I have linked a few Tagan PSU reviews ;) Check the archives of the news :D U r getting sloppy in your old age ;)

Rytr
03-29-04, 09:09 AM
Rytr: I have linked a few Tagan PSU reviews ;) Check the archives of the news :D U r getting sloppy in your old age ;)

Hey thanks MUYA! Yeah, getting a little sloppy, its what happens sometimes with age...acquiring too much knowledge and experience you tend to have overflows occassionally. :zzzz:

MUYA
03-29-04, 09:10 AM
buffer overflows? :p