PDA

View Full Version : my fx1000 don't work property


victor_chang
03-31-04, 11:45 PM
please help me :
my computeri is DELL M60 workstation.
OS :Redhat 9.0 desktop version/workstation
my question is
I install the video driver acroding to
http://www.nvidia.com/object/linux_display_ia32_1.0-5336.html txt README.
I think I already install the driver ,because the screen appear clearly than before install ...it always appears 800X600...it can't above 1024x768...
the monitor is not setup.....It appear 'Unknown monitor' ...
please tell me what is the reason!!!

thanks

-=DVS=-
03-31-04, 11:51 PM
you should install monitor driver *.inf file i would guess , but you have linux , try this forum it got info on linux http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

Ma-at
04-25-04, 05:04 PM
maybe i can help a little :D

i worked a moment on this problem for my own laptop with Fedora core 1 and Mandrake 10.

You have to edit you XF86Config file which is located in /etc/X11 in Red Hat

1 - Check the "Module" section and insure to remove "GLcore" and "dri"
and to add "glx"


Section "Module"
#Load "GLcore" # this line needs to be removed or commented
#Load "dri" # this line needs to be removed or commented
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # NVIDIA 3D layer this line needs to be present
EndSection

Section "Module"
EndSection


2 - Check the "Monitor" section and replace it by this one i've written for my own Precision M60


Section "Monitor"
Identifier "monitor1"
VendorName "DELL"
ModelName "Flat Panel Ultrasharp WUXGA 1920x1200"
HorizSync 31.5-90
VertRefresh 50-90

# DELL PRECISION M60 WUXGA - NVIDIA Quadro FX Go 1000
# 1280x800 @ 300 MHz
ModeLine "1280x800" 292.97 1280 1344 1480 1680 800 801 804 828
# 1280x800 @ 400 MHz
ModeLine "1280x800" 390.63 1280 1360 1496 1712 800 801 804 835
# 1680x1040 @ 300 MHz
ModeLine "1680x1050" 170.07 1680 1800 1984 2288 1050 1051 1054 1103
# 1680x1040 @ 400 MHz
ModeLine "1680x1050" 226.76 1680 1808 1992 2304 1050 1051 1054 1112
# 1920x1200 @ 300 MHz
ModeLine "1920x1200" 130.21 1920 2072 2280 2640 1200 1201 1204 1260
# 1920x1200 @ 400 MHz
ModeLine "1920x1200" 173.61 1920 2072 2288 2656 1200 1201 1204 1271

EndSection


3 - Check the "Device section" section and replace it by this one

Note : you must have correctly installed the nvidia driver


Section "Device"
Identifier "device1"
Driver "nvidia"
# enable use of nvidia agp instead of kernel agpgart (for recent kernels)
Option "NvAGP" "1"
# prevents the nvidia logo from showing at X startup
Option "NoLogo" "on"
# option needed for flat panel to work proprly
# workaround for problems of EDID detection
Option "UBB" "off"
Option "Dac8Bit" "on"
Option "HWCursor" "off"
Option "ConnectedMonitor" "DFP"
Option "IgnoreEDID" "on"
Option "FlatPanelProperties" "Dithering=enabled"
Option "IgnoreDisplayDEvices" "CRT, TV"
# sometimes it can be clever to diable DPMS
# to gain stability
Option "DPMS"
EndSection


3 - Check the "Screen section" section and replace it by this one
the Virtual lines hereafter define the screen resolution,
they must refer to "Monitor" section.
so, with the "Monitor" section defined above, the values can be :
Virtual 1920 1200
Virtual 1680 1050
Virtual 1280 800


Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1920 1200
EndSubsection

Subsection "Display"
Depth 15
Virtual 1920 1200
EndSubsection

Subsection "Display"
Depth 16
Virtual 1920 1200
EndSubsection

Subsection "Display"
Depth 24
Virtual 1920 1200
EndSubsection
EndSection


That's all... save your config file and enjoy.

:kill:
Note : with recent kernels and laptops (in particular Dell wide panels), this driver is still very unstable and buggy. You may have to face X somewhat frequent hangups particularly when trying to switch to a VT with CTRL+ALT+Fn keyborad sequences :(

Advice : I suggest that you use "nv" XFree driver instead of NVIDIA's when you need not 3D features :D

the "Device" section needed is much more simple :



Section "Device"
Identifier "device1"
Driver "nv"
# needed for flat panels to work properly
Option "FlatPanel" "on"
Option "FPDither" "on"
Option "DPMS"
EndSection


Note : Such an XF86Config won't allow you to use dual head features of your FX Go1000.
For this to work you should write a slightly more complex XF86Config file with xinerama options
or NVIDIA TwinView options...


hope that can help you.