PDA

View Full Version : UDMA driving me mad


Evil17
10-09-02, 02:47 AM
I have a gigabyte 6VTXE-A motherboard and a seagate ST340016A (ATA-100, 7200rpm, 40GB) harddisk.

According to the specifications, my motherboard supports up to ATA100, and i have the right cables attached (40/80 cable) but when i had a look at the device manager in win XP, it says this harddrive is running in UDMA-3 (i.e. ATA33...) and while the other harddrive (an old ATA-66 13GB Quantum Fireball) is running at ATA-66 so there must be something wrong.

I used to use IBM ATA-66 harddisk and it runs at ATA-66 in win ME but since I gave that harddsik to mum and change to this new one, the speed has been, err, agonising, takes longer to defrag and hours to scan for viruses etc

can anyone help me changing it to run at where it suppose to run?

thanx

saturnotaku
10-09-02, 07:36 AM
Have you installed the proper IDE drivers for that motherboard? Looks like what you have is a VIA chipset. Head over www.viaarena.com and download the latest 4-in-1 package to see if that will help.

Evil17
10-09-02, 10:52 AM
I forgot to mention, I have installed the latest VIA 4-in-1 driver from VIAarena, and it basically didn't make any difference...

I also download some disc tool thing from seagate, but it sounds a bit dodgy cos it requires that program to be installed onto some book-up floppy. Last time when similar thing happened with my IBM harddisk, the disk tool IBM provided didn't need that, and i didn't even remember whether i used it to get to ATA66 or i tweaked something else, but that was on WinMe

The Baron
10-09-02, 11:10 AM
Remove the IDE controller that it's on in the WinXP device manager.

That MIGHT do the trick.

Evil17
10-09-02, 11:18 AM
you mean that the system re-detect the drive?

sounds good to me, thanx i'll give it a go

Evil17
10-09-02, 11:31 AM
unfortunately didn't work...

still says UDMA mode 3
the more annoying thing is that, my old harddisk (quantum fireball 13G) connected to the same cable as slave, is running at UDMA mode 4 i.e. faster... (even shows in benchmarking)

maybe i should try again, (and bribe winXP)

eL_PuSHeR
10-10-02, 08:01 AM
Do the same for both ide channels. Reboot. Before entering windows, enter bios setup and make sure all drives are using AUTODETECT. Save changes and reboot.

Evil17
10-10-02, 09:32 AM
I tried that for both drives and reboot (setting auto for ide in bios)
still the same...
then tried again, this time set the bios to ide=ATA66/100 for both, and again it didn't work...
(but got my CD rom to run at UDMA -2, but i know i have to get the new cable for that to run higher)

sorry didn't work but thanx for the effort