PDA

View Full Version : Painkiller seems "slow"


Warden13
08-02-04, 01:24 PM
I grabbed a copy of Painkiller from the local Best Buy the other day and installed it. I go to fire it up and it's almost like playing in slow motion. I don't mean its stuttering at all, it just seems like slow motion. Thinking I was having some kind of conflict I decided to just re-format and start from scratch. Installed Windows XP-Pro, all my correct drivers including the 61.77 Nvidia drivers and it's the exact same thing. This is running on a 6800 GT at 400/1100 and an AMD 64-3200 @ 2250mhz with a Gig of ram. I've never quite seen anything like this and if this is how the game is meant to be played I will be sorely disappointed :(

Warden

Shocky
08-02-04, 01:37 PM
Plays fine for me although it does drop to 30fps when huge amounts of monsters are running after you. :clap:

saturnotaku
08-02-04, 01:59 PM
Try disabling character shadows and see if that helps. This seems to be a major sticking point in Painkiller regardless of whether you own an NVIDIA or ATI card.

Morrow
08-02-04, 02:02 PM
Warden, check under Control Panel --> System --> Advanced Tab--> Performance Settings --> Advanced Tab if you have the processor scheduling set to "Programs" or "Background Services".

If it is "Background Services" set back again to "Programs" and reboot

Superfly
08-02-04, 02:20 PM
runs slick for me @ 1280x1024 max details/everything on inc: AF & AAx4 - as stated it can drop to 30-40 FPS when LOADS of badguys are on screen.

im using the 61.77 drivers.

SLippe
08-02-04, 05:52 PM
Warden, check under Control Panel --> System --> Advanced Tab--> Performance Settings --> Advanced Tab if you have the processor scheduling set to "Programs" or "Background Services".

If it is "Background Services" set back again to "Programs" and reboot

I think you mean check and see if Memory Usage is set to Programs or System Cache. Make sure it is set to Programs, as this had to be this way to play the PK demo. The above could be correct, also, but I know for sure that you had to have the Memory Usage set to Programs.

tazman
08-02-04, 07:09 PM
try clocking that GT back to stock man.

DarkOneX
08-02-04, 07:44 PM
I've been playing Painkiller, very far into it now, at 1600x1200 w/ 16X AF on, all HQ settings, and I have been in awe at how beautiful and perfectly smooth it's running. I have seen absolutely 0 jerkiness in the entire game now, and I'm up to Chapter 5 part 3 now.

Morrow
08-03-04, 05:40 AM
I think you mean check and see if Memory Usage is set to Programs or System Cache. Make sure it is set to Programs, as this had to be this way to play the PK demo. The above could be correct, also, but I know for sure that you had to have the Memory Usage set to Programs.

Well, several settings have been found which could slow down Painkiller. I also had the problem and that was because of the "Processor scheduling".

But there are many other reasons why this slowdown may occur, not all of them have been found so maybe "Memory Usage" could also be one of them although I have set it to "System Cache" and Painkiller now runs fine.

AFAIK PCF has not yet completed that slowdown issue although it went back during beta testing.