PDA

View Full Version : Anybody tried the Xpand Rally Demo - my performance is lousy


Zzorrkk
08-09-04, 07:04 AM
Hi,

just I just tried the Xpand Rally Single Player Demo. What I got was an astoundingly bad performance. 1280x960 on balanced settings was merely playable... but not from 3rd person perspective...

Is it just my system, or is the "thewayitsmeanttobeplayed" here just a joke? Ok. Its just a Demo, but thats supposed to work too, right?

Any other experiences with this are welcome, since I got problems with morrowind, too. If its my system the format C is coming my way :(

Zzorrkk

PS: That is Forceware 61.77 and latest Creative drivers...

s-flow
08-09-04, 08:52 AM
Where to get it?

saturnotaku
08-09-04, 09:00 AM
The MP demo is not scheduled for release until Aug. 12.

OWA
08-09-04, 09:09 AM
To echo what saturnotaku said, here's the blurb at gamer's hell.

"Although expected for the 12th, Xpand Rally demo probably got leaked, anyway as we could not get ahold of any Techland reps and the demo is widely available already, here it is local mirrored for your download-bandwidth pleasure.

Update: We were contacted by a Techland rep who confirmed the demo to be not official and subsequentially it is no more available for download locally."

Zzorrkk
08-09-04, 11:11 AM
To echo what saturnotaku said, here's the blurb at gamer's hell.

"Although expected for the 12th, Xpand Rally demo probably got leaked, anyway as we could not get ahold of any Techland reps and the demo is widely available already, here it is local mirrored for your download-bandwidth pleasure.

Update: We were contacted by a Techland rep who confirmed the demo to be not official and subsequentially it is no more available for download locally."

Ok, thanks for letting me know. Hope they find some performance in the engine though. The game has real sweet graphics and seems like a fun arcade race.

Bye,
Zzorrkk

Morrow
08-09-04, 12:52 PM
That game seems to run bad on all kind of graphiccards (nvidia as ATI).

I'm still downloading...


Anyway, the demo apparently installed the StarForce client on your PC without asking for your permission and this could result in unexpected problems with your PC.

StarForce Removal Tool (http://www.star-force.com/support/sfdrvrem.zip )

Use this tool to get rid of the StarForce protection which is not needed for the demo.

-=DVS=-
08-09-04, 03:30 PM
1152x864 all details max 4x AA no idea AF , from different view places it ran arround 60FPS dipping in 50ys.

They pulled it this morning but some japanese site still got it , can find links at Rage3d / game forum.

Very comperable to Colin MCRae 4 except graphics are different for better i think,

Anima86
08-09-04, 04:57 PM
ok my thought,

I simply love the game!

The GFX is amazing, the car handling was a bit irritating in the beginning but now with my momo racing wheel it works perfect after a lil trial and error :)

and it runs perfect on my sys all maxed out

OWA
08-09-04, 10:11 PM
Yep, have to agree. I can't wait for this one to be released. Finally, I may be able to retire Rallisport Challenge. The graphics and sound in this one are great and I really like that it provides an in-car view.

Anyway, seems to run fine here. Fraps results below. Used the benchmark mode to bench while racing so it's under real gameplay conditions (which also means it's not consistent from race to race -- test to test).

1280x1024 All game settings maxed (best quality settings)

2004-08-09 21:41:11 - XpandRally (in car view, 4xAA/ansi set in game)
Frames: 13084 - Time: 214568ms - Avg: 60.978 - Min: 38 - Max: 80

2004-08-09 21:45:25 - XpandRally (3rd person view, 4xAA/ansi set in game)
Frames: 11299 - Time: 202529ms - Avg: 55.790 - Min: 34 - Max: 75

2004-08-09 21:52:06 - XpandRally (3rd person view, 4xAA/8xAF forced in CP)
Frames: 10471 - Time: 216439ms - Avg: 48.379 - Min: 30 - Max: 66

2004-08-09 21:56:01 - XpandRally (in car view, 4xAA/8xAF forced in CP)
Frames: 10130 - Time: 203527ms - Avg: 49.772 - Min: 34 - Max: 65