PDA

View Full Version : Physical Address Extension - WinXP SP2 - how to disable?


Gator
08-10-04, 05:50 AM
Ever since I installed SP2 from Microsoft.com, Physical Address Extension or PAE mode has been enabled. My hard drive access since then has been misery, and my Virtual PC software refuses to launch in this mode. According to the Microsoft Knowledge Base, there is no reason for me to use this mode unless I have 4gb of RAM.

How do I disable PAE mode? According to Microsoft I need to remove a line from the boot.ini, but that's in reference to Win2k Advanced Server, I donot see such a line in the boot.ini for WinXP Pro.

http://www.microsoft.com/whdc/system/platform/server/PAE/PAEdrv.mspx
That's all I found so far and it is not helping me. It says "If your hardware does not support PAE, or if the problem persists and you continue to believe that PAE may be the cause, disable PAE by removing the /PAE parameter from the Boot.ini file." but I don't even see that listing at all! :(

Gator
08-10-04, 05:57 AM
aw crap, look what I just found

http://www.microsoft.com/technet/prodtechnol/winxppro/maintain/sp2mempr.mspx


Beginning with Windows XP Service Pack 2, the 32-bit version of Windows utilizes the no-execute page-protection (NX) processor feature as defined by AMD or the Execute Disable bit feature as defined by Intel. In order to use these processor features, the processor must be running in Physical Address Extension (PAE) mode. The 64-bit versions of Windows XP uses the NX processor feature on 64-bit extensions and certain values of the access rights page table entry (PTE) field on IPF processors.

It is hoped that all future 32-bit and 64-bit processors will provide support for hardware-enforced data execution prevention. Microsoft continues to work with processor vendors to encourage the adoption and development of DEP technologies.


So if I want to use the AMD64 DEP support, I have to keep PAE enabled :(. I don't know if this is to blame for my slower hard drive activity, but it sure seems like a likely candidate. I also need to figure out how to make Virtual PC work now :(

Gator
08-10-04, 09:22 PM
Everything seems fixed now. I defrag the hard drive and it seems much better, and I upgraded my version of Virtual PC so it works fine with PAE enabled.


















...not that anyone responded anyway...

Electronic Punk
08-20-04, 09:21 AM
lol, I was always curious what the hell that was :)

thanhhaHP
09-06-06, 06:12 AM
Everything seems fixed now. I defrag the hard drive and it seems much better, and I upgraded my version of Virtual PC so it works fine with PAE enabled.


Hi, I just joined this forum. So, no way to disable PAE on WinXP pro sp2??
Hix, Because I use Win XP sp2 and Conextive Virtual PC 5.0 can not run with PAE enable (as it mention).
Pls tell me which version of Virtual PC can run in this environment or there's any way to help Virtual PC 5.0 (or 2004) can run on it? Thankyou very much

Ah, btw, my mail : thanhha181281@gmail.com.
Looking forward to hear from you.

...not that anyone responded anyway...
------------------------------------------------------------------------

saturnotaku
09-06-06, 06:18 AM
Look at the date of the last post above yours.

By the way, you're supposed to type your response after the [/quote] tag on this forum.

The Bigman
09-09-06, 04:58 PM
Hey dude chill out on him he probably didn't know. your not a mod let them deal with it.

Anyway i put the extension in when i put in 4 gigs of ram and it didn't really do anything. i just leave it and it doesn't make much difference anyway.

tonyos2
09-28-06, 12:23 AM
------------------------------------------------------------------------

Set "/noexecute= AlwaysOff" in your Boot.ini, like so.

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=AlwaysOff

This will allow Virtual PC 5.0/5.2 to work with XP Pro SP2. :)