PDA

View Full Version : Fog Banding...help plz


nVidiaGuru
08-17-04, 02:03 AM
now that ive gotten into the game a bit more and im getting to the levels with the fog in the caverns and im really annoyed by the banding of the fog itself. Heres a screenshot of what im talking about ... http://supra9301.homestead.com/files/banding.jpg ... its very noticable along the upper lefthand walls. At first i thought it was drivers so i switched from 62.20's to the 61.77's to the 65.62's which didnt solve the problem. I then thought that perhaps it was my LCD monitor itself causing the banding so i changed my primary monitor to my CRT and the banding was still present.

Is anyone lse getting this affect? is it perhaps a game setting ive messed with through the console or perhaps a setting in the application profiles?

jAkUp
08-17-04, 02:06 AM
Yup... I hate it. I have tried everything but I cant seem to fix it..

http://www.nvnews.net/vbulletin/attachment.php?attachmentid=7550&stc=1

Pandora's Box
08-17-04, 02:49 AM
carmack gonna fix it...

Arioch
08-17-04, 02:58 AM
carmack gonna fix it...

Is that speculation or did you read that somewhere?

I posted at Rage3D about the banding issue and someone with a X800XT PE also gets it so at least it appears to be a game issue and not a video card or driver problem.

Zeno
08-17-04, 03:02 AM
Yup... I hate it. I have tried everything but I cant seem to fix it..

Yea, it's definitely distracting in the cavern levels. I don't think there's anything you can do to fix it. I think it's a side effect of the way they chose to implement the fog. It looks like they're blending several mostly-translucent quads on top of one another perpendicular to the user's view direction.

Strange that they wouldn't just put a per-pixel distance calculation in the fragment program and use that to do fog color - at least on the high end cards. Maybe the method they're using instead is the only one that would work across all generations of graphics card?

Pandora's Box
08-17-04, 09:24 AM
Is that speculation or did you read that somewhere?

I posted at Rage3D about the banding issue and someone with a X800XT PE also gets it so at least it appears to be a game issue and not a video card or driver problem.


was a joke.