PDA

View Full Version : window animation problem with 4x.xx?


Edguy
10-31-02, 01:02 PM
i have a relativly small problem.. but still quite annoying.

usually with older detonators (30.82 and earlier)... maximizing and minimizing windows is smooth... as it should be.

but with these new (tried 40.71 and 40.72).. at first.. it's nice and smooth as usual... but after playing a video (divx, vcd, anything) or anything else that uses any sort of acceleration/overlay... it's like the window-animation is turned off, maximizing and minimizing windows is very jerky... switch resolution.. and it's all good...

the older det's didn't get affected by playing any videos.. sometimes playing games in the same res/colordepth as the desktop could casue windows to minimize and maximize jerky but nothing else..

tried and it's on both my systems... 40.71 on the XP and 40.72 on the P4... both are good on 30.82 and earlier...

any thoughts apreciated... i like my smoothly animated windows :p

methodmansi
11-10-02, 03:13 AM
Yeah man.. I hate that damn jerky window animation crap.. been getting it for so damn long.. Old drivers only did it once in a while... after playing games or whatever... new ones do it after u play a movie.. it's garbage.. just for that I went back to 30.82's... screw the performance improvement.. I like smooth windows damnit!!! Man.. I knew I wasn't going crazy... nobody else seems to notice it tho... hopefully nVidia does something about it.. I doubt it tho.. it's such a minor thing for them... they're all about tweaking the performance and that.. oh well...

Edguy
11-10-02, 09:07 AM
yeah... tho i noticed it doesn't happen after i play a video using NView with Video-mirror to the TV... so i guess i can live with that for a while... but DAMN...

i thought they fixed this... can't believe more people aren't complaining about it :p

IGx89
11-16-02, 07:42 PM
I just upgraded to the 40.72 WHQL'ed drivers, and they also have that jerky window animation problem :(. I've also noticed that my framerate in America's Army: Operations (uses the UT2003 engine) at the start of rifle training is ~34fps, instead of my usual ~40 with the 29.xx drivers :(

Specs:
AMD XP2000
Abit NV7-133R
512mb RAM
Abit Geforce 4 Ti 4400 (default clocks)
Windows XP

Edguy
11-17-02, 01:33 PM
well.. my fix for it is to enable the secondary output.... (Nview on twinview mode)....

using this it never gets jerky.. even after playing games at the same res/colordepth as the desktop....

and it doesn't seem to affect performance in any way so i'll just leave it on.... the videomirror feature is wonderful (reason why i want 40.xx drivers)..

still the bug is there and should be fixed... :p

bernard_yu
11-17-02, 08:21 PM
I know this problem really stinks, cuz some ppl like me use 2d more often then 3d, and i dun wanna switch resolution/color depth all the time after playing movie etc.
and u know wut, one of my 3d fish screensaver (www.serenescreen.com) fps dropped from 210fps -> 160fps:mad: ........i think this release is rather too optimized towards newer nvidia cards (GF4), so older card user should stick to the older release (ie 30.82, 29.42)

IGx89
12-30-02, 12:06 PM
I just upgraded to the 42.01 drivers, and they still have that exact same window animation problem :(

The good stuff, though, is that I got my AA:O framerate to 45.5fps by upgrading my nForce drivers to 2.00, and by overclocking the graphics card. Also, the new 42.01 have amazing image quality with Digital Vibrance on; it even beats my Uncle's iMac, if that's a big deal :)

Nutty
12-31-02, 09:16 AM
I upgraded to 42.01 and noticed another problem.

In CS I use the volume controls on my logitech keyboard. When I press volume up or down, a little volume bar comes onscreen, like TV's do. Previously it used to work fine. Now when the bar appears and disapears it completely blanks my screen for about 1/4 a second.. Most annoying.

Only in games tho.. works fine on the desktop.

I'm not sure if its DX9 install that did that.. or what. Cos it does it in GL and D3D games.. But its bloody annoying.

Tactics
12-31-02, 12:40 PM
Originally posted by Edguy
i have a relativly small problem.. but still quite annoying.

usually with older detonators (30.82 and earlier)... maximizing and minimizing windows is smooth... as it should be.

but with these new (tried 40.71 and 40.72).. at first.. it's nice and smooth as usual... but after playing a video (divx, vcd, anything) or anything else that uses any sort of acceleration/overlay... it's like the window-animation is turned off, maximizing and minimizing windows is very jerky... switch resolution.. and it's all good...

the older det's didn't get affected by playing any videos.. sometimes playing games in the same res/colordepth as the desktop could casue windows to minimize and maximize jerky but nothing else..

tried and it's on both my systems... 40.71 on the XP and 40.72 on the P4... both are good on 30.82 and earlier...

any thoughts apreciated... i like my smoothly animated windows :p

Well i'm not sure this will help but I believe the same thing happened to me in win 98SE with new drivers. When trying to min/max a window it was not smooth. What I did was right click on desktop or go to display properties then effects and un-check animate windows, menu and lists. It seems that was being checked by default and I would have to uncheck it. If you use XP or 2000 i'm not you have that option. I'm on a win 2000 machine here at work and don't see it.