PDA

View Full Version : Unreal engine games and 65.XX/66.XX drivers


Ice Nine
10-04-04, 08:45 AM
Folks,

While 61.77 appears to have no issues with Unreal-based games like UT2004 proper and Rainbow Six games, Version 65 and newer drivers all appear to BSOD when exiting the game. The newest 66.81 drivers on nvidia's ftp site don't appear to fix this problem either.

I'd like to get a feel for what kind of hardware people are running in an effort to find out exactly what common thread there might be. Please report back if you actually have the problem or not, and what kind of system/OS you're running.

For details on what i'm running, you can visit here (http://www.weckstrom.com/perf/), but in a nutshell it's an Athlon 64 3800+ 939, MSI Neo2 board, PNY 6800U. I'm running WinXP SP2. I've played with the DEP stuff, but to no avail.

Thanks in advance
-Karl

MightyMax505
10-04-04, 09:12 AM
Interesting Ice Nine....

I see that you have done the BIOS flash to bring the card to running at the same speed 2d / 3d. Have you turned of fast writes yet? Also, I see that your system board supports dual channel DDR, some have reported that breaking up the dual channel have fixed a few problems.

My system specs are different but I do have a 6800GT and have had no problems with UT2004 with any of the latest drivers. Other games and issues.... yes, but not with the UT engine.

It does seem that the 6800 series is very picky where it wants to play for sure.

|MaguS|
10-04-04, 09:14 AM
No issues with Ureal games here, Tried them all and they all work fine for me. System in Signature...

Ice Nine
10-04-04, 09:16 AM
Interesting Ice Nine....

I see that you have done the BIOS flash to bring the card to running at the same speed 2d / 3d. Have you turned of fast writes yet? Also, I see that your system board supports dual channel DDR, some have reported that breaking up the dual channel have fixed a few problems.

My system specs are different but I do have a 6800GT and have had no problems with UT2004 with any of the latest drivers. Other games and issues.... yes, but not with the UT engine.

It does seem that the 6800 series is very picky where it wants to play for sure.

I haven't turned off Fast Writes (haven't seen a need to, as 61.77 were just fine). I'll give it a shot, but I doubt it will make a difference.

I can try disabling dual channel as well to see if that changes anything, but crippling your system to me doesn't seem like much of a fix :)

Regardless, 61.77 has no issues in any games I play (and I play quite a few). Just the newer ones crash on exiting Unreal-based games. Gameplay seems ok, it's just the act of EXITING the game that makes Windows BSOD...

OWA
10-04-04, 09:23 AM
Are you talking about the SP2 / AMD64 combo issue that causes BSODs on exit in some games? If so, the solution for now is to disable DEP. I'll see if I can find the thread on this...

Try here: http://www.nvnews.net/vbulletin/showthread.php?t=37255&highlight=DEP

and here: http://www.nvnews.net/vbulletin/showthread.php?t=36541&highlight=UT2004

Edit: Actually, try the second thread first. That's the original one.

Warden13
10-04-04, 09:58 AM
What OWA said...

I disabled DEP and things have been running fine since then.

Warden

Ice Nine
10-04-04, 09:59 AM
Interesting.

Guess it's gonna be hard to get WHQL certification if you have to turn off DEP :)

SevnDusty
10-05-04, 10:09 PM
How do I disable DEP? Can I turn it off all togather?

|MaguS|
10-05-04, 10:12 PM
http://www.numlock.ch/news/archives/000280.html

SP2 = The Suck.

Im staying SP1 untill they force me to install SP2 or im drunk and do it by mistake.

bkswaney
10-05-04, 10:21 PM
No problems here and I'm a unreal head. "lol" ;)

bmg
10-06-04, 01:08 AM
Epic and nvidia have been made aware of this issue. Until there's a fix you'll have to disable DEP if you're running SP2 and amd64.

jAkUp
10-06-04, 01:27 AM
no probs here either... I believe its just an a64 problem

|MaguS|
10-06-04, 02:04 AM
Epic and nvidia have been made aware of this issue. Until there's a fix you'll have to disable DEP if you're running SP2 and amd64.

No, It has NOTHING to do with Nvidia, Its actually a problem with SP2 that have DEP enabled and AMD64's. So Amd64 SP2 users need to wait for MS to fix the issue, NOT Nvidia.

Bah!
10-06-04, 03:44 AM
Interesting.

Guess it's gonna be hard to get WHQL certification if you have to turn off DEP :)

Its a Athlon64/SP2 issue, it has nothing to do with Nvidia.

saturnotaku
10-06-04, 06:38 AM
Its a Athlon64/SP2 issue, it has nothing to do with Nvidia.

NVIDIA is at least partially responsible because UT2004 works perfectly with an X800 and SP2.

Warden13
10-06-04, 07:17 AM
Nvidia is certainly resposnible considering it affects only their hardware, but it works fine with their 61.77 drivers. Somehow they introduced something in their newer drivers that caused this to happen.

Warden

saturnotaku
10-06-04, 07:38 AM
Exactly. It worked perfectly fine with all driver revisions prior to 65.xx.

mikedep333
10-06-04, 08:11 PM
Unfortunately this bug isn't mentioned in the release notes for the 66.81's.

http://download.nvidia.com/Windows/66.81/66.81_ForceWare_Release_65_Graphics_Drivers_Releas e_Notes_Windows_XP-2000.pdf

bmg
10-06-04, 09:22 PM
Unfortunately this bug isn't mentioned in the release notes for the 66.81's.

http://download.nvidia.com/Windows/66.81/66.81_ForceWare_Release_65_Graphics_Drivers_Releas e_Notes_Windows_XP-2000.pdf

I'm not sure they really knew about it until yesterday. Patience.