PDA

View Full Version : How to enable MMX, 3DNow, SSE, and SSE2 to gain a FPS boost!


anzak
10-30-04, 01:17 AM
While reading a few guides on CS: Source tweaking I ran across a way to enable CPU instruction sets. Simply add any of the following lines to your config file found in counter-strike source\cstrike\cfg.

r_mmx "1"
r_sse "1"
r_sse2 "1"
r_3dnow "1" (AMD CPU's only)

After enabling MMX, SSE, and 3DNow I gained about 10fps (keep in mind my avg. is 40) when there is lots of action going on. I could really tell a difference in heavy firefights where the processor is being stressed.

Some other useful commands are

net_graph 3
cl_ragdoll_collide "1"
cl_allowupload "0" and cl_allowdownload "0" (removes useless uploads and downloads to improve ping)

Intel17
10-30-04, 09:13 AM
I'm surprised that the game doesn't take advantage of a CPU's given instruction set, without manual commnads...

Anyway, Nice find! I'll be sure to use them when HL2 comes out :)

saturnotaku
10-30-04, 10:20 AM
Excellent find. :thumbsup:

Morrow
10-30-04, 11:34 AM
All those CPU extensions should be enabled by default if your CPU supports them.

Maybe there is one rare bug which doesn't enabled it on your system but I highly doubt it.

There is no reason for valve NOT to enable them if your CPU has support for it.

anzak
10-30-04, 11:43 AM
All those CPU extensions should be enabled by default if your CPU supports them.

Maybe there is one rare bug which doesn't enabled it on your system but I highly doubt it.

There is no reason for valve NOT to enable them if your CPU has support for it.

They are disabled by default. Don't ask me why, but they are.

Morrow
10-30-04, 12:18 PM
They are disabled by default. Don't ask me why, but they are.

Maybe just on your PC because Steam is unable to detect your CPU correctly, but it certainly is enabled for the majority of CS:S users.

Maybe you should post this also in the official Steam forum to see what the reaction is like...

FierceDeityLink
10-30-04, 04:30 PM
To the topic creator:
Does CS:S recognize your CPU when you start it up? I would assume that it would automatically set the extra instructions depending on the CPU (as it prints out what instructions your CPU supports in the console).

anzak
10-30-04, 05:07 PM
This is what the console shows without my custom config.

1 CPU, Frequency: 2.4 Ghz, Features: AuthenticAMD SSE MMX 3DNow RDTSC CMOV FCMOV
execing valve.rc

This is what the console shows with my custom config.

1 CPU, Frequency: 4.7 Ghz, Features: AuthenticAMD SSE MMX 3DNow RDTSC CMOV FCMOV
execing valve.rc
execing autoexec.cfg
MMX code is enabled
SSE code is enabled
3DNow code is enabled

Morrow
10-30-04, 08:07 PM
This is what the console shows without my custom config.



This is what the console shows with my custom config.

ok, now try this.

Make sure your custom config is NOT loaded when starting CS:S, also make sure that r_mmx, r_sse, r_sse2 are NOT loaded from within the default config.cfg or any other cfg file which might be loaded automatically upon running CS:S

Start CS:S and type in the console "r_mmx" without the "1". If after this step the console says "MMX code is disabled" there is indeed something wrong with your setup and Steam is not able to set the correct CPU instruction set.

But again, most probably the console will say "MMX code is enabled" like it should do it.

The fact that your CS:S indicates that the different instructions are enabled with your config does not necessary mean that they were disabled before. It's rather the standard console output you get when typing in "r_mmx 1" even if mmx or sse was already enabled before.

anzak
10-30-04, 09:11 PM
Hmm this is odd

] r_mmx
MMX code is enabled
] r_mmx 0
MMX code is disabled
] r_mmx
MMX code is enabled

It appears that r_mmx enables it. If I disable it with r_mmx 0 then type r_mmx it shows that it's enabled. Their is no way of telling if it's enabled by default or not.