PDA

View Full Version : WHQL 66.93 ForceWare feedback thread


Pages : [1] 2 3 4 5 6 7 8 9 10

bingo13
11-09-04, 08:28 AM
ftp://download.nvidia.com/Windows/66.93/

RanCorX2
11-09-04, 08:30 AM
nice find, wonder if they are the same as the others.

Superfly
11-09-04, 08:31 AM
well spotted sir - lets see how long it takes to bring NVIDIA's server to its knees!!!!

Superfly
11-09-04, 08:33 AM
well - there WHQl so that at least is different - also you wont have to put up with your card being called a winfast!!!!!!

all good IMHO

MUYA
11-09-04, 08:39 AM
not a bad thing for me since i have a Winfast Leadtek A500 Ultra TDh ;)

Superfly
11-09-04, 08:40 AM
Horray for us!!!

http://www.nvidia.com/object/winxp_2k_66.93

Release Highlights:

Updated driver to WHQL Certified for TNT2 through GeForce 6 Series
Added support for GeForce 6600, GeForce 6600 GT, and GeForce 6200
Added support for SLI™
Added support for using HDTV over DVI connectors
Added support for 512 MB frame buffer GPUs
Added support for advanced DVI timing on all GeForce 6 series GPUs
Added support to recognize and display monitor name in all control panels
Added support for TV/HDTV setup in the nView Display Setup Wizard
Updated Gridlines for easier grid setup and management
Microsoft® DirectX® 9.0c and OpenGL® 1.5 support

bingo13
11-09-04, 08:42 AM
They are now up on their driver page also-

http://www.nvidia.com/object/winxp_2k_66.93


So far so good for me in some game testing, CS-Source coming up now.

RanCorX2
11-09-04, 08:46 AM
Omg Finally Whql's !!!

MUYA
11-09-04, 08:46 AM
Merged superflys and bingo's thread...no need for seperate thraeds on the same issue...more or less

Superfly
11-09-04, 08:47 AM
Merged superflys and bingo's thread...noneed for seperate thrads on the same issue...more or less

thanks MUYa - just tried to post a reply tro the other asking you to do just that.

thanks dude.

MX/MX400
11-09-04, 08:55 AM
Has anyone benched with them, to check for performance gains?

Fatman
11-09-04, 09:01 AM
Please post some feedback for all the poor souls who are stuck at work. Thanks.

MUYA
11-09-04, 09:03 AM
thanks MUYa - just tried to post a reply tro the other asking you to do just that.

thanks dude.
heheh no worries man ;)

|MaguS|
11-09-04, 09:07 AM
Downloading now, will post tests ASAP. :)

EDIT: I could have guessed they would release today, all past drivers had had issues with EQ2, these probably will work great with the game since this is one of the big Nvidia Titles.

Graphicmaniac
11-09-04, 09:17 AM
Am i dreaming???

an official release!

anwyay i was thinking the same about EQ2 :)

and now everybody to test them till the last bit! :D


is videoprocessor working now?

Renzo
11-09-04, 09:24 AM
Has anyone benched with them, to check for performance gains?
According to some game benches OpenGL part appears to be a little slower than 66.77/66.81 in high quality mode but the difference is very small (52,1fps vs 52,4fps or 419,7fps vs 421,1fps etc etc).

Edit: No noticeable performance improvements/decreases on Direct3D. The driver has probably somewhat nicer filtering quality in HQ mode or I'm just blind.

Graphicmaniac
11-09-04, 09:25 AM
there is an error

on the website TNT2 is not WHQL

look:

* WHQL Certified for GeForce 256 through GeForce 6 series.

thrawn42
11-09-04, 09:43 AM
Wooooooooo hooooooooooooooooo!

Just in time for HL2.

I gotta head to the doctor's soon but i'll start dling now and see if I can post some test results when I get back.

Skinner
11-09-04, 09:51 AM
I hoped for 70.xx's no 66-driver matches the 70.41's

|MaguS|
11-09-04, 10:01 AM
My Benches... These are done on High Quality (others were on Opts on).

VST: 110 (old 108) @ 1600x1200
3DMark05: 5189
3DMark03: 12296

IQ seems to be dead on, only problems I saw were in 3DMark05 which gave me Artifacts like no tomorrow. I don't know if this is due to my OC or not since I see no Artifacts in anything else...

whiskeychaser
11-09-04, 10:07 AM
no more lines in source. finally.

Superfly
11-09-04, 10:10 AM
My Benches... These are done on High Quality (others were on Opts on).

VST: 110 (old 108) @ 1600x1200
3DMark05: 5189
3DMark03: 12296

IQ seems to be dead on, only problems I saw were in 3DMark05 which gave me Artifacts like no tomorrow. I don't know if this is due to my OC or not since I see no Artifacts in anything else...

I got really bad artifacts in 05 using the 66.81 driver and I run @ stock!!!, your clocks are high though maybe back em off a bit.....

|MaguS|
11-09-04, 10:14 AM
I will back them off if I get artifacts in something else but if everything else is fine then I will blame the software, not my card. Heck I can even go higher and still be fine in games, just 3DMarks doesn't like it...

Superfly
11-09-04, 10:22 AM
also just to let you know I get just over 5300 in 05 with the same card running @ 400.1100 on my rubbish MoBo and chip!!!

perhaps your clocks are two high and this is actually hurting your score.

just a thought.......

Ruined
11-09-04, 10:28 AM
kind of a downer, apparently all the CS:S artifacts from 66.81 are in these drivers, too