PDA

View Full Version : xp has knackered my hd access speed


Dogpigboy
11-09-04, 10:19 AM
just installed xp on an older system. (c.1998)

Now, in device manager the quantumfireball (quantum yes -fireball no) hard disc is shown as PIO.

But when booting up it's displayed as udma2 capable.

Tried all the usual things lie uninstalling the ide controled with device manager, and a registry fix which forces xp to re-evaluate the devices capability but no joy.

Any suggestions - ide controller driver perhaps?

r2d2d3d4d5
11-09-04, 10:49 AM
Can you not select the transfer mode from IDE controller properties?

Dogpigboy
11-09-04, 12:17 PM
Can you not select the transfer mode from IDE controller properties?

That was the the first thing I tried. Current transfer mode remains obstinately stuck in PIO..

r2d2d3d4d5
11-09-04, 04:39 PM
Could this (http://support.microsoft.com/default.aspx?scid=kb;en-us;817472) be your problem? The fix is available as part of SP2.

Son Goku
11-09-04, 11:31 PM
Is there a mode setting in BIOS? Where you can manually set it to UDMA transfer mode, rather then let it auto-detect or go by plug and pray?

And yes, you should try SP2 if you haven't already.

Dogpigboy
11-10-04, 04:51 AM
Thanks chaps. I am running service pack 2 and the bios didn't have these options.

But problem solved!.. :)

I obtained a driver from Driver Guide for the ide controller - SIS PCI IDE controller- this replaces the one that win. xp sp2 installed and it all seems to work fine. Program manager reports hard disk running in udma2 and everything is considerably quicker.

Looks like a case of older hardware not running correctly with the driver that xp sp2 installed.