PDA

View Full Version : Refresh, NvCpl and CoolBits


zzonbi
11-17-04, 08:14 AM
The refresh rate defaults to 100 when I start W98. I want 75 wo manually changing it each time. What to do?

I noticed the bug happens when calling NvCpl.dll,NvStartup and only if the CoolBits are loaded (DWord=3). It is solved by erasing the CoolBits, but I need them for underclocking.

TIA

rewt
11-17-04, 08:17 AM
Go into Refresh rate overrides. Set your desired refresh rate of 75 for whatever resolution it is...

zzonbi
11-17-04, 07:54 PM
Go into Refresh rate overrides. Set your desired refresh rate of 75 for whatever resolution it is...

It doesn't work, starting the daemon points back to 'application controlled refresh rate'. Besides the frequency fields are corrupted and only display 'default'.

An older driver (53.03 vs 61.76) works well in XP. I guess it came with those bits enabled.

Tx for reply. Are you the author of the CoolBits? I tried finding a cooler value than 3, hoping to separate the OC/sliders from this stubborn refresh lock. What does each bit do?

rewt
11-17-04, 08:34 PM
Ok now I'm confused. What are you using Win98 or Win XP? :confused:

In XP you can override the desktop resolution. I know. I've tested it myself using the 67.xx series drivers.

The .reg file (for XP) is as follows..


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak\RefreshOverrides]
"EnableRefreshOverrides"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak\RefreshOverrides\1152x8 64]
"RefreshRate"=dword:0000004b
"Flags"=dword:00000007


For 98


REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak\RefreshOverrides]
"EnableRefreshOverrides"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\NVTweak\RefreshOverrides\1152x8 64]
"RefreshRate"=dword:0000004b
"Flags"=dword:00000007


This forces the 1152x864 resolution @ 75 Hz

zzonbi
11-17-04, 11:13 PM
I am using both. I have the problem in 98. I mentioned the XP because there everything is fine, despite using older drivers.

I see the registry changes are identical for both OSes. I guess the two spaces between 8 and 64 have no relevance. I entered those lines and still the same problem. However, the radio button sticks at 'Override refresh rates' now, but yet the pop down menus are corrupted and only show 'Default' when trying to expand it.

I would try older drivers, even if I wouldn't go back, but I have a feeling the problem would reiterate.

Tx for taking the time, it is really a minor problem after all, but we shouldn't let a driver be more stubborn than us ;)

rewt
11-17-04, 11:29 PM
Alright at least we are getting somewhere. :)

What resolution are you trying to use? Perhaps all we need to do now is adjust the reg file accordingly.

zzonbi
11-20-04, 07:32 AM
Alright at least we are getting somewhere. :)

What resolution are you trying to use? Perhaps all we need to do now is adjust the reg file accordingly.

I am using 800x600.

However, I am not so sure any more I want the newest drivers. I only have a GF2 MX400, and I read the drivers newer than 30.82 decrease performance with each generation ?! I like the new drivers' interface more, but I only really need color correction and overclocking features (and a correctly applicable refresh). I tried the custom resolutions and nothing works; also that keystone thingy.