View Full Version : Texture popping in HL2

11-18-04, 07:20 PM
I'm getting this weird texture "popping" effect in HL2. It happens on some objects, like in the trainstation in the big open hall where there's 2 people lining up to receive some clothes. There's the metal barred barrier things where they're lining up, and if I move away from them, they lose detail, like a bottom chunk of the barrier disappears. If i go right up to it, all the detail comes back on.

Edit: Found out that it's not actually the texture changing. It's actually switching model detail. At certain distances, the models switch to low quality. Close up it goes back to high quality.

Here's an example of another one. Just outside the trainstation, on the lamppost. One I reach a certain distance from it, the base of it becomes more detailed, and has more shadowing. Once I step back, it loses its detail.



I'm running BFG 6800GT OC oc'd to 415/1100, Forceware 67.02. 8xAA 8xAF

11-18-04, 07:24 PM
This is what AA and AF is used for. Turn it off and see how bad it is then :) Turn up to 16x and then you will see more detail further away but kills your FPS in HL2.

I think this is what you are talking about right?

11-18-04, 07:33 PM
It's not an AA or AF problem. The texture switch is basically on/off. It's like for example, I'm 6 ft. away from the post, and it looks fine. Then I move back 1 inch and the texture (and object) changes to a crappier model or something.

11-18-04, 07:43 PM
Mine kinda does the same, there is a point where things change as you come closer to them. I guess you could try HL2 on a Different computer??? Any friends playing it next door?

11-18-04, 07:49 PM
I'm noticing that its actually happening on more objects than I thought. Lampposts, barriers, light fixtures on the walls, that dispensing machine in the trainstation, the pillars on the trainstation steps. Its really annoying! On some objects there's more than one switch. Move back it switches once. Move back farther and then it degrades another notch. etc.

Switched back to 66.93 and it's still happening.

11-18-04, 07:50 PM
Sounds like your mip mapping isnt working good or somethin. Could just be this game but usually with mip mapping on it forces a higher quality image at longer distances if im correct.

Possibly try putting your quality options in nVpanel on High Quality and make sure all of the optimizations are off. And it woudlnt hurt to try a few drivers if that doesnt work.

gl to u

11-18-04, 09:21 PM
I noticed the exact same thing you are talking about and strangely with that lamp post. Stop worrying it is definately the game and not your card or drivers.

11-18-04, 09:23 PM
Maybe its just optimizations for the game..

11-18-04, 09:50 PM
After looking at some screenshot threads, I think everyone is probably having this issue, but just not noticing it. Anyways, I dig some digging around in the console commands and figured out a fix. Just input:

r_modellodscale 0

Before it was set to 1, which would cause the models to scale down detail the further away you were from it. Setting it to 0 disables it. Oh man, i'm so glad I figured this out, because it was really affecting me once i noticed it happening :rolleyes: . If you want it to default to 0, i think you can just put the command in the config.cfg like so: r_modellodscale "0"

11-18-04, 10:23 PM
Good find vpance.