PDA

View Full Version : Tweakguides take on the HL2 stuttering Problem


Superfly
11-19-04, 10:21 AM
Half Life 2 Update #3 - Additional Fix for Stuttering
18 November 2004


OK after a fair bit of experimentation, I believe I have found another cause of the constant stuttering on some systems. Go to Options in the game, and under the Mouse tab untick the 'Mouse Filter' setting. This has resolved a lot of random stuttering for me throughout the game (autosaving aside) in conjunction with the tweaks posted below. I believe the reason for this setting causing a problem is that on some motherboards it has issues with the Interrupts (IRQs) and causes CPU 'hiccups'. That's my guess anyway, but give it a try and let me know if it works for you.

LINK: http://www.tweakguides.com/

I have yet to try this as im at work - please post your results.

Superfly
11-19-04, 10:49 AM
I have a positive feeling about this as most of my stuttering takes place when moving the mouse........I wont hold my breath though.....

Superfly
11-19-04, 10:52 AM
does it work......anyone??

Arioch
11-19-04, 11:00 AM
I guess I am lucky that I do not have the stuttering problem in general. My main issue is the autosave glitch that many others have. I hope there is a fix for this at some point.

superklye
11-19-04, 11:27 AM
I'll give it a try today after class. I'm done at 1 (which is in 90 minutes)...I would try now but i have to write a paper for that class quick. :)

cambrian
11-19-04, 06:26 PM
ehhh...my mouse setting already has mouse filter unticked...But I am currently having the stuttering problem.

I just don't know anymore...

shinrai
11-21-04, 09:53 PM
I have a positive feeling about this as most of my stuttering takes place when moving the mouse........I wont hold my breath though.....


You funny. LoL.

kurt454
11-22-04, 07:27 AM
I guess I am lucky that I do not have the stuttering problem in general. My main issue is the autosave glitch that many others have. I hope there is a fix for this at some point.

I set my autosave files to 'read only' and that stopped that problem. You have to remember to hit f6 alot, though.

Vapor Trail
11-22-04, 10:14 AM
stuttering fix on the way

http://www.steampowered.com/forums/showthread.php?threadid=183832

Arioch
11-22-04, 10:52 AM
Sheesh - I will probably be done with the game by that time but a fix either way would be nice. Setting autosave to read-only helps a lot so at least I can control when I have to deal with the stuttering during a manual save.

saturnotaku
11-22-04, 11:25 AM
Setting autosave to read-only helps a lot so at least I can control when I have to deal with the stuttering during a manual save.

How do you do this? Auto save sucks anyway and if there's a way I can disable it all together that would be really helpful, stuttering issue aside.

Vagrant Zero
11-22-04, 12:09 PM
How do you do this? Auto save sucks anyway and if there's a way I can disable it all together that would be really helpful, stuttering issue aside.

Goto this folder on your main drive.

C:\Program Files\Valve\Steam\SteamApps\[your steam account name here]\half-life 2\hl2\SAVE

Find the autosave.sav, autosave01.sav, autosave.tga, autosave01.tga files. Right click on them and goto properties. Check the Read Only box. No more autosaving.

EciDemon
11-22-04, 12:24 PM
Or ... you could use the console command "sv_autosave 0" without quotes.

Arioch
11-22-04, 12:39 PM
I must be lucky then since the only issue I have is during saves - I do not notice any stuttering in the game besides that.

Riptide
11-22-04, 01:05 PM
Mine burps on occasion when not auto saving. I don't know why... 4xAA/8xAF 1600x1200. I'll turn a corner or something and it freezes for a split second. I've also had the sound screw up on me briefly as well. The game is by far still playable but this is a minor annoyance.